Install problem on Intel iMac...

Ask questions about your setup or get help installing ZCS server (ZD section below).
melmaninga
Posts: 3
Joined: Fri Sep 12, 2014 10:10 pm

Install problem on Intel iMac...

Postby melmaninga » Thu May 25, 2006 3:31 am

I'm currently in the process of setting up a pilot of Zimbra Network Edition, to see if it is worth deploying at my organisation. I pulled a brand new 20 iMac out of the box, updated the OS and installed Zimbra.
After following the "Quick Start" guide it would appear that some of my services are not running and I cannot get them started. I have checked the forums but no one seems to have similar issues installing on an Intel iMac.
I have no idea where to go to get things started. :confused:
Below is an excerpt when I check the status...


administrators-computer:~ zimbra$ zmcontrol status

Host zimbra.XXX.XXX.XXX

antispam Stopped

zmamavisdctl is not running

antivirus Stopped

zmamavisdctl is not running

ldap Running

logger Stopped

logmysql.server is not running

zmlogswatchctl is not running

mailbox Stopped

tomcat is not running

mysql.server is not running

mta Running

snmp Stopped

swatch is not running

spell Running


When I try and start the appropriate services...
administrators-computer:~ zimbra$ zmamavisdctl start

mount: /opt/zimbra/amavisd-new-2.3.3/tmp: unknown special file or file system.

administrators-computer:~ zimbra$ ERROR: MISSING REQUIRED BASIC MODULES:

Time::HiRes

Unix::Syslog

Compress::Zlib

BEGIN failed--compilation aborted at /opt/zimbra/amavisd/sbin/amavisd line 148.
administrators-computer:~ zimbra$ logmysql.server start

Logger appears not to be installed

administrators-computer:~ zimbra$ zmlogswatchctl start

administrators-computer:~ zimbra$ tomcat start

administrators-computer:~ zimbra$ mysql.server start

Error: assertion '-x /opt/zimbra/mysql/bin/mysqld_safe' failed
I still have "no joy"... :(
Host zimbra.XXX.XXX.XXX

antispam Stopped

zmamavisdctl is not running

antivirus Stopped

zmamavisdctl is not running

ldap Running

logger Stopped

logmysql.server is not running

zmlogswatchctl is not running

mailbox Stopped

tomcat is not running

mysql.server is not running

mta Running

snmp Stopped

swatch is not running

spell Running


Klug
Elite member
Elite member
Posts: 2352
Joined: Mon Dec 16, 2013 11:35 am
Contact:

Install problem on Intel iMac...

Postby Klug » Thu May 25, 2006 3:34 am

The errors seem to say it all : you're missing perl modules...

Time::HiRes, Unix::Syslog and Compress::Zlib are perl modules.
Is perl (and additionnal modules) setup on your Imac ?
9214mikez
Posts: 1
Joined: Fri Sep 12, 2014 10:11 pm

Install problem on Intel iMac...

Postby 9214mikez » Thu May 25, 2006 10:17 pm

Good luck, I hope you're able to resolve these issues and get Zimbra running.
However, if you try to completely uninstall the software, be aware that a couple of us Mac users have run into some system issues. Most notably, cron jobs will continue to run even if the zimbra user is deleted (these must be manually removed), CPU cycles will be eaten up by Spotlight until you manually reset the index, and your hard drive might not go sleep anymore on its own (mine doesn't).
I filed a bug on this issue (#7793)
http://www.zimbra.com/forums/showthread.php?t=1945
thread outlines some of the problems we've been having and the response from the support staff.
I also started a Wiki entry.
Hopefully these issues will get resolved soon.
melmaninga
Posts: 3
Joined: Fri Sep 12, 2014 10:10 pm

Install problem on Intel iMac...

Postby melmaninga » Sun May 28, 2006 4:08 am

[quote user="8141Klug"]The errors seem to say it all : you're missing perl modules...

Time::HiRes, Unix::Syslog and Compress::Zlib are perl modules.
Is perl (and additionnal modules) setup on your Imac ?[/QUOTE]
My understanding is that perl is already included with the OS. I assumed that everything I needed was already included with the OS or installed by the zimbra installer. I don't use perl so I am not familiar with the process of "activating/installing" it.
I installed the Developer Tools as well, but I still ended up with the same errors, when trying to start the Zimbra services... :(
What do I need to do to set-up perl??
melmaninga
Posts: 3
Joined: Fri Sep 12, 2014 10:10 pm

Install problem on Intel iMac...

Postby melmaninga » Sun May 28, 2006 4:10 am

[quote user="9214mikez"]Good luck, I hope you're able to resolve these issues and get Zimbra running.[/QUOTE]
Fortunately I am trying to set-up a pilot on a new machine. It was easier to blow it away and start with a fresh copy of the OS.
14319KevinH
Ambassador
Ambassador
Posts: 4558
Joined: Fri Sep 12, 2014 9:52 pm

Install problem on Intel iMac...

Postby 14319KevinH » Sun May 28, 2006 10:27 am

melmaninga -
Are you running the installer as root? Are there any errors in the install log(s)? You can see the logs in /tmp

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 2 guests