Initializing LDAP...Failed (256)

Ask questions about your setup or get help installing ZCS server (ZD section below).
iratik
Posts: 16
Joined: Fri Sep 12, 2014 10:23 pm

Initializing LDAP...Failed (256)

Postby iratik » Wed Jan 03, 2007 10:59 am



DNS ERROR - none of the MX records for com.c******s.com
resolve to this host
Done
Checking for port conflicts
Operations logged to /tmp/zmsetup.log.8158
Setting local config values...

Setting local config zimbra_server_hostname to com.c******s.com
*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_server_hostname=com.c******s.com
Setting local config ldap_master_url to ldap://com.c******s.com:389
*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_master_url=ldap://com.c******s.com:389
Setting local config ldap_url to ldap://com.c******s.com:389
*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_url=ldap://com.c******s.com:389
Setting local config ldap_port to 389
*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_port=389
Setting local config ldap_host to com.c******s.com
*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_host=com.c******s.com
Setting local config zimbra_uid to 1001
*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_uid=1001
Setting local config zimbra_gid to 1001
*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_gid=1001
Setting local config zimbra_user to zimbra
*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_user=zimbra
Setting local config av_notify_user to admin@com.c******s.com
*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e av_notify_user=admin@com.c******s.com
Setting local config ssl_allow_untrusted_certs to TRUE
*** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ssl_allow_untrusted_certs=TRUE
Done
Setting up CA...

*** Running as zimbra user: cd /opt/zimbra; zmcreateca
** Creating CA private key
Generating a 1024 bit RSA private key

.......++++++

.......++++++

unable to write 'random state'

writing new private key to '/opt/zimbra/ssl/ssl/ca/ca.key'

-----

** Creating CA cert
Signature ok

subject=/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite

Getting Private key

unable to write 'random state'

Done
Creating SSL certificate...

chmod: cannot access `/jre/lib/security/cacerts': No such file or directory

*** Running as zimbra user: cd /opt/zimbra; zmcreatecert
/opt/zimbra/bin/zmcreatecert: 27: source: not found

chmod: cannot access `/jre/lib/security/cacerts': No such file or directory

Done
Initializing ldap...

*** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
/opt/zimbra/bin/ldap: 32: source: not found

FAILED (256)

ERROR
Configuration failed

Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to

complete the configuration

On installing Zimbra Collaboration Suite 4.0 - Open Source Edition on Ubuntu 6.10 Edgy Server Edition on a fresh installation (Chose Bind9/DNS option) having setup a static network configuration and having verified it and having installed cURL, fetchmail, openssl, libxml2, libgmp3c2, libpcre3 and libidn11 and apt-get update and apt-get upgrade have both been run on a completely opened sources.list.
I had also linked

/usr/lib/libssl.so.0.9.7 to /usr/lib/libssl.so.0.9.8

and

/usr/lib/libcrypto.so.0.9.7 to /usr/lib/libcrypto.so.0.9.8
verified all zimbra ports open to the local machine 192.168.1.114

whereas durign OS setup the hostname was set as COM
I've tried installation on 3 different /etc/hosts configurations



127.0.0.1 localhost.localdomain localhost

127.0.0.1 com.c******s.com com



127.0.0.1 localhost.localdomain localhost

192.168.1.114 com.c******s.com com



127.0.0.1 localhost.localdomain localhost

75.44.237.46 com.c******s.com com

I get a message during setup saying my MX record is not configured for this hostname. An MX query for c******s.com will yield "com.c******s.com" and the hostname of the machine is com, I do not understand this message.
Searching the forums yields a variety of possible fixes. The first one (Unquotable 'See "Regarding LDAP Issues..." Regarding LDAP issues: - Zimbra - Forums) says that many users have had LDAP problems and provides a 'broken' link .

See

http://www.c******s.com:666/zimbra/LDAPGone.swf
Other
Resolutions include
[quote user="ContemporaryFusion"]I also have this error - although I am pretty sure this is due to me trying to use FC5's version of Zimbra on FC 6 :o
I'm about to play with a source download as I have nothing better to do on a Sunday :)
*** EDIT *** Solution:
as root:

visudo

comment out
#Defaults requiretty
Hope this helps you[/quote]

However does not specify which file to make the changes in.
Another fix only works on VMWare
[quote user="pheitman"]For some reason edgy made the default shell (/bin/sh) point to dash instead of bash. Apparently they are not quite the same, which causes the ldap initialization to fail. Since I was installing this on a VMWare VM, I could get away with
sudo rm /bin/sh

sudo ln -s /bin/bash /bin/sh
then uninstalling zimbra and reinstalling it. Now the installation works fine after following this fine guide.
Peter[/quote]


The only other reference was in this post with no reply
[quote user="dijichi2"]whoa, whats this?
Creating SSL certificate...

chmod: 无法访问‘/jre/lib/security/cacerts’: No such file or directory

*** Running as zimbra user: cd /opt/zimbra; zmcreatecert
/opt/zimbra/bin/zmcreatecert: 27: source: not found

chmod: 无法访问‘/jre/lib/security/cacerts’: No such file or directory

Done
Initializing ldap...

*** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
/opt/zimbra/bin/ldap: 32: source: not found

FAILED (256)
Are you running chinese version of linux?[/quote]
I've scoured the forums the wiki's and even asked in the chat rooms
|iratik> alright I did ./install -u and tried again with both the main WAN ip and the local 192.168 IP

|iratik> still Initializing LDAP...failed (256) Any IdeaS?

|reco> iratik: be sure you have mailserver.mydomain.com -> LAN ip in /etc/hosts

|iratik> thats the current setup

|iratik> 192.168.1.114 com.c******s.com com

|reco> reboot the box and try to install then

|iratik> and i'm sure the router is configured for 389 - > 192.168.1.114

|reco> open all ports

|iratik> Open all ports on the router to 192.168.1.114

|jodok> reco: switch to the zimbra user

|jodok> su - zimbra

|jodok> and start ldap manually

|iratik> how do you start ldap

|jodok> sudo /opt/zimbra/openldap-2.3.21/libexec/slapd -d7 -l LOCAL0 -4 -u zimbra -h ldap://yourhost.yourdomain.com:389 -f /opt/zimbra/conf/slapd.conf
Following his instructions I get



root@com:~/dl/zcs# su - zimbra

zimbra@com:~$ /opt/zimbra/openldap-2.3.21/libexec/slapd -d7 -l LOCAL0 -4 -u zimbra -h ldap://com.c******s.com:389 -f /opt/zimbra/conf/slapd.conf

@(#) $OpenLDAP: slapd 2.3.21 (Jul 14 2006 12:14:14) $

root@build-debian.liquidsys.com:/home/build/p4/main/ThirdParty/openldap/openldap-2.3.21/servers/slapd

daemon_init: ldap://com.c******s.com:389

daemon_init: listen on ldap://com.c******s.com:389

daemon_init: 1 listeners to open...

ldap_url_parse_ext(ldap://com.c******s.com:389)

daemon: bind(7) failed errno=13 (Permission denied)

slap_open_listener: failed on ldap://com.c******s.com:389

slapd stopped.

connections_destroy: nothing to destroy.

I don't know what to do about this I've tried everything and just can't seem to make sense of much. Wiki was a DeadEnd, Chat is sparse, Forums seem like the only option left.. Please Help!


iratik
Posts: 16
Joined: Fri Sep 12, 2014 10:23 pm

Initializing LDAP...Failed (256)

Postby iratik » Wed Jan 03, 2007 11:04 am

Noting that the configuration says MX lookup does not point to "com.c******s.com"



Checking 15 U.S. NameServers...

Domain: com.c******s.com
Domain Server: ns.mob.net

No MX found!
Domain Server: resolver.qwest.net

Destination: com.c******s.com.

Time To Live: 3568 seconds

Priority: 10

-------
Domain Server: vnsc-lc.sys.gtei.net

Destination: com.c******s.com.

Time To Live: 3572 seconds

Priority: 10

-------
Domain Server: ns-1.iastate.edu

Destination: com.c******s.com.

Time To Live: 3573 seconds

Priority: 10

-------
Domain Server: dns1.mci.com

No MX found!
Domain Server: ns1.us.prserv.net

Destination: com.c******s.com.

Time To Live: 3572 seconds

Priority: 10

-------
Domain Server: ns2.mindspring.com

Destination: com.c******s.com.

Time To Live: 3600 seconds

Priority: 10

-------
Domain Server: dns1.rcsntx.sbcglobal.net

Destination: com.c******s.com.

Time To Live: 3600 seconds

Priority: 10

-------
Domain Server: ns2.us.dellhost.com

Destination: com.c******scom.

Time To Live: 3573 seconds

Priority: 10

-------
Domain Server: ns3.earthlink.net

Destination: com.c******s.com.

Time To Live: 3573 seconds

Priority: 10

-------
Domain Server: ns.isi.edu

Destination: com.c******s.com.

Time To Live: 3573 seconds

Priority: 10

-------
Domain Server: ns1.super-dns.com

Destination: com.c******s.com.

Time To Live: 3573 seconds

Priority: 10

-------
Domain Server: ns1.sprintlink.net

Destination: com.c******s.com.

Time To Live: 3600 seconds

Priority: 10

-------
Domain Server: cache01.ns.uu.net

Destination: com.c******s.com.

Time To Live: 3600 seconds

Priority: 10

phoenix
Ambassador
Ambassador
Posts: 26674
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Initializing LDAP...Failed (256)

Postby phoenix » Wed Jan 03, 2007 11:24 am

The problem appears to be this:
DNS ERROR - none of the MX records for com.c******s.com
in your first post. If that's the domain name you're trying to use then it's broken. Have a look at this report. What you should be using for the domain name is c******s.com - look at this report that has the correct MX records.
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
iratik
Posts: 16
Joined: Fri Sep 12, 2014 10:23 pm

Initializing LDAP...Failed (256)

Postby iratik » Wed Jan 03, 2007 11:40 am

How do I get it so that the config looks for the MX for just c******s.com and not com.c******s.com ? Do I have to reinstall and not specify a hostname (don't think it'll let me) ? I'm just so confused about this concept more than anything because I thought no matter what all machines would have to have a hostname. Could you clear the confusion up for me.
What should i have in

/etc/hosts

/etc/hostname
phoenix
Ambassador
Ambassador
Posts: 26674
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Initializing LDAP...Failed (256)

Postby phoenix » Wed Jan 03, 2007 11:53 am

If this is a test server then the easiest thing to do is remove Zimbra completely by shuitting down (or killing) any running services, next uninstall it by running './install.sh -u'. Your hosts file should contain something like this:
127.0.0.1       localhost.localdomain   localhost

192.168.1.15 com.c******s.com com
Obviously your LAN IP needs to go in there.



When you've done that just do a reinstall and when you get to the final question about continuing then change the domain name there to 'c******s.com' - note that's the domain name not the server name. Once that's done you should have a working server.
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
iratik
Posts: 16
Joined: Fri Sep 12, 2014 10:23 pm

Initializing LDAP...Failed (256)

Postby iratik » Wed Jan 03, 2007 12:46 pm



root@com:~/dl/zcs# cat /etc/hosts

127.0.0.1 localhost

192.168.1.114 com.c******s.com com
# The following lines are desirable for IPv6 capable hosts

::1 ip6-localhost ip6-loopback

fe00::0 ip6-localnet

ff00::0 ip6-mcastprefix

ff02::1 ip6-allnodes

ff02::2 ip6-allrouters

ff02::3 ip6-allhosts

The installation yielded the following when i changed the name to c******s.com


DNS ERROR - none of the MX records for com.c******s.com

resolve to this host

Change domain name? [Yes] Yes

Create Domain: [com.c******s.com] c******s.com

MX: com.c******s.com (75.44.237.46)
Interface: 192.168.1.114

Interface: 127.0.0.1


DNS ERROR - none of the MX records for c******s.com

resolve to this host

It is suggested that the MX record resolve to this host

Re-Enter domain name? [Yes] No

Done

Checking for port conflicts

Main menu
1) Hostname: com.c******s.com

2) Ldap master host: com.c******s.com

3) Ldap port: 389

4) Ldap password: set

5) zimbra-ldap: Enabled

6) zimbra-store: Enabled

+Create Admin User: yes

+Admin user to create: admin@c******s.com

******* +Admin Password UNSET

+Enable automated spam training: yes

+Spam training user: imafj_e1@c******s.com

+Non-spam(Ham) training user: 20rf27hua8@c******s.com

+SMTP host: com.c******s.com

+Web server HTTP port: 80

+Web server HTTPS port: 443

+Web server mode: http

+Enable POP/IMAP proxy: no

+IMAP server port: 143

+IMAP server SSL port: 993

+POP server port: 110

+POP server SSL port: 995

+Use spell check server: yes

+Spell server URL: http://com.c******s.com:7780">http://com.c******s.com:7780">http://com.c******s.com:7780">http://com.c******s.com:7780 /aspell.php
7) zimbra-mta: Enabled

8) zimbra-snmp: Enabled

9) zimbra-logger: Enabled

10) zimbra-spell: Enabled

r) Start servers after configuration yes

s) Save config to file

x) Expand menu

q) Quit
Address unconfigured (**) items (? - help) 6


Store configuration
1) Status: Enabled

2) Create Admin User: yes

3) Admin user to create: admin@c******s.com

** 4) Admin Password UNSET

5) Enable automated spam training: yes

6) Spam training user: imafj_e1@c******s.com

7) Non-spam(Ham) training user: 20rf27hua8@c******s.com

8) SMTP host: com.c******s.com

9) Web server HTTP port: 80

10) Web server HTTPS port: 443

11) Web server mode: http

12) Enable POP/IMAP proxy: no

13) IMAP server port: 143

14) IMAP server SSL port: 993

15) POP server port: 110

16) POP server SSL port: 995

17) Use spell check server: yes

18) Spell server URL: http://com.c******s.com:7780">http://com.c******s.com:7780">http://com.c******s.com:7780">http://com.c******s.com:7780 /aspell.php
Select, or 'r' for previous menu [r] 4
Password for admin@c******s.com (min 6 characters): [jtA9_Y4P] com.c******s .com
Store configuration
1) Status: Enabled

2) Create Admin User: yes

3) Admin user to create: admin@c******s.com

4) Admin Password set

5) Enable automated spam training: yes

6) Spam training user: imafj_e1@c******s.com

7) Non-spam(Ham) training user: 20rf27hua8@c******s.com

8) SMTP host: com.******s..com

9) Web server HTTP port: 80

10) Web server HTTPS port: 443

11) Web server mode: http

12) Enable POP/IMAP proxy: no

13) IMAP server port: 143

14) IMAP server SSL port: 993

15) POP server port: 110

16) POP server SSL port: 995

17) Use spell check server: yes

18) Spell server URL: http://com.c******s.com:7780">http://com.c******s.com:7780">http://com.c******s.com:7780">http://com.c******s.com:7780 /aspell.php
Select, or 'r' for previous menu [r] r
Main menu
1) Hostname: com.c******s.com

2) Ldap master host: com.c******s.com

3) Ldap port: 389

4) Ldap password: set

5) zimbra-ldap: Enabled

6) zimbra-store: Enabled

7) zimbra-mta: Enabled

8) zimbra-snmp: Enabled

9) zimbra-logger: Enabled

10) zimbra-spell: Enabled

r) Start servers after configuration yes

s) Save config to file

x) Expand menu

q) Quit
*** CONFIGURATION COMPLETE - press 'a' to apply

Select from menu, or press 'a' to apply config (? - help) a

Save configuration data to a file? [Yes] No

The system will be modified - continue? [No] Yes

Operations logged to /tmp/zmsetup.log.12452

Setting local config values...Done

Setting up CA...Done

Creating SSL certificate...Done

Initializing ldap...FAILED (256)


ERROR
So with that in mind, what else can I do?
phoenix
Ambassador
Ambassador
Posts: 26674
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Initializing LDAP...Failed (256)

Postby phoenix » Wed Jan 03, 2007 1:14 pm

From your zimbra server, waht do the following give you?
host `hostname`

dig all c******s.com
Note the host command has backticks not quotes. Post the details of the commands.
I should also have said that this report shows an error for your MX record that needs fixing.
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
iratik
Posts: 16
Joined: Fri Sep 12, 2014 10:23 pm

Initializing LDAP...Failed (256)

Postby iratik » Wed Jan 03, 2007 1:19 pm



root@com:~/dl/zcs# host `hostname`

root@com:~/dl/zcs# dig all c******s.com

;; Got answer:

;; ->>HEADER<
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; QUESTION SECTION:

;all. IN A
;; Query time: 148 msec

;; SERVER: 66.93.87.2#53(66.93.87.2)

;; WHEN: Wed Jan 3 19:18:47 2007

;; MSG SIZE rcvd: 21


; <<>> DiG 9.3.2 <<>> all c******s.com

;; global options: printcmd

;; Got answer:

;; ->>HEADER<
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;; QUESTION SECTION:

;c******s.com. IN A
;; ANSWER SECTION:

c******s.com. 3600 IN A 75.44.237.46
;; Query time: 204 msec

;; SERVER: 66.93.87.2#53(66.93.87.2)

;; WHEN: Wed Jan 3 19:18:47 2007

;; MSG SIZE rcvd: 46
jholder
Zimbra Employee
Zimbra Employee
Posts: 4686
Joined: Fri Sep 12, 2014 10:00 pm

Initializing LDAP...Failed (256)

Postby jholder » Wed Jan 03, 2007 4:40 pm

You need to add an MX record to the DNS Servers.
iratik
Posts: 16
Joined: Fri Sep 12, 2014 10:23 pm

Initializing LDAP...Failed (256)

Postby iratik » Wed Jan 03, 2007 4:51 pm

An MX Record is on the DNS Servers for the domain


c0@com:~$ dig c******s.com mx
; <<>> DiG 9.3.2 <<>> c******s.com mx

;; global options: printcmd

;; Got answer:

;; ->>HEADER<
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;; QUESTION SECTION:

;c******s.com. IN MX
;; ANSWER SECTION:

c******s.com. 3430 IN MX 10 com.c******s.com.
;; Query time: 458 msec

;; SERVER: 66.93.87.2#53(66.93.87.2)

;; WHEN: Wed Jan 3 22:48:44 2007

;; MSG SIZE rcvd: 50



DNS ERROR resolving MX for com.c******s.com

It is suggested that the domain name have an MX record configured in DNS

Re-Enter domain name? [Yes] Yes

Create Domain: [com.c******s.com] c******s.com

MX: com.c******s.com (75.44.237.46)
Interface: 192.168.1.114

Interface: 127.0.0.1


DNS ERROR - none of the MX records for c******s.com

resolve to this host

It is suggested that the MX record resolve to this host


Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 9 guests