Initializing LDAP...Failed (256)

Ask questions about your setup or get help installing ZCS server (ZD section below).
phoenix
Ambassador
Ambassador
Posts: 26693
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Initializing LDAP...Failed (256)

Postby phoenix » Thu Jan 04, 2007 2:16 am

When you did the "host `hostname`" it seemd to return nothing, is that correct? What's in your /etc/hosts file now? It should have the entries I mentioned above, namely:
127.0.0.1       localhost.localdomain   localhost

192.168.1.15 com.c******s.com com
is that what you've got?
This line
c******s.com.           1980    IN      A       75.44.237.46
is also wrong it should be the hostname that's in there not the domain name, it should read
com.c******s.com.           1980    IN      A       75.44.237.46
.


Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
iratik
Posts: 16
Joined: Fri Sep 12, 2014 10:23 pm

Initializing LDAP...Failed (256)

Postby iratik » Thu Jan 04, 2007 9:34 am

[quote user="iratik"]


root@com:~/dl/zcs# cat /etc/hosts

127.0.0.1 localhost

192.168.1.114 com.c******s.com com
# The following lines are desirable for IPv6 capable hosts

::1 ip6-localhost ip6-loopback

fe00::0 ip6-localnet

ff00::0 ip6-mcastprefix

ff02::1 ip6-allnodes

ff02::2 ip6-allrouters

ff02::3 ip6-allhosts

[/quote]

My /etc/hosts file still looks as it did several posts ago, exactly to your specification.


However, as far as the @ records for the main domain. I am forced to use a hosted user interface rather than manually editing the configuration, hence - this is what I'm left with. What needs to be changed?

 http://www.ctatechs.com:666/zimbra/dns.gif />
As far as the LDAP issue .. The link that wannabeatenor provided finally worked and I was easily able to find a solution to get LDAP initialized. (The link had been down so far)
Ubuntu 6.10 LDAP Startup Solution
This applies to running the Debian build on Ubuntu, not the Ubuntu build
LDAP startup ... FAILED (256) on UBUNTU 6.10
1 UBUNTU by default symlinks /bin/sh to /bin/dash which does not support the 'source' command.
To fix

rm /bin/sh

ln -s bash /bin/sh
2 UBUNTU Server distro does not have a Java runtime, the certification startup
The zimbra installer requires the java runtime in the /jre directory.

Zimbra has a JRE available so simply a second symlink will solve the problem

To fix:

ln -s /opt/zimbra/jdk1.5.0_08/jre /jre
phoenix
Ambassador
Ambassador
Posts: 26693
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Initializing LDAP...Failed (256)

Postby phoenix » Thu Jan 04, 2007 10:13 am

[quote user="iratik"]My /etc/hosts file still looks as it did several posts ago, exactly to your specification.[/quote]No, that's not what I told you to put in there. This is what I sadi you should have:
127.0.0.1       localhost.localdomain   localhost

192.168.1.15 com.c******s.com com
In this image:

 http://www.ctatechs.com:666/zimbra/dns.gif />

(for the host record) can you edit the first column for the entry 'com', try changing it to com.c******s.com and see if that shows correctly when you do a dig.Check it with 'dig c******s.com' after you've made the changes and see if it shows correctly. I really do dislike these DNS providers that don't give you complete control over the records.:(
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
iratik
Posts: 16
Joined: Fri Sep 12, 2014 10:23 pm

Initializing LDAP...Failed (256)

Postby iratik » Thu Jan 04, 2007 12:24 pm

Well there are differences between the hosts file you specified and what i have, the LAN address of the machine that zimbra is running is 192.168.1.114 not 192.168.1.15 , and there is IPV6 information appended by the operating system.. should i modify the machine's IP to be 192.168.1.15 ?
As far as the DNS setup.. I'm not so sure its completely off. If you do dig com.c******s.com you get the records you are looking for. So what to do?
phoenix
Ambassador
Ambassador
Posts: 26693
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Initializing LDAP...Failed (256)

Postby phoenix » Thu Jan 04, 2007 12:34 pm

[quote user="iratik"]Well there are differences between the hosts file you specified and what i have, the LAN address of the machine that zimbra is running is 192.168.1.114 not 192.168.1.15 , and there is IPV6 information appended by the operating system.. should i modify the machine's IP to be 192.168.1.15 ?[/quote]No, of course you don't modify the local LAN IP address - I mentioned that earlier. The problem is your 127.0.0.1 details, they're the ones that need changing.
[quote user="iratik"]As far as the DNS setup.. I'm not so sure its completely off.[/quote]Yes, it is.
[quote user="iratik"]If you do dig com.c******s.com you get the records you are looking for.[/quote]What you are doing here is a dig lookup for a DOMAIN NAME, that name is the FQDN of your Zimbra server and is made up of the host name i.e. com then your domain name i.e. c******s.com that gives you a FQDN of com.c******s.com The dig you've done on com.c******s.com and contains no MX records because it is the WRONG name. You domain name is c******s.com and it should contain the MX records (pointing to the FQDN of your server) but the MX record in that domain name is incorrect and needs fixing. The
[quote user="iratik"]So what to do?[/quote]Read the forums thread on 'DNS in a nutshell', it describes the required DNS records then make the changes to your config. All these problems are caused by incorrect DNS records.
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
iratik
Posts: 16
Joined: Fri Sep 12, 2014 10:23 pm

Initializing LDAP...Failed (256)

Postby iratik » Thu Jan 04, 2007 12:49 pm

Thanks for the help Bill, I can't believe I couldn't see the problems with the 127.0.0.1 record this whole time! I'll read up on the DNS because it really is something I've never completely grasped.
phoenix
Ambassador
Ambassador
Posts: 26693
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Initializing LDAP...Failed (256)

Postby phoenix » Thu Jan 04, 2007 12:53 pm

Don't be put off by DNS, at the level we're configuring it for Zimbra it really is simple. When you've read the thread then post again if you have any questions.
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
cibercol
Posts: 1
Joined: Fri Sep 12, 2014 10:16 pm

Initializing LDAP...Failed (256)

Postby cibercol » Sat Feb 17, 2007 10:24 pm

Creating SSL certificate...Done

Initializing ldap...daemon: bind(7) failed errno=99 (Cannot assign requested ad ress)

slap_open_listener: failed on ldap://yourdomain.com:389

ERROR - failed to start slapd


Solution:
in yourdomainzone

yourdomain.com. IN A 127.0.0.1 ; IP address for the domain


sample for bind9 and ubuntu edgy
yourdomain.com zone
;

; Zone File for "yourdomain.com" - Internal Use ONLY

;

$TTL 1D

@ IN SOA nameserver.yourdomain.com. sysadmin.yourdomain.com. (

10 ; Serial

8H ; Refresh

2H ; Retry

4W ; Expire

1D ) ; Minimum

;

IN NS nameserver ; Name Server for the domain

IN MX 10 nameserver ; Mail Exchange

IN MX 10 mail ; Mail Exchange

;

yourdomain.com. IN A 127.0.0.1 ; IP address for the domain

nameserver IN A 192.168.0.223 ; IP address for 'snombres'

mail IN A 127.0.0.1 ; IP address for 'snombres'

;www IN CNAME snombres ; 'snombres' is also known as www

ftp IN CNAME snombres ; 'snombres' is also known as ftp

;

wkstn1 IN A 192.168.0.16 ; MANUAL IP address entry for 'wkstn1'
reverse zone: (reverse-192.168.0)
;

; Reverse File for network "192.168.0.0/24" - Internal ONLY

;

$TTL 1D

@ IN SOA nameserver.yourdomain.com. sistemas.yourdomain.com. (

10 ; Serial

8H ; Refresh

2H ; Retry

4W ; Expire

1D ) ; Minimum

;

IN NS nameserver.yourdomain.com.

4 IN PTR nameserver.yourdomain.com.

;

16 IN PTR wkstn1.yourdomain.com. ; entrada MANUAL para 'wkstn1' reverse delegation


configuration for /etc/bind/named.conf.local
//

// Do any local configuration here

//
// Consider adding the 1918 zones here, if they are not used in your

// organization

//include "/etc/bind/zones.rfc1918";
zone "yourdomain.com" IN {

type master;

file "data/yourdomain.com";

allow-update { none; };

};
zone "0.168.192.in-addr.arpa" IN {

type master;

file "data/reverse-192.168.0";

allow-update { none; };

};
jerryboi
Advanced member
Advanced member
Posts: 124
Joined: Fri Sep 12, 2014 10:09 pm

Initializing LDAP...Failed (256)

Postby jerryboi » Mon Feb 26, 2007 5:54 pm

[quote user="10330phoenix"] ...at the level we're configuring it for Zimbra it really is simple. When you've read the thread then post again if you have any questions.[/QUOTE]
I did read DNS in a nutshell, read up on dns, but this stuff is still beyond me. This thread helped me a lot, I managed to install zimbra, It's up and running (I can't log in just yet, though)
If anybody could answer my lamer questions, it'd be very much appreciated.

First, a theoretical one: why did phoenix ask for a host `hostname` ?

I thought the hostname is just a hostname and not a FQDN, and thus it can't be resolved. In my case:

jerryboi@always:~> host `hostname`

Host always not found: 3(NXDOMAIN)
And secondly, a practical one: Why does pingability and zimbra install (see below) agree on my host not having an A record? I set the A record (for this host as well as for @) on the very same green interface that Iratik used (of one of those dns providers that Phoenix disliked). It is set, thus host command resolves my server name, digging brings back

$ dig always.ringstwice.net
; <<>> DiG 9.3.4 <<>> always.ringstwice.net

;; global options: printcmd

;; Got answer:

;; ->>HEADER<
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0
;; QUESTION SECTION:

;always.ringstwice.net. IN A
;; ANSWER SECTION:

always.ringstwice.net. 222 IN A 195.70.35.236
;; AUTHORITY SECTION:

ringstwice.net. 222 IN NS park32.secureserver.net.

ringstwice.net. 222 IN NS park31.secureserver.net.
;; Query time: 53 msec

;; SERVER: 127.0.0.1#53(127.0.0.1)

;; WHEN: Tue Feb 27 00:05:33 2007

;; MSG SIZE rcvd: 110
which I would have thought was an A record.
And here's the zimbra install:
always:/home/pc/zcs # /opt/zimbra/libexec/zmsetup.pl

Operations logged to /tmp/zmsetup.log.10096

Setting defaults...
DNS ERROR resolving MX for always.ringstwice.net

It is suggested that the domain name have an MX record configured in DNS

Change domain name? [Yes] y

Create Domain: [always.ringstwice.net] ringstwice.net

Warning: no 'A' record found for always.ringstwice.com
Interface: 195.70.35.236

Interface: 127.0.0.1

Warning: no 'A' record found for always.ringstwice.com

Warning: no 'A' record found for always.ringstwice.com
DNS ERROR - none of the MX records for ringstwice.net

resolve to this host

It is suggested that the MX record resolve to this host

Re-Enter domain name? [Yes] n
This is anything but simple.
phoenix
Ambassador
Ambassador
Posts: 26693
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Initializing LDAP...Failed (256)

Postby phoenix » Tue Feb 27, 2007 1:53 am

[quote user="jerryboi"]First, a theoretical one: why did phoenix ask for a host `hostname` ?

I thought the hostname is just a hostname and not a FQDN, and thus it can't be resolved. In my case:

jerryboi@always:~> host `hostname`

Host always not found: 3(NXDOMAIN)[/QUOTE]He asked for that becase it would have shown if your hosts file was correct. The output from that command would have been something like 'fqdn has IP 192.168.x.x' In you case it looks like the /etc/hosts file is incorrect, can you post the details?
[quote user="jerryboi"]And secondly, a practical one: Why does pingability and zimbra install (see below) agree on my host not having an A record? I set the A record (for this host as well as for @) on the very same green interface that Iratik used (of one of those dns providers that Phoenix disliked). It is set, thus host command resolves my server name, digging brings back

$ dig always.ringstwice.net
; <<>> DiG 9.3.4 <<>> always.ringstwice.net

;; global options: printcmd

;; Got answer:

;; ->>HEADER<
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0
;; QUESTION SECTION:

;always.ringstwice.net. IN A
;; ANSWER SECTION:

always.ringstwice.net. 222 IN A 195.70.35.236
;; AUTHORITY SECTION:

ringstwice.net. 222 IN NS park32.secureserver.net.

ringstwice.net. 222 IN NS park31.secureserver.net.
;; Query time: 53 msec

;; SERVER: 127.0.0.1#53(127.0.0.1)

;; WHEN: Tue Feb 27 00:05:33 2007

;; MSG SIZE rcvd: 110
which I would have thought was an A record.
And here's the zimbra install:
always:/home/pc/zcs # /opt/zimbra/libexec/zmsetup.pl

Operations logged to /tmp/zmsetup.log.10096

Setting defaults...
DNS ERROR resolving MX for always.ringstwice.net

It is suggested that the domain name have an MX record configured in DNS

Change domain name? [Yes] y

Create Domain: [always.ringstwice.net] ringstwice.net

Warning: no 'A' record found for always.ringstwice.com
Interface: 195.70.35.236

Interface: 127.0.0.1

Warning: no 'A' record found for always.ringstwice.com

Warning: no 'A' record found for always.ringstwice.com
DNS ERROR - none of the MX records for ringstwice.net

resolve to this host

It is suggested that the MX record resolve to this host

Re-Enter domain name? [Yes] n[/QUOTE]What you have here is a 'dig' command for which you've entered a 'domain' name "always.ringstwice.net" - that is actually a sub-domain (although from the set-up I guess it's the FQDN of your server?). When the Zimbra install runs you are asked for the domain name and you change it to 'ringstwice.net' - that's correct, it is a domain name but it has incorrect DNS records and that's why it borks the install.
[quote user="jerryboi"]This is anything but simple.[/QUOTE]I disagree, as a complete newcomer to Linux I managed to set it up - that's what I base my 'simple' comment on.:D
OK, I think there's possible a misunderstanding of terminology here. You have a server called 'fred' and you have a domain called 'domain.com', the fully qualified domain name (FQDN) of your Zimbra server will be 'fred.domain.com' and your hosts file will look like:
127.0.0.1 localhost.localdomain localhost

192.168.x.x fred.domain.com fred
You will need DNS A & MX records pointing to your server, the domain name will be domain.com and the server FQDN will be fred.domain.com
Does that help you understand what I've posted previously?
BTW, it's not the DNS hosting providers I dislike (I use one myself) - it's the fact that some of them don't give you full control over all your DNS records.
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 8 guests