[SOLVED] i really need help for configuring split dns

Ask questions about your setup or get help installing ZCS server (ZD section below).
16616hercules
Posts: 8
Joined: Fri Sep 12, 2014 10:45 pm

[SOLVED] i really need help for configuring split dns

Postby 16616hercules » Wed Sep 26, 2007 2:37 pm

Hello all,
i tried 3 long days to get "split dns" work, but with no success. The result is that can send mails, or receive mails, but no both.
I installed Zimbra successfully and zmcontrol repports that all systems are running correct. Also the installes named seems to run, but the setup is not correct, because sending and receiving will not work at same time. I need to change the MTA Hostname in the web admin-interface.
My TCP-Data:
I use a router wit NAT firewall.
Router IP 192.168.178.1

Nameserver Networkcard IP: 192.168.178.5

Hostname namserver: mailserver.sinsheim-wetter.de

mail-domain which will need for mail addresses: sinsheim.wetter.de

External IP: 194.231.187.137

System is Suse 10.2

Zimbra is the current open source release
Here is my current named config. Could you have a look for any errors please?

// Default named.conf generated by install of bind-9.2.4-2

options {

directory "/var/bin/named";

dump-file "/var/bin/named/data/cache_dump.db";

statistics-file "/var/named/data/named_stats.txt";

forwarders { 192.168.178.1 ; };

};

include "/etc/rndc.key";

// We are the master server for server.example.com

zone "mailserver.sinsheim-wetter.de" {

type master;

file "db.mailserver.sinsheim-wetter.de";

};


/var/bin/named/db.mailserver.sinsheim-wetter.de:


; Addresses and other host information.

;

@ IN SOA sinsheim-wetter.de. hostmaster.sinsheim-wetter.de. (

10118 ; Serial

43200 ; Refresh

3600 ; Retry

3600000 ; Expire

2592000 ) ; Minimum

; Define the nameservers and the mail servers

IN NS

IN A

IN MX 10 mailserver.sinsheim-wetter.de.
Off course the mx entries for sinsheim-wetter.de on the namserver at my provider is set correctly! When i use MS-Exchange, all works well without problems. Just with Zimbra i have this trouble.


Iam really not sure whats wrong and i have search the whole web and forum, but nothing does work.
Thanks for you assistance
Thomas


dwmtractor
Outstanding Member
Outstanding Member
Posts: 993
Joined: Fri Sep 12, 2014 10:41 pm

[SOLVED] i really need help for configuring split dns

Postby dwmtractor » Wed Sep 26, 2007 2:56 pm

Thomas, this may not be your only problem, but this line
[quote user="16616hercules"]

forwarders { 192.168.178.1 ; };

[/quote]

is pointing to the address you said is your router address. Unless you have your router configured as a DNS proxy, that won't work. The forwarders have to be DNS to whom bind can direct queries that it does not have the answer for. . .in my case they are the DNS servers provided to me by my ISP.
You might take a look at this wiki article I wrote on installing to Ubuntu. I go over the installation and configuration of bind9 step-by-step, and at least for me these steps worked.
HTH,
Dan
16616hercules
Posts: 8
Joined: Fri Sep 12, 2014 10:45 pm

[SOLVED] i really need help for configuring split dns

Postby 16616hercules » Thu Sep 27, 2007 4:39 am

ok..thanks for the first.
Do you tihnk, that the other config values are correct so it should work, or there are may another errors in thies configs that could make trouble?
Thomas
apatosaur.9
Posts: 31
Joined: Fri Sep 12, 2014 10:07 pm

[SOLVED] i really need help for configuring split dns

Postby apatosaur.9 » Thu Sep 27, 2007 6:41 am

Hi
I think your problem is that you are using "mailserver.sinsheim-wetter.de"

zone "mailserver.sinsheim-wetter.de"

as your domain, instead of using "sinsheim-wetter.de"

so change in your named.conf or named.conf.inc

// We are the master server for server.example.com

zone "sinsheim-wetter.de" {

type master;

file "db.mailserver.sinsheim-wetter.de";

};


then you'd rather have in your zone file

@ IN SOA sinsheim-wetter.de. hostmaster.sinsheim-wetter.de. (

10118 ; Serial

43200 ; Refresh

3600 ; Retry

3600000 ; Expire

2592000 ) ; Minimum
IN NS 192.168.178.5
IN MX 10 mailserver.sinsheim-wetter.de.
IN A 192.168.178.5
mailserver.sinsheim-wetter.de. IN A 194.231.187.137 ; notice the "." at end of 'de.'


regards
Mac :)
530randall
Advanced member
Advanced member
Posts: 191
Joined: Fri Sep 12, 2014 10:38 pm

[SOLVED] i really need help for configuring split dns

Postby 530randall » Thu Sep 27, 2007 6:42 am

what do you have in your /etc/hosts?
16616hercules
Posts: 8
Joined: Fri Sep 12, 2014 10:45 pm

[SOLVED] i really need help for configuring split dns

Postby 16616hercules » Thu Sep 27, 2007 8:23 am

hello togther,
i changed all like your told me. Iam not sure its correct, because i havent install Zimbra yes, since it should be only installed when Split Dns is working.
When i type nslookup sinsheim-wetter.de i get "server cabt find sinsheim-wetter.de". Just the same with mailserver.sinsheim-wetter.de.
When i ping sinsheim-wetter.de i get "unknown host". and with mailserver.sinsheim-wetter.de i get a response with 192.168.178.5
Iam not so sure, but the nslookup schouls respone the internal IP...or?
In my host is
127.0.0.1 localhost.localdomain localhost
192.168.178.5 mailserver.sinsheim-wetter.de mailserver


in my resolv.conf:

nameserver 192.168.178.5

search sinsheim-wetter.de
Any further ideas?
Thomas
soxfan
Outstanding Member
Outstanding Member
Posts: 958
Joined: Fri Sep 12, 2014 10:08 pm

[SOLVED] i really need help for configuring split dns

Postby soxfan » Thu Sep 27, 2007 9:27 am

The first question I would ask is are you sure the DNS server (named) is running? Check the system processes to be sure it is. If it's not running then you need to start it. If it is running then I'd try stopping and starting it, and then look at the system logs, which should give you some information is things aren't configured properly.
16616hercules
Posts: 8
Joined: Fri Sep 12, 2014 10:45 pm

[SOLVED] i really need help for configuring split dns

Postby 16616hercules » Thu Sep 27, 2007 9:49 am

hi,
yes named is running! The logs shows no errors.
But im not sure about the following:
When i configure a zone in named.conf i must create the zone file. Does named check this file exits? I ask, because when i delete this zone file, named is starting without errors about the not existing zone file.
soxfan
Outstanding Member
Outstanding Member
Posts: 958
Joined: Fri Sep 12, 2014 10:08 pm

[SOLVED] i really need help for configuring split dns

Postby soxfan » Thu Sep 27, 2007 10:20 am

I don't know SuSe that well, but it's possible that the system is running a chroot version of BIND. Search your system for other occurrences of the named.conf file. Also look in the system logs for any references to what named.conf file is being read.
16616hercules
Posts: 8
Joined: Fri Sep 12, 2014 10:45 pm

[SOLVED] i really need help for configuring split dns

Postby 16616hercules » Fri Sep 28, 2007 11:23 am

hi..thanks a lot. After many hours of testiings i found a working solution.

Zimbra works fine now
Thomas

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 7 guests