[Solved] Upgrade from GA 8.0.6 to 8.5.0 fails

Ask questions about your setup or get help installing ZCS server (ZD section below).
sononaco
Posts: 10
Joined: Fri Sep 12, 2014 11:35 pm

[Solved] Upgrade from GA 8.0.6 to 8.5.0 fails

Postby sononaco » Wed Sep 17, 2014 5:56 pm

As the title states I have tried upgrading from 8.0.6 GA to 8.5. During the upgrade the routine fails leaving my Zimbra installation broken (thank goodness for backups). The system is CentOS 6.5 (Final).
The specific error point of failure is here (bolded in the log below):
Wed Sep 17 04:34:07 2014 Upgrading from  to 8.5.0_GA_3042
Wed Sep 17 04:34:07 2014 ERROR: Upgrading from a ZCS version less than 6.0.0_GA is not supported
Here is the output from the log:
Wed Sep 17 04:34:06 2014 Operations logged to /tmp/zmsetup09172014-043406.log
Wed Sep 17 04:34:06 2014 *** Running as zimbra user: /opt/zimbra/libexec/zmldapschema 2>/dev/null
Looking for LDAP installation...succeeded
Installing core schema...
Installing cosine schema...
Installing inetOrgPerson schema...
Installing zimbra schema...
Installing amavis schema...
Installing dyngroup schema...
Installing OpenDKIM schema...
Installing PGP schema...
Wed Sep 17 04:34:07 2014 Determining installed web applications
Wed Sep 17 04:34:07 2014 Web application service is enabled.
Wed Sep 17 04:34:07 2014 Web application zimbra is enabled.
Wed Sep 17 04:34:07 2014 Web application zimbraAdmin is enabled.
Wed Sep 17 04:34:07 2014 Web application zimlet is enabled.
Wed Sep 17 04:34:07 2014 Upgrading from  to 8.5.0_GA_3042
Wed Sep 17 04:34:07 2014 ERROR: Upgrading from a ZCS version less than 6.0.0_GA is not supported
Wed Sep 17 04:34:07 2014 UPGRADE FAILED - exiting.
Any help is greatly appreciated!


User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2778
Joined: Thu May 22, 2014 4:47 pm

Upgrade from GA 8.0.6 to 8.5.0 fails

Postby jorgedlcruz » Wed Sep 17, 2014 6:14 pm

Hi sononaco,

Are you using the proper package or update? - http://files2.zimbra.com/downloads/8.5.0_GA/zcs-8.5.0_GA_3042.RHEL6_64.20140828192005.tgz



Could you please first Update to 8.0.7 - http://files2.zimbra.com/downloads/8.0.7_GA/zcs-8.0.7_GA_6021.RHEL6_64.20140408123911.tgz and then upgrae to 8.5.0?



I've give to you the links for Open Source Edition, I assume that is the version that you are using.



Best regards, tell us if works !
Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
sononaco
Posts: 10
Joined: Fri Sep 12, 2014 11:35 pm

Upgrade from GA 8.0.6 to 8.5.0 fails

Postby sononaco » Thu Sep 18, 2014 10:15 am

When I try to upgrade to 8.0.7 it tells me that I am already upgraded to 8.5.0, even though on the admin screen it shows 8.0.6. And yes, I am using the RHEL6 package.
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2778
Joined: Thu May 22, 2014 4:47 pm

Upgrade from GA 8.0.6 to 8.5.0 fails

Postby jorgedlcruz » Thu Sep 18, 2014 11:38 am

Do a zmcontrol -v and paste us the result. You told us that the process fail and you use your Backup, it was this backup a Snapshot so you revert everything?



Best regards
Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
sononaco
Posts: 10
Joined: Fri Sep 12, 2014 11:35 pm

Upgrade from GA 8.0.6 to 8.5.0 fails

Postby sononaco » Thu Sep 18, 2014 4:33 pm

zmcontrol -v:



Release 8.5.0_GA_3042.RHEL6_64_20140828192005 RHEL6_64 FOSS edition.



Just a backup of the zimbra folder. We don't have the ability to take snapshots, unfortunately.
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2778
Joined: Thu May 22, 2014 4:47 pm

Upgrade from GA 8.0.6 to 8.5.0 fails

Postby jorgedlcruz » Thu Sep 18, 2014 5:23 pm

Hi sononaco,

Looks like you are already in the last version, but are you system working propertly, or it isn't? Do you have web access? Best regards!
Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
comara
Posts: 5
Joined: Sat Sep 13, 2014 3:17 am

Upgrade from GA 8.0.6 to 8.5.0 fails

Postby comara » Tue Sep 23, 2014 4:01 pm

I ran into this same issue as well. The problem is that the formatting of /opt/zimbra/.install_history was corrupted. Look here for the correct formatting: http://wiki.zimbra.com/wiki/Upgrade:_Unable_to_find_initial_version



I was able to edit the file by hand and reinstall successfully.
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2778
Joined: Thu May 22, 2014 4:47 pm

Upgrade from GA 8.0.6 to 8.5.0 fails

Postby jorgedlcruz » Wed Sep 24, 2014 5:26 am

Thank you comara, your help is very appreciated, I'm pretty sure that will help to other people !



Best regards
Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
dlbewley
Advanced member
Advanced member
Posts: 82
Joined: Fri Sep 12, 2014 10:15 pm

Upgrade from GA 8.0.6 to 8.5.0 fails

Postby dlbewley » Fri Jan 02, 2015 12:21 am

I hit this when trying to do a test install of 8.5.0 using a modified defaultsfile (`./install.sh config.xxx`), which I gleaned from my first test server.



The install bombed when it go to the setup phase, after editing `.install_history` as described above I can run `zmsetup.pl` without this error.
rus@rainor.ru
Posts: 7
Joined: Fri Oct 07, 2016 10:28 am

Re: Upgrade from GA 8.0.6 to 8.5.0 fails

Postby rus@rainor.ru » Tue Oct 11, 2016 8:36 pm

Hello! I ask you to help me! I am trying to upgrade and out of such a result. What am I doing wrong?

Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
HOSTNAME=localhost
LDAPHOST=
LDAPPORT=
SNMPTRAPHOST=
SMTPSOURCE=
SMTPDEST=
SNMPNOTIFY=0
SMTPNOTIFY=0
LDAPROOTPW=*
LDAPZIMBRAPW=*
LDAPPOSTPW=*
LDAPREPPW=*
LDAPAMAVISPW=*
LDAPNGINXPW=*
Restoring existing configuration file from /opt/zimbra/.saveconfig/localconfig.xml...done
Operations logged to /tmp/zmsetup.20161011-232022.log
Upgrading from to 8.7.0_GA_1659
ERROR: Upgrading from a ZCS version less than 7.0.0_GA is not supported
UPGRADE FAILED - exiting.
[root@mail zcs-8.7.0_GA_1659.RHEL6_64.20160628192545]#

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 4 guests