Missing Left Column with List of Folders & Inbox-Sent-Trash

Ask questions about your setup or get help installing ZCS server (ZD section below).
rkt
Posts: 10
Joined: Tue Sep 30, 2014 4:01 am

Missing Left Column with List of Folders & Inbox-Sent-Trash

Postby rkt » Tue Sep 30, 2014 4:20 am

We are running two mailbox server. Server A and Server B. They are working fine when we accessing by their individual url. Now we have configured reverse proxy at server A and accessing server B through redirection. It is getting redirected to user's mail box, Missing Left Column with List of Folders & Inbox-Sent-Trash etc.in each mail box of server B.



Pls help us. Currently we are running Release 8.0.7_GA_6021.RHEL6_64_20140408123911 RHEL6_64 FOSS edition, Patch 8.0.7_P2.
 



User avatar
pup_seba
Outstanding Member
Outstanding Member
Posts: 687
Joined: Sat Sep 13, 2014 2:43 am
Location: Tarragona - Spain
Contact:

Missing Left Column with List of Folders & Inbox-Sent-Trash

Postby pup_seba » Fri Oct 03, 2014 5:24 am

Hi,



This happens because the lookup handler has the wrong information about where the mailbox is located.



Try:

1) Disabling memcached

2) Purging from old mailbox any mailbox you moved (carefull with this)

3) Clearing all your servers caché information





Regards,

Sebas

Please, post your feedback and mark as answered this thread so others can easly find the solution.
rkt
Posts: 10
Joined: Tue Sep 30, 2014 4:01 am

Missing Left Column with List of Folders & Inbox-Sent-Trash

Postby rkt » Fri Oct 03, 2014 11:53 pm

Hi,

Thanx for quick response.



below are activities done by us.

1. Disabling memcached from both serve A and Server B by

$zmmemcachedctl stop

$zmprov ms `zmhostname` -zimbraServiceEnabled memcached

$zmcontrol stop

$zmcontrol start



2. Created new user in server B



3. Flush Contents Of a Memcached Server by

$echo 'flush_all' | nc localhost 11211



Flushing other all cache by



$zmprov flushCache account

$zmprov flushCache skin

$zmprov flushCache locale

$zmprov flushCache cos

$zmprov flushCache domain

$zmprov flushCache server



But we are facing same problem. Pls suggest.
User avatar
pup_seba
Outstanding Member
Outstanding Member
Posts: 687
Joined: Sat Sep 13, 2014 2:43 am
Location: Tarragona - Spain
Contact:

Missing Left Column with List of Folders & Inbox-Sent-Trash

Postby pup_seba » Mon Oct 06, 2014 2:38 am

Hi,



The only 2 times I faced this problem, it got solved by doing that :(



FYI, you can use 'zmprov fc all' instead of a one by one approach to flushing.



At this point, only thing I can think of is:

1) Try to find some "warn", "fatal", "error" in your logs. All of them (/var/log/zimbra.log and /opt/zimbra/log/)

2) Redeploy your ssh keys (zmupdateauthkeys as zimbra user)

3) Fixing perms

as 'root'

$ su - zimbra -c 'zmcontrol stop'

$ /opt/zimbra/libexec/zmfixperms -v -e

$ su - zimbra -c 'zmcontrol start'



4) Comunication is ok? I mean, firewall between proxy and stores (in case there is any); proxy ports and service ports are correctly configured, etc?



That's all I can think of right now. Sorry there's is no straight answer but troubleshoot is all I can think of and those would be the steps I would do to begin with.
rkt
Posts: 10
Joined: Tue Sep 30, 2014 4:01 am

Missing Left Column with List of Folders & Inbox-Sent-Trash

Postby rkt » Mon Oct 06, 2014 5:09 am

We have performed as per suggestion in 2) and 3).But same result. pls find the attached mailbox.log for a user ,may be you have some clue for the issue.



2014-10-06 14:51:35,654 INFO [qtp662845511-629:http://127.0.0.1:80/service/soap/AuthRequest] [name=test.sk@test.co.in;oip=172.16.5.170;ua=zclient/8.0.7_GA_6021;] soap - AuthRequest elapsed=3

2014-10-06 14:51:35,683 INFO [qtp662845511-629:http://127.0.0.1:80/service/soap/GetInfoRequest] [name=test.sk@test.co.in;oip=172.16.5.170;ua=zclient/8.0.7_GA_6021;] soap - GetInfoRequest elapsed=21

2014-10-06 14:51:35,703 INFO [qtp662845511-628:http://127.0.0.1:80/service/soap/AuthRequest] [name=test.sk@test.co.in;oip=172.16.5.170;ua=zclient/8.0.7_GA_6021;] soap - AuthRequest elapsed=1

2014-10-06 14:51:35,724 INFO [qtp662845511-628:http://127.0.0.1:80/service/soap/GetInfoRequest] [name=test.sk@test.co.in;oip=172.16.5.170;ua=zclient/8.0.7_GA_6021;] soap - GetInfoRequest elapsed=13

2014-10-06 14:51:35,747 INFO [qtp662845511-628:http://127.0.0.1:80/service/soap/GetAvailableLocalesRequest] [name=test.sk@test.co.in;ip=127.0.0.1;ua=ZCS/8.0.7_GA_6037;] soap - GetAvailableLocalesRequest elapsed=14

2014-10-06 14:51:35,759 INFO [qtp662845511-628:https://127.0.0.1:7071/service/admin/soap/GetDomainInfoRequest] [ip=127.0.0.1;ua=ZCS/8.0.7_GA_6037;] soap - GetDomainInfoRequest elapsed=1

2014-10-06 14:51:35,806 INFO [qtp662845511-631:http://127.0.0.1:80/service/soap/AuthRequest] [name=test.sk@test.co.in;oip=172.16.5.170;ua=zclient/8.0.7_GA_6021;] soap - AuthRequest elapsed=1

2014-10-06 14:51:35,819 INFO [qtp662845511-631:http://127.0.0.1:80/service/soap/GetFolderRequest] [name=test.sk@test.co.in;oip=172.16.5.170;ua=zclient/8.0.7_GA_6021;] soap - GetFolderRequest elapsed=8

2014-10-06 14:51:35,823 INFO [qtp662845511-628:http://127.0.0.1:80/service/soap/BatchRequest] [name=test.sk@test.co.in;oip=172.16.5.170;ua=ZCS/8.0.7_GA_6037;] soap - BatchRequest

2014-10-06 14:51:35,851 INFO [qtp662845511-628:http://127.0.0.1:80/service/soap/BatchRequest] [name=test.sk@test.co.in;oip=172.16.5.170;ua=ZCS/8.0.7_GA_6037;] soap - (batch) GetInfoRequest elapsed=28

2014-10-06 14:51:35,868 INFO [qtp662845511-628:http://127.0.0.1:80/service/soap/BatchRequest] [name=test.sk@test.co.in;oip=172.16.5.170;ua=ZCS/8.0.7_GA_6037;] soap - (batch) SearchRequest elapsed=17

2014-10-06 14:51:36,170 INFO [qtp662845511-628:http://172.16.7.49:80/service/soap/BatchRequest] [name=test.sk@test.co.in;ip=172.16.5.170;ua=ZimbraWebClient - IE7 (Win)/8.0.7_GA_6021;] soap - BatchRequest

2014-10-06 14:51:36,173 INFO [qtp662845511-630:http://172.16.7.49:80/service/soap/BatchRequest] [name=test.sk@test.co.in;ip=172.16.5.170;ua=ZimbraWebClient - IE7 (Win)/8.0.7_GA_6021;] soap - BatchRequest

2014-10-06 14:51:36,179 INFO [qtp662845511-628:http://172.16.7.49:80/service/soap/BatchRequest] [name=test.sk@test.co.in;ip=172.16.5.170;ua=ZimbraWebClient - IE7 (Win)/8.0.7_GA_6021;] soap - (batch) DiscoverRightsRequest elapsed=9

2014-10-06 14:51:36,185 INFO [qtp662845511-630:http://172.16.7.49:80/service/soap/BatchRequest] [name=test.sk@test.co.in;ip=172.16.5.170;ua=ZimbraWebClient - IE7 (Win)/8.0.7_GA_6021;] soap - (batch) GetMailboxMetadataRequest elapsed=12

2014-10-06 14:51:36,705 INFO [Timer-Zimbra] [] session - WaitSet sweeper: 10 active WaitSets (10 accounts) - 8 sets with blocked callbacks

2014-10-06 14:51:41,967 INFO [qtp662845511-631:http://172.16.7.49:80/service/soap/GetMiniCalRequest] [name=test.sk@test.co.in;ip=172.16.5.170;ua=ZimbraWebClient - IE7 (Win)/8.0.7_GA_6021;] soap - GetMiniCalRequest elapsed=6
User avatar
pup_seba
Outstanding Member
Outstanding Member
Posts: 687
Joined: Sat Sep 13, 2014 2:43 am
Location: Tarragona - Spain
Contact:

Missing Left Column with List of Folders & Inbox-Sent-Trash

Postby pup_seba » Mon Oct 06, 2014 8:54 am

Hi,



What is your zimbra conf? (please specify roles, LANs and IPs so I can better interpretate your logs).



Did you look all your logs as suggested previously? I see some delayed/blocked callbacks in the log you copied/pasted. If DoSfilter is causing these problems you should notice some messages pointing towards that sort of error in your sync.log or zmmailboxd.out logs. If you do see DoSfilter acting, you could throtle the DoSfilter settings while looking for the root 'cause of the error.



IE7?! omg! that stil existits?! lol Did you also try with other web browsers? I know that if you connect directly to the store it works...but please make sure.



Most important here, is that you check all your logs until you find some "warn", "error" or "fatal" that actually points towards a cause.



What's the output of running this command in your servers?



zmprov gs `zmhostname` zimbraReverseProxyLookupTarget
rkt
Posts: 10
Joined: Tue Sep 30, 2014 4:01 am

Missing Left Column with List of Folders & Inbox-Sent-Trash

Postby rkt » Tue Oct 07, 2014 2:14 am

Pls find the attached our zimbra conf


Server A:


Name:zimbra-mail-svr.test.co.in


IP: 172.16.7.49


Role:Primary LDAP,MTA,Reverse Proxy,Mail Box Server1


Services Installed: antispam,antivirus,ldap,logger,mailbox,mta,opendkim,proxy,snmp,spell,stats,


zmconfigd                    


 


Server B:


Name:zimbra-test-svr.test.co.in


IP: 172.16.7.250       


Role:Secondary LDAP,Mail Box Server2


Services Installed: ldap,mailbox,snmp,spell,stats,zmconfigd


 


Pls suggest, DoSfilter settings impact on in our problem case. Is it required to check the same?


We have looked all logs as suggested previously. But unable to find any relevant messages. We are not using IE7.We don’t understand why it’s showing IE7.We have checked with IE11,Mozilla Firefox 32.0.3,Google chrome 37.0.2062.124 m. But same result.


The output of running the command “zmprov gs `zmhostname` zimbraReverseProxyLookupTarget” in our both servers are:


Server A


# name zimbra-mail-svr.test.co.in


zimbraReverseProxyLookupTarget: TRUE


Server B


# name zimbra-test-svr.test.co.in


zimbraReverseProxyLookupTarget: TRUE


 


 


Regards


User avatar
pup_seba
Outstanding Member
Outstanding Member
Posts: 687
Joined: Sat Sep 13, 2014 2:43 am
Location: Tarragona - Spain
Contact:

Missing Left Column with List of Folders & Inbox-Sent-Trash

Postby pup_seba » Tue Oct 07, 2014 3:27 am

Hi,



I'm running out of ideas. If DoSfilter (http://wiki.zimbra.com/wiki/DoSFilter) is ok or there's no need to throtle it, having memcached disabled and both servers being lookuptargets the only thing I can think of is that this is a communication problem or just a proxy misconfiguration.



Make sure you are using the right ports. It is easy to confuse what should be zimbra-zimbra ports in a proxied enviroment. For instance: Both of your mailstores should use ports 8080 and 8443 for internal comunication and your proxy server should be the only one with the additional 80 and 443 listening.



zmprov -garpu should list both your servers

zmprov -garpb should list both your servers

zmprov -gamcs should be empty (as you disabled memcached)



As they are both in the same lan, no external firewall could be causing trouble but, make sure you have your OS level firewalls disabled (iptables most of the times).



I'm sorry to not being able to help you more.
rkt
Posts: 10
Joined: Tue Sep 30, 2014 4:01 am

Missing Left Column with List of Folders & Inbox-Sent-Trash

Postby rkt » Thu Oct 09, 2014 2:30 am

Hi

Sorry for giving trouble again.



We have observed that this is working fine with https://<server ip> .But its giving problem with http://<server ip> .It means it working with ssl.Pls suggest can it work without SSL.



Thanx
User avatar
Gren Elliot
Zimbra Employee
Zimbra Employee
Posts: 183
Joined: Tue Jun 10, 2014 4:45 am

Missing Left Column with List of Folders & Inbox-Sent-Trash

Postby Gren Elliot » Thu Oct 09, 2014 3:34 am

You probably need to look at the zmtlsctl command - see http://wiki.zimbra.com/wiki/CLI_zmtlsctl_to_set_Web_Server_Mode



Regards,

Gren

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 1 guest