unable to send or receive mail

Ask questions about your setup or get help installing ZCS server (ZD section below).
damanmokha
Posts: 7
Joined: Mon Dec 29, 2014 1:24 pm

unable to send or receive mail

Postby damanmokha » Mon Dec 29, 2014 1:29 pm


Hi


I have installed latest version on centos 6 but i am getting following error while sending and i am unable to receive emails. please help me out


 


 














An unknown error (mail.TRY_AGAIN) has occurred.





























method:[unknown]
msg:try again: Unable to connect to the MTA
code:mail.TRY_AGAIN
detail:soap:Receiver
trace:qtp509886383-197:https://63.142.248.216:8443/service/soap/SendMsgRequest:1419881169453:b46279604877d38c
request:
Body: {
SendMsgRequest: {
_jsns: "urn:zimbraMail",
m: {
e: [
// [0]:
{
a: "info@afterdoor.com",
t: "t"
},
// [1]:
{
a: "admin@askcentos.com",
t: "f"
}
],
idnt: "27761114-71b5-4883-83d3-60eff65a01e4",
mp: [
// [0]:
{
ct: "multipart/alternative",
mp: [
// [0]:
{
content: {
_content: "Hi
"
},
ct: "text/plain"
},
// [1]:
{
content: {
_content: "<html><body><div style="font-family: arial, helvetica, sans-serif; font-size: 12pt; color: #000000"><div>Hi</div></div></body></html>"
},
ct: "text/html"
}
]
}
],
su: {
_content: "Test"
}
},
suid: 1419881170950
}
},
Header: {
context: {
_jsns: "urn:zimbra",
account: {
_content: "admin@askcentos.com",
by: "name"
},
authToken: "(removed)",
csrfToken: "0_85b07c86406bc5fef2865e049a061004dc3a3e27",
notify: {
seq: 7
},
session: {
_content: 13,
id: 13
},
userAgent: {
name: "ZimbraWebClient - GC39 (Win)",
version: "8.6.0_GA_1153"
}
}
}




User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2773
Joined: Thu May 22, 2014 4:47 pm

unable to send or receive mail

Postby jorgedlcruz » Mon Dec 29, 2014 1:50 pm

Hi  damanmokha,


This problem sounds like a problem with the DNS configuration, please take a look here http://wiki.zimbra.com/wiki/Split_DNS


And if you want more help, paste us the result of /etc/hosts and /etc/hostname and zmcontrol -v. Also your public domain will help to fix your problem.



Best regards

Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
damanmokha
Posts: 7
Joined: Mon Dec 29, 2014 1:24 pm

unable to send or receive mail

Postby damanmokha » Mon Dec 29, 2014 1:56 pm

/etc/hosts



127.0.0.1 localhost.localdomain localhost localhost4.localdomain4 localhost4

# Auto-generated hostname. Please do not remove this comment.

63.142.248.216 mail.askcentos.com mail mail.askcentos.com

::1 localhost localhost.localdomain localhost6 localhost6.localdomain6



zmcontrol -v

Release 8.6.0_GA_1153.RHEL6_64_20141215151155 RHEL6_64 FOSS edition.



Public domain is askcentos.com with hostname mail.askcentos.com



and there is only hosts file not the hostname file
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2773
Joined: Thu May 22, 2014 4:47 pm

unable to send or receive mail

Postby jorgedlcruz » Mon Dec 29, 2014 2:06 pm

Hi damanmokha,


Your /etc/hosts should be like this:


127.0.0.1 localhost.localdomain localhost localhost4.localdomain4 localhost4
# Auto-generated hostname. Please do not remove this comment.
63.142.248.216 mail.askcentos.com mail
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6


So delete the last mail.askcentos.com in the third line. Also you need to check if you are able to ping your own public IP and telnet trough the port 25, so launch the next commands:


ping 63.142.248.216
telnet 63.142.248.216 25

Also, could you please launch the next command?


zmhostname

Best regards

Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
damanmokha
Posts: 7
Joined: Mon Dec 29, 2014 1:24 pm

unable to send or receive mail

Postby damanmokha » Mon Dec 29, 2014 2:11 pm

zmhostname

mail.askcentos.com



ping working fine but telnet shows this

telnet: connect to address 63.142.248.216: Connection refused



and now i have edited the hosts file
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2773
Joined: Thu May 22, 2014 4:47 pm

unable to send or receive mail

Postby jorgedlcruz » Mon Dec 29, 2014 2:33 pm

Do you have all the services running?

Do a zmcontrol status, and zmcontrol restart and try again, what is the result of /etc/hostname?



Best regards
Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
damanmokha
Posts: 7
Joined: Mon Dec 29, 2014 1:24 pm

unable to send or receive mail

Postby damanmokha » Mon Dec 29, 2014 2:40 pm

amavis Running

antispam Running

antivirus Running

dnscache Running

ldap Running

mailbox Running

memcached Running

mta Stopped

postfix is not running

opendkim Running

proxy Running

service webapp Running

snmp Running

spell Running

stats Running

zimbra webapp Running

zimbraAdmin webapp Running

zimlet webapp Running

zmconfigd Stopped



mta & zmconfigd are not running even after restart and there is no file named hostname in the etc directory
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2773
Joined: Thu May 22, 2014 4:47 pm

unable to send or receive mail

Postby jorgedlcruz » Mon Dec 29, 2014 3:07 pm

Hi,


So there is the problem, do you have any info in the /var/log/zimbra.log ? Try to debug it and tell us the error.


Which Operating system do you have? Did you follow the System Requirements? So have at least 8GB RAM? https://files.zimbra.com/website/docs/8.6/ZCS_System_Requirements_8.6.0.pdf


Best regards

Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
damanmokha
Posts: 7
Joined: Mon Dec 29, 2014 1:24 pm

unable to send or receive mail

Postby damanmokha » Tue Dec 30, 2014 1:55 am

here is the portion of log file

Dec 30 00:57:25 mail zmconfigd[16987]: Exception in bin/zmmailboxdctl: (Cannot run program "/opt/zimbra/bin/zmmailboxdctl" (in directory "/root"): error=13, Permission denied)
Dec 30 00:57:25 mail zmconfigd[16987]: Exception in bin/zmmailboxdctl: (Cannot run program "/opt/zimbra/bin/zmmailboxdctl" (in directory "/root"): error=13, Permission denied)
Dec 30 00:57:25 mail zmconfigd[16987]: Exception in bin/zmmailboxdctl: (Cannot run program "/opt/zimbra/bin/zmmailboxdctl" (in directory "/root"): error=13, Permission denied)
Dec 30 00:57:25 mail zmconfigd[16987]: Exception in bin/zmclamdctl: (Cannot run program "/opt/zimbra/bin/zmclamdctl" (in directory "/root"): error=13, Permission denied)
Dec 30 00:57:25 mail zmconfigd[16987]: Watchdog: service antivirus status is OK.
Dec 30 00:57:25 mail zmconfigd[16987]: All rewrite threads completed in 0.01 sec
Dec 30 00:57:25 mail zmconfigd[16987]: All restarts completed in 0.00 sec
Dec 30 00:57:47 mail postfix/postqueue[17707]: fatal: Queue report unavailable - mail system is down
Dec 30 00:58:17 mail postfix/postqueue[18259]: fatal: Queue report unavailable - mail system is down
Dec 30 00:58:25 mail zmconfigd[16987]: Fetching All configs
Dec 30 00:58:25 mail zmconfigd[16987]: All configs fetched in 0.05 seconds
[...]

User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2773
Joined: Thu May 22, 2014 4:47 pm

unable to send or receive mail

Postby jorgedlcruz » Tue Dec 30, 2014 2:23 am

Hi damanmokha,


Please launch the next command as root:


/opt/zimbra/libexec/zmfixperms -extended
su - zimbra
zmcontrol restart


Best regards

Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 4 guests