Failed to upgrade from 8.6 to 8.7 Zimbra

Ask questions about your setup or get help installing ZCS server (ZD section below).
tadcin1
Posts: 1
Joined: Tue Jul 19, 2016 2:12 pm

Failed to upgrade from 8.6 to 8.7 Zimbra

Postby tadcin1 » Wed Jul 20, 2016 4:58 am

Hi there,
yesterday I've try to upgrade zimbra from 8.6 to 8.7 with now luck.
Log file show this:
Errors were encountered while processing:
/var/cache/apt/archives/zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Can somebody help?
Thanks
Tadej


ITelligencia
Posts: 4
Joined: Sat Sep 13, 2014 12:00 am

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby ITelligencia » Wed Jul 20, 2016 3:31 pm

I just experienced the same issue:

Using: Ubuntu server 14.04.
Current zimbra version: zcs-8.6.0_GA_1153.UBUNTU14_64.20141215151116
Tried to upgrade from zimbra 8.6 to 8.7.

Exact same errors in the log as tadcin1. Was able to fix perms and re-run the 8.6 installer to get the server back online.
I will apply the latest June patch and then try again.

Thanks,
Ruben
temerarious
Posts: 8
Joined: Sat Sep 13, 2014 2:55 am

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby temerarious » Thu Jul 21, 2016 12:29 am

I also encountered EXACTLY the same issue when I tried the 8.6 to 8.7 upgrade early this morning. And like ITelligencia, I fixperms and reran the 8.6 installer and patch 7 which has me quickly back online at 8.6. I don't have another window of downtime for a couple of days so I wont be able to troubleshoot or take another shot at it for a while.

It appears as if the packages zimbra-osl zimbra-perl-mail-spamassassin and zimbra-spamassassin-rules all retrieved from the new zimbra repositories added by the 8.7 install script, are failing to install with a dpkg error, causing the install script to abort in kind of a messy condition.


Release 8.6.0.GA.1153.UBUNTU14.64 UBUNTU14_64 FOSS edition, Patch 8.6.0_P7
ITelligencia
Posts: 4
Joined: Sat Sep 13, 2014 12:00 am

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby ITelligencia » Thu Jul 21, 2016 2:14 pm

I applied patch 7 to the same 8.6 installation on my failover server, then was able to install 8.7 with no errors.
juancanic
Posts: 10
Joined: Sat Sep 13, 2014 12:41 am

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby juancanic » Thu Jul 28, 2016 3:39 pm

I have the same problem in the same place. I applied the las zimbra patch 7
Release 8.6.0.GA.1153.UBUNTU14.64 UBUNTU14_64 FOSS edition, Patch 8.6.0_P7.
I still getting the same error in:
/var/cache/apt/archives/zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
User avatar
DualBoot
Elite member
Elite member
Posts: 1250
Joined: Mon Apr 18, 2016 8:18 pm
Location: France - Earth
ZCS/ZD Version: ZCS FLOSS - 8.8.15 Mutli servers
Contact:

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby DualBoot » Thu Jul 28, 2016 8:53 pm

Purge your system apt cache and retry.
The Guy - DualBoot

PostMaster - WikiMaster - SysAdmin
"Free Your Mind. Think Open Source"
april.org
Zetalliance Member - zetalliance.org
User avatar
quanah
Zimbra Alumni
Zimbra Alumni
Posts: 1668
Joined: Fri Sep 12, 2014 10:33 pm
Contact:

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby quanah » Thu Jul 28, 2016 8:56 pm

juancanic wrote:I have the same problem in the same place. I applied the las zimbra patch 7
Release 8.6.0.GA.1153.UBUNTU14.64 UBUNTU14_64 FOSS edition, Patch 8.6.0_P7.
I still getting the same error in:
/var/cache/apt/archives/zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Looks like there's an issue with your cached copies of those debs. I would see about deleting them, and re-running the installer so they get downloaded fresh from the package repository.
--
Quanah Gibson-Mount
Product Architect, Symas http://www.symas.com/
OpenLDAP Core team http://www.openldap.org/project/
temerarious
Posts: 8
Joined: Sat Sep 13, 2014 2:55 am

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby temerarious » Sat Jul 30, 2016 5:24 pm

I gave it another shot and failed miserably. This time I messed it up so badly while trying to troubleshoot, I had to restore the backup and I am still at version 8.6 patch 7 and will not have another chance to try it again for another week.

I think I have located the root of the error. When dpkg is trying to install zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb, zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b1.14.04_all.deb, and zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb

it is getting overwrite errors and aborting installing the packages.

The error in the log is

dpkg: error processing archive /var/cache/apt/archives/zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb (--unpack):
trying to overwrite '/opt/zimbra/docs/open_source_licenses.txt', which is also in zimbra-core 8.6.0.GA.1153.UBUNTU14.64

and similar errors for the other two debs.

Then the install script aborts leaving a non working system

I'm guessing zimbra-core 8.6.0.GA.1153.UBUNTU14.64 should have uninstalled earlier in the script???? and did not uninstall completely ????

Alas, since the install script aborted without finishing, it never copied zmsetup*.log from /tmp to /opt/zimbra/log and I foolishly rebooted, clearing /tmp, without making a copy of the /tmp/zmsetup*.log containing the dpkg errors and other record of the failed upgrade which I am sure would be incredibly helpful ;-) But I did clearly see that the actual errors causing the condition encountered by me and the other posters in this thread was an dpkg overwrite issue with the three deb's named above and zimbra-core 8.6.0.GA.1153.UBUNTU14.64 . All fairly trivial files it was trying to overwrite too so other than making dpkg happy, it would have made no difference to the way the uupgrade functioned whether those files were overwritten or not.

It will probably be next weekend before I try again. I will maliciously preserve the log in /tmp at that time and hopefully either be able to troubleshoot it myself or have a more complete record of what is going on. I just posted this incomplete summery of what I found in the hopes it would at least provide a clue for anyone else looking at this exact issue.
kinetic
Posts: 1
Joined: Sun Jul 31, 2016 12:37 am

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby kinetic » Sun Jul 31, 2016 1:00 am

Hi All,

I am also stuck at the same point with the same issue

Ubuntu 14.04.4 LTS Zimbra 8.6 Patch 7 to Zimbra 8.7

Errors were encountered while processing:
/var/cache/apt/archives/zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

At this point I tried to manually install the deb which failed with the following error.

dpkg -i /var/cache/apt/archives/zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb

Unpacking zimbra-osl (1.0.9-1zimbra8.7b1.14.04) ...
dpkg: error processing archive /var/cache/apt/archives/zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb (--install):
trying to overwrite '/opt/zimbra/docs/open_source_licenses.txt', which is also in package zimbra-core 8.6.0.GA.1153.UBUNTU14.64

As with temerarious, similar errors with zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b1.14.04_all.deb and zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb

Force installing the deb packages did succeed but the 8.7 installer then failed. (ldap error)

After restoring from snapshot I also tried

./install.sh --force-upgrade

Same error at the same point, at this point I'm all out of ideas :?
patobasalo
Posts: 6
Joined: Mon Aug 01, 2016 12:42 am

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby patobasalo » Mon Aug 01, 2016 12:50 am

(sorry for my english)
Hi, I am also stuck at the same point with the same issue Ubuntu 14.04.4 LTS Zimbra 8.6 Patch 7 to Zimbra 8.7 like temerarious and kinetic with the same errors.

I tried to fix my apt, but for this needs to remove zimbra-mta-components and zimbra-core-components.
If i execute apt-get remove those packages, apt works fine, but when i try to install the new version of Zimbra, hangs also the same errors appears.

I dont know what can i do to fix it.

Thanx

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 5 guests