ZCS 8.6_P7 to 8.7 error

Ask questions about your setup or get help installing ZCS server (ZD section below).
gadmin
Posts: 7
Joined: Sun Aug 21, 2016 12:28 pm

ZCS 8.6_P7 to 8.7 error

Postby gadmin » Sun Aug 21, 2016 1:16 pm

Hi

I'm trying to upgrade my server to Zimbra (ZCS 8.6_P7 to 8.7), but it does not work and I get an error message.

Code: Select all

[root@mail zcs-8.7.0_GA_1659.RHEL6_64.20160628192545]# ./install.sh --platform-override

Operations logged to /tmp/install.log.N2EjYiwK
Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-8.6.0_GA_1153
    zimbra-logger...FOUND zimbra-logger-8.6.0_GA_1153
    zimbra-mta...FOUND zimbra-mta-8.6.0_GA_1153
    zimbra-dnscache...NOT FOUND
    zimbra-snmp...FOUND zimbra-snmp-8.6.0_GA_1153
    zimbra-store...FOUND zimbra-store-8.6.0_GA_1153
    zimbra-apache...FOUND zimbra-apache-8.6.0_GA_1153
    zimbra-spell...FOUND zimbra-spell-8.6.0_GA_1153
    zimbra-convertd...NOT FOUND
    zimbra-memcached...FOUND zimbra-memcached-8.6.0_GA_1153
    zimbra-proxy...FOUND zimbra-proxy-8.6.0_GA_1153
    zimbra-archiving...NOT FOUND
    zimbra-core...FOUND zimbra-core-8.6.0_GA_1153
ZCS upgrade from 8.6.0 to 8.7.0 will be performed.
Checking for existing proxy service in your environment
Error: proxy not enabled
Error: No proxy detected in your environment. Proxy is required for ZCS 8.7+.
See https://wiki.zimbra.com/wiki/Enabling_Zimbra_Proxy for details on installing proxy.
Checking for existing memcached service in your environment
Error: memcached not enabled
Error: No memcached detected in your environment. Memcached is required for ZCS 8.7+.
See https://wiki.zimbra.com/wiki/Enabling_Zimbra_Memcached for details on installing memcached.
Proxy and Memcached services must exist. Exiting...



I read the instructions, https://wiki.zimbra.com/wiki/Enabling_Zimbra_Proxy and the required packages are installed but do not know how to turn on the Proxy and Memcached services.

Please write it step by step what to do.

I use CentOS 6 system.

Please help me.

regard

gadmin


phoenix
Ambassador
Ambassador
Posts: 26624
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: ZCS 8.6_P7 to 8.7 error

Postby phoenix » Sun Aug 21, 2016 2:34 pm

It tells you in the output that you need to proxy enabled for this upgrade to work and it points you to a wiki page, read that. I'm also guessing that you've downloaded a copy of ZCS NE because there's trwo list services that aren't in the OSS version - are you an NE customer? I'd also suggest that you read the Release Notes (in detail) and the wiki article on upgrading to this version of ZCS before you go any further.
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
gadmin
Posts: 7
Joined: Sun Aug 21, 2016 12:28 pm

Re: ZCS 8.6_P7 to 8.7 error

Postby gadmin » Sun Aug 21, 2016 2:38 pm

phoenix wrote:It tells you in the output that you need to proxy enabled for this upgrade to work and it points you to a wiki page, read that. I'm also guessing that you've downloaded a copy of ZCS NE because there's trwo list services that aren't in the OSS version - are you an NE customer? I'd also suggest that you read the Release Notes (in detail) and the wiki article on upgrading to this version of ZCS before you go any further.



I understand, but how do I enable the services?

gadmin
phoenix
Ambassador
Ambassador
Posts: 26624
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: ZCS 8.6_P7 to 8.7 error

Postby phoenix » Sun Aug 21, 2016 2:42 pm

gadmin wrote:I understand, but how do I enable the services?
How do you enable which services? How about answering the question(s) I've asked in my previous post?
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
gadmin
Posts: 7
Joined: Sun Aug 21, 2016 12:28 pm

Re: ZCS 8.6_P7 to 8.7 error

Postby gadmin » Sun Aug 21, 2016 2:57 pm

phoenix wrote:
gadmin wrote:I understand, but how do I enable the services?
How do you enable which services? How about answering the question(s) I've asked in my previous post?


I downloaded a 8.7 OSS versions. I'm trying to install.
Can you help me step by step descriptions?

gadmin
phoenix
Ambassador
Ambassador
Posts: 26624
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: ZCS 8.6_P7 to 8.7 error

Postby phoenix » Sun Aug 21, 2016 3:03 pm

gadmin wrote:I downloaded a 8.7 OSS versions. I'm trying to install.
I don't believe you have downloaded that version because there are two services mentioned (archive & convertd) that are only available in the NE version. Just for confirmation, please post the exact filename of the file you've downloaded.

gadmin wrote:Can you help me step by step descriptions?
Have you read the wiki article that describes how to ebale the proxy before you upgrade? Have you also read the wiki article on the upgrade process for ZCS 8.7? Both of those articles contain complete descriptions of what's necessary to upgrade to ZCS 8.7 and, again, I'll suggest yopu read those and the ZCS Release Notes before you go any further - you need to do that and understand what's necessary.
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
gadmin
Posts: 7
Joined: Sun Aug 21, 2016 12:28 pm

Re: ZCS 8.6_P7 to 8.7 error

Postby gadmin » Sun Aug 21, 2016 3:19 pm

phoenix wrote:
gadmin wrote:I downloaded a 8.7 OSS versions. I'm trying to install.
I don't believe you have downloaded that version because there are two services mention (archive & convertd) that are only available in the NE version. Just for confirmation, please post the exact filename of the file you've downloaded.



gadmin wrote:Can you help me step by step descriptions?
Have you read the wiki article that describes how to ebale the proxy before you upgrade? Have you also read the wiki article on the upgrade process for ZCS 8.7? Both of those articles contain complete descriptions of what's necessary to upgrade to ZCS 8.7 and, again, I'll suggest yopu read those and the ZCS Release Notes before you go any further - you need to do that and understand what's necessary.



file name: zcs-8.7.0_GA_1659.RHEL6_64.20160628192545.tgz


https://wiki.zimbra.com/wiki/Enabling_Z ... _memcached
i have read

detail from the description ....

Assuming you are running ZCS version with no proxy/memcached, zimbraMailMode as https, and want to upgrade to 8.5, or above, along with adding proxy & memcached, follow these steps

Start 8.5, or above, installer (install.sh script)

Do you wish to upgrade? [Y] y
Install zimbra-memcached [N] y
Install zimbra-proxy [N] y

i run the install.sh script, but not working:

Code: Select all

Operations logged to /tmp/install.log.N2EjYiwK
Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-8.6.0_GA_1153
    zimbra-logger...FOUND zimbra-logger-8.6.0_GA_1153
    zimbra-mta...FOUND zimbra-mta-8.6.0_GA_1153
    zimbra-dnscache...NOT FOUND
    zimbra-snmp...FOUND zimbra-snmp-8.6.0_GA_1153
    zimbra-store...FOUND zimbra-store-8.6.0_GA_1153
    zimbra-apache...FOUND zimbra-apache-8.6.0_GA_1153
    zimbra-spell...FOUND zimbra-spell-8.6.0_GA_1153
    zimbra-convertd...NOT FOUND
    zimbra-memcached...FOUND zimbra-memcached-8.6.0_GA_1153
    zimbra-proxy...FOUND zimbra-proxy-8.6.0_GA_1153
    zimbra-archiving...NOT FOUND
    zimbra-core...FOUND zimbra-core-8.6.0_GA_1153
ZCS upgrade from 8.6.0 to 8.7.0 will be performed.
Checking for existing proxy service in your environment
Error: proxy not enabled
Error: No proxy detected in your environment. Proxy is required for ZCS 8.7+.
See https://wiki.zimbra.com/wiki/Enabling_Zimbra_Proxy for details on installing proxy.
Checking for existing memcached service in your environment
Error: memcached not enabled
Error: No memcached detected in your environment. Memcached is required for ZCS 8.7+.
See https://wiki.zimbra.com/wiki/Enabling_Zimbra_Memcached for details on installing memcached.
Proxy and Memcached services must exist. Exiting...
gadmin
Posts: 7
Joined: Sun Aug 21, 2016 12:28 pm

Re: ZCS 8.6_P7 to 8.7 error

Postby gadmin » Mon Aug 22, 2016 1:11 pm

Hi

I do not know what I'm doing wrong. Does not work
I am running the install.sh script, but I can not activate the services.
Not recommended for the options:

"
Do you wish to upgrade? [Y] y
Install zimbra-memcached [N] y
Install zimbra-proxy [N] y
"

I get an error message:

Code: Select all


Operations logged to /tmp/install.log.N2EjYiwK
Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-8.6.0_GA_1153
    zimbra-logger...FOUND zimbra-logger-8.6.0_GA_1153
    zimbra-mta...FOUND zimbra-mta-8.6.0_GA_1153
    zimbra-dnscache...NOT FOUND
    zimbra-snmp...FOUND zimbra-snmp-8.6.0_GA_1153
    zimbra-store...FOUND zimbra-store-8.6.0_GA_1153
    zimbra-apache...FOUND zimbra-apache-8.6.0_GA_1153
    zimbra-spell...FOUND zimbra-spell-8.6.0_GA_1153
    zimbra-convertd...NOT FOUND
    zimbra-memcached...FOUND zimbra-memcached-8.6.0_GA_1153
    zimbra-proxy...FOUND zimbra-proxy-8.6.0_GA_1153
    zimbra-archiving...NOT FOUND
    zimbra-core...FOUND zimbra-core-8.6.0_GA_1153
ZCS upgrade from 8.6.0 to 8.7.0 will be performed.
Checking for existing proxy service in your environment
Error: proxy not enabled
Error: No proxy detected in your environment. Proxy is required for ZCS 8.7+.
See https://wiki.zimbra.com/wiki/Enabling_Zimbra_Proxy for details on installing proxy.
Checking for existing memcached service in your environment
Error: memcached not enabled
Error: No memcached detected in your environment. Memcached is required for ZCS 8.7+.
See https://wiki.zimbra.com/wiki/Enabling_Zimbra_Memcached for details on installing memcached.
Proxy and Memcached services must exist. Exiting...



Does anyone have ideas?
gadmin
Posts: 7
Joined: Sun Aug 21, 2016 12:28 pm

Re: ZCS 8.6_P7 to 8.7 error

Postby gadmin » Wed Aug 31, 2016 3:35 pm

Hi Bill

First, thanks very much for your help so far, I really appreciate it.

I'll try to describe my problem more precisely in short.
The thing is that i have the 8.6_P7 version of ZCS_OSS where i didn't enable the proxy & memcached because it wasn't necessary. Probably that's why proxy & memcached are not detectable when i start to run the install.sh file of ZCS_OSS version 8.7. SO of course it ends with an error message:

Code: Select all

CS upgrade from 8.6.0 to 8.7.0 will be performed.
Checking for existing proxy service in your environment
Error: proxy not enabled
Error: No proxy detected in your environment. Proxy is required for ZCS 8.7+.
See https://wiki.zimbra.com/wiki/Enabling_Zimbra_Proxy for details on installing proxy.
Checking for existing memcached service in your environment
Error: memcached not enabled
Error: No memcached detected in your environment. Memcached is required for ZCS 8.7+.
See https://wiki.zimbra.com/wiki/Enabling_Zimbra_Memcached for details on installing memcached.
Proxy and Memcached services must exist. Exiting...



But! As the installation can't be performed because of this, of course I can't enable proxy & memcached using version 8.7 which means that I should do that in version 8.6 before I try to install version 8.7.
Here comes the next problem! The original version that i installed was version 8.6 and since then i have patched it several times, and now my version is ZCS_OSS 8.6_P7.
Well, as I know, I can only enable proxy & memcached using the original 8.6 installation package, but I worry that doing so I might lose patches (P1 - P7) and because of this I might also lose data and configuration from the database. Or maybe, and here is my big question, there is another way to enable proxy & memcached in for example ZCS_OSS 8.6_P7? Or maybe you have some other ideas how to do it?

As I said, I have read the Wiki articles, but they dont't have any information regarding this question, and this is why I am a bit confused right now and I feel I am a little stuck in the process.

thanks for your reply,

regards

gadmin
thonglm
Posts: 12
Joined: Mon Aug 29, 2016 12:54 pm

Re: ZCS 8.6_P7 to 8.7 error

Postby thonglm » Fri Sep 09, 2016 6:51 am

Add proxy for shell env (for zimbra repository key import) and proxy for apt/yum (for download packages from zimbra)

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 4 guests