Dificuldade com o proxy depois do upgrade [SOLVED]

Ask questions about your setup or get help installing ZCS server (ZD section below).
systemcrash
Posts: 7
Joined: Wed Aug 31, 2016 2:45 pm

Dificuldade com o proxy depois do upgrade [SOLVED]

Postby systemcrash » Wed Aug 31, 2016 2:49 pm

Possuo um Centos 6.5 fiz o upgrade da versão 8.6 para 8.7

quando vou inciar o zimbra aparece a mensagem:

Starting proxy...Failed.
Starting proxy...nginx: [emerg] invalid URL prefix in /opt/zimbra/conf/nginx/includes/nginx.conf.zmlookup:3
failed.

alguém poderia me dar algum norte sobre como resolver isso?
Last edited by systemcrash on Wed Oct 26, 2016 1:10 pm, edited 1 time in total.


phoenix
Ambassador
Ambassador
Posts: 25598
Joined: Fri Sep 12, 2014 9:56 pm

Re: Dificuldade com o proxy depois do upgrade

Postby phoenix » Wed Aug 31, 2016 6:10 pm

These are English language forums, you need to post in English here.

You need to enable the proxy and memcached before the upgrade then run the upgrade again.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
systemcrash
Posts: 7
Joined: Wed Aug 31, 2016 2:45 pm

Re: Dificuldade com o proxy depois do upgrade

Postby systemcrash » Wed Aug 31, 2016 6:24 pm

Sorry man, in english now

Before upgrade proxy and mencache already configurated and works normaly
After upgrade someone proxy fails to start and show these mensage.

thanks for reply.
systemcrash
Posts: 7
Joined: Wed Aug 31, 2016 2:45 pm

Re: Dificuldade com o proxy depois do upgrade

Postby systemcrash » Wed Aug 31, 2016 7:43 pm

Hi,

I run again ./install for upgrade zimbra, no log erros on process

When I start zimbra services proxy fails with the same message.

Starting proxy...Failed.
Starting proxy...nginx: [emerg] invalid URL prefix in /opt/zimbra/conf/nginx/includes/nginx.conf.zmlookup:3
failed.

Look on archive /opt/zimbra/conf/nginx/includes/nginx.conf.zmlookup


zm_lookup_allow_unqualified off;


# URL prefix for the upstream server
zm_prefix_url /;


This information is correct?
systemcrash
Posts: 7
Joined: Wed Aug 31, 2016 2:45 pm

Re: Dificuldade com o proxy depois do upgrade

Postby systemcrash » Wed Sep 14, 2016 10:45 am

Sorry man, but not resolve this question.

If anyone have a clean install please confirm for me if the archive /opt/zimbra/conf/nginx/includes/nginx.conf.zmlookup contain:

zm_lookup_allow_unqualified off;


# URL prefix for the upstream server
zm_prefix_url /;
igonzalez
Posts: 1
Joined: Wed Oct 26, 2016 10:05 am

Re: Dificuldade com o proxy depois do upgrade

Postby igonzalez » Wed Oct 26, 2016 10:18 am

Edit file /opt/zimbra/conf/nginx/includes/nginx.conf.zmlookup
Modify URL

Code: Select all

zm_lookup_handlers https://email.hostname.by:7072/service/extension/nginx-lookup;


Disabled module chunkin because is no longer needed for Nginx 1.3.9+ because since 1.3.9, the Nginx core already has built-in support for the chunked request bodies. Verify Nginx version: nginx -v
Edit file /opt/zimbra/conf/nginx/includes/nginx.conf.web
Comment line

Code: Select all

# chunkin on;


Edit file /opt/zimbra/conf/nginx/includes/nginx.conf.web.https.default
Modify lines

Code: Select all

#chunkin handler
   # location @chunkin_handler {
   #     chunkin_resume;
   # }
 


Restart proxy service

Code: Select all

 zmproxyctl restart


Reference
http://slava-boor.livejournal.com/31166.html
systemcrash
Posts: 7
Joined: Wed Aug 31, 2016 2:45 pm

Re: Dificuldade com o proxy depois do upgrade

Postby systemcrash » Wed Oct 26, 2016 12:48 pm

Great man!

Solve my problem!

Very thanks man :D :D :D
User avatar
maumar
Outstanding Member
Outstanding Member
Posts: 366
Joined: Fri Sep 12, 2014 10:28 pm

Re: Dificuldade com o proxy depois do upgrade [SOLVED]

Postby maumar » Mon Apr 30, 2018 3:56 pm

Hello
Ubuntu 14
after upgrade from 8.6.0 to 8.8.8.
I get:
Starting proxy...nginx: [emerg] invalid URL prefix in /opt/zimbra/conf/nginx/includes/nginx.conf.zmlookup:3
In Centos6, instead, there is any occurrence of chunkin
It seems a bug in Ubuntu14 upgrade script

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 5 guests