Proxy and Memcached issue

Ask questions about your setup or get help installing ZCS server (ZD section below).
bhwong
Advanced member
Advanced member
Posts: 151
Joined: Thu Feb 27, 2014 8:40 pm

Proxy and Memcached issue

Postby bhwong » Thu Dec 01, 2016 8:20 am

I read that to upgrade to 8.7x, we will need to install Proxy and Memcached first. However, I notice that 8.7 installation do not have the option to install them, so it mean that I have to install them in the previous version first.

Yet I was told that for my setup which do not require them, installing Proxy and Memcached will affect my email server. Does this mean that I have to reinstall my current version (8.0.9) with Proxy and Memcached, then proceed to upgrade to 8.71 immediately?

I also found out that many admins have encounter the Proxy causing webmail to hangs every few hours:
viewtopic.php?f=13&t=60503&p=271836&hilit=ubuntu+12#p271836

Their workaround is to disable it. Since this is the case now, is it possible to upgrade and bypass the check for proxy since we are going to disable it anyway?

btw, I also encounter another error while upgrading my cloned Zimbra in my test environment:
Error: Unable to contact the LDAP server

I have to return as Zimbra user to start LDAP and exit back to root user to restart the installation to overcome the LDAP issue. Is this a known bug? Or I shouldn't stop Zimbra services before upgrading?


vchong68
Posts: 19
Joined: Sat Apr 30, 2016 4:45 am
Location: Singapore
ZCS/ZD Version: Release 8.7.11.GA.1854.UBUNTU16.64

Re: Proxy and Memcached issue

Postby vchong68 » Thu Dec 01, 2016 8:40 am

My experience was from 8.6 to 8.71 (FOSS) on Ubuntu 14.04 succeeded after numerous failures:

After full backup zimbra and snapshot the vm:

1) I have to enable proxy and dnscache first and make sure they function well. I have done that according to the wiki: https://wiki.zimbra.com/wiki/Zimbra_Pro ... mbra_Proxy
One obsticle I encountered was I have to remove the bind9 on the host.

2) Run install.sh without zimbra stopping.
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2773
Joined: Thu May 22, 2014 4:47 pm

Re: Proxy and Memcached issue

Postby jorgedlcruz » Thu Dec 01, 2016 2:41 pm

Hi bhwong,
You will need to install the proxy and memcached for ZCS 8.0.9, then you can move to ZCS 8.7.1

Best regards
Jorge de la Cruz https://jorgedelacruz.es
Systems Engineer at Veeam Software https://www.veeam.com/
bhwong
Advanced member
Advanced member
Posts: 151
Joined: Thu Feb 27, 2014 8:40 pm

Re: Proxy and Memcached issue

Postby bhwong » Fri Dec 02, 2016 6:47 am

I have tried reinstalling 8.0.9 with Proxy and memcached. However, I still cannot upgrade to 8.7.1 because it said my proxy has not been enabled. I try to enable it by following the instruction here:

https://wiki.zimbra.com/wiki/Zimbra_Pro ... _Servers_2

However, there is NO zmproxyconfig in /opt/zimbra/libexec/zmproxyconfig for me to proceed. Is zmproxyconfig not installed even when I have selected Y to install proxy?
bhwong
Advanced member
Advanced member
Posts: 151
Joined: Thu Feb 27, 2014 8:40 pm

Re: Proxy and Memcached issue

Postby bhwong » Fri Dec 02, 2016 6:49 am

I found your post with similar problem: viewtopic.php?t=59069

I followed your instruction to manually install them resolve the problem:

Code: Select all

dpkg -i zimbra-memcached_8.0.9.GA.6191.UBUNTU14.64_amd64.deb zimbra-proxy_8.0.9.GA.6191.UBUNTU14.64_amd64.deb


However, this didn't run:

Code: Select all

/opt/zimbra/libexec/zmproxyconfig -e -m -o -i 7143:143:7993:993 -p 7110:110:7995:995 -H mydomain.com
bhwong
Advanced member
Advanced member
Posts: 151
Joined: Thu Feb 27, 2014 8:40 pm

Re: Proxy and Memcached issue

Postby bhwong » Fri Dec 02, 2016 7:18 am

btw, how can I bypass the license expiry check for testing my upgrade in the test environment? There is a 5 times activation limit as well right?
vchong68
Posts: 19
Joined: Sat Apr 30, 2016 4:45 am
Location: Singapore
ZCS/ZD Version: Release 8.7.11.GA.1854.UBUNTU16.64

Re: Proxy and Memcached issue

Postby vchong68 » Fri Dec 02, 2016 8:13 am

bhwong wrote:I found your post with similar problem: viewtopic.php?t=59069

I followed your instruction to manually install them resolve the problem:

Code: Select all

dpkg -i zimbra-memcached_8.0.9.GA.6191.UBUNTU14.64_amd64.deb zimbra-proxy_8.0.9.GA.6191.UBUNTU14.64_amd64.deb


However, this didn't run:

Code: Select all

/opt/zimbra/libexec/zmproxyconfig -e -m -o -i 7143:143:7993:993 -p 7110:110:7995:995 -H mydomain.com


At first I hit this problem too.

lsof -i:7143,7993,7110,7885 to check the status of the ports.

Stop the service and perform:
/opt/zimbra/libexec/zmproxyconfig -e -m -o -i 7143:143:7993:993 -H yourdomian.com
/opt/zimbra/libexec/zmproxyconfig -e -m -o -p 7110:110:7995:995 -H yourdomain.com
bhwong
Advanced member
Advanced member
Posts: 151
Joined: Thu Feb 27, 2014 8:40 pm

Re: Proxy and Memcached issue

Postby bhwong » Fri Dec 02, 2016 8:50 am

I managed to get the installation going and was disappointed that it take so long to download additional files. Why can't it let us download them to save the upgrade time in order to minimize the downtime?

Also, after it has done with the download, it stop zimbra services and prompt me for zimbra password. How do I find out the default zimbra password???
vchong68
Posts: 19
Joined: Sat Apr 30, 2016 4:45 am
Location: Singapore
ZCS/ZD Version: Release 8.7.11.GA.1854.UBUNTU16.64

Re: Proxy and Memcached issue

Postby vchong68 » Fri Dec 02, 2016 9:02 am

bhwong wrote:I managed to get the installation going and was disappointed that it take so long to download additional files. Why can't it let us download them to save the upgrade time in order to minimize the downtime?

Also, after it has done with the download, it stop zimbra services and prompt me for zimbra password. How do I find out the default zimbra password???


paste these to the last of /etc/sudoers may solve the password prompts:

%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmstat-fd *
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmslapd
%zimbra ALL=NOPASSWD:/opt/zimbra/postfix/sbin/postfix, /opt/zimbra/postfix/sbin/postalias, /opt/zimbra/postfix/sbin/qshape.pl, /opt/zimbra/postfix/sbin/postconf,/opt/zimbra/postfix/sbin/postsuper
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmqstat,/opt/zimbra/libexec/zmmtastatus
%zimbra ALL=NOPASSWD:/opt/zimbra/amavisd/sbin/amavis-mc
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmunbound
%zimbra ALL=NOPASSWD:/sbin/resolvconf *
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmmailboxdmgr
%zimbra ALL=NOPASSWD:/opt/zimbra/bin/zmcertmgr
%zimbra ALL=NOPASSWD:/opt/zimbra/nginx/sbin/nginx
bhwong
Advanced member
Advanced member
Posts: 151
Joined: Thu Feb 27, 2014 8:40 pm

Re: Proxy and Memcached issue

Postby bhwong » Fri Dec 02, 2016 9:32 am

Thanks vchong68!

So the instruction given on the wiki is incorrect, because I need to split them up into two command lines right?

From:

Code: Select all

/opt/zimbra/libexec/zmproxyconfig -e -m -o -i 7143:143:7993:993 -p 7110:110:7995:995 -H mydomain.com

To:

Code: Select all

/opt/zimbra/libexec/zmproxyconfig -e -m -o -i 7143:143:7993:993 -H yourdomian.com
/opt/zimbra/libexec/zmproxyconfig -e -m -o -p 7110:110:7995:995 -H yourdomain.com


Also, I found this: https://wiki.zimbra.com/wiki/Sudoers

It suggest that I also change Defaults from env_reset to requiretty. Is this necessary?

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 7 guests