Use the repository to upgrade?

Ask questions about your setup or get help installing ZCS server (ZD section below).
6125amartin
Advanced member
Advanced member
Posts: 63
Joined: Sat Sep 13, 2014 1:45 am

Use the repository to upgrade?

Postby 6125amartin » Tue Feb 07, 2017 9:16 pm

I am running ZCS 8.7.0 open-source edition on Ubuntu 14.04. I would like to upgrade to ZCS 8.7.2, but the upgrade documentation seems to just say to download the new tarball and run ./install.sh. I enabled the repositories when I did the ZCS 8.7.0 install, so why can't I simply apt-get update && apt-get install zimbra-core to upgrade? If upgrading via the packages isn't supported, what is the purpose of the repository?


User avatar
DualBoot
Elite member
Elite member
Posts: 1308
Joined: Mon Apr 18, 2016 8:18 pm
Location: France - Earth
ZCS/ZD Version: ZCS FLOSS - 8.8.15 Mutli servers
Contact:

Re: Use the repository to upgrade?

Postby DualBoot » Wed Feb 08, 2017 10:17 am

For the moment it is a transition period I think.
glenndm
Advanced member
Advanced member
Posts: 109
Joined: Fri Sep 12, 2014 10:35 pm
ZCS/ZD Version: Zimbra 8.8.8_GA_2009 (build 2018032

Re: Use the repository to upgrade?

Postby glenndm » Wed Jul 11, 2018 8:49 am

Hello,
I am sure this has been asked and answered before. but my forum searches result in unrelated hits and wiki and I do not get along.

I'm running 8.8.8 NE looking to install the 8.8.9 version

- Is apt-get upgrade the recommended method to get the upgrades?
Is a full system backup advisable beforehand? Normally I don't do this when using apt-get.

- Do I still need to manually install the new version using the release?

best regards
phoenix
Ambassador
Ambassador
Posts: 26697
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: Use the repository to upgrade?

Postby phoenix » Wed Jul 11, 2018 8:55 am

The quick answer is yes, you need to download the package from the Zimbra Downloads page - only some of the packages are provided via the repository.
Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
glenndm
Advanced member
Advanced member
Posts: 109
Joined: Fri Sep 12, 2014 10:35 pm
ZCS/ZD Version: Zimbra 8.8.8_GA_2009 (build 2018032

Re: Use the repository to upgrade?

Postby glenndm » Wed Jul 11, 2018 9:25 am

Thank you for the quick answer :)

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 3 guests