How to upgrade from 8.6.0

Ask questions about your setup or get help installing ZCS server (ZD section below).
phoenix
Ambassador
Ambassador
Posts: 26727
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: How to upgrade from 8.6.0

Postby phoenix » Fri May 05, 2017 3:54 pm

You'll find full details on upgrading to 8.7.x and installing the proxy on the following wiki pages:

https://wiki.zimbra.com/wiki/Zimbra_Rel ... .0/Upgrade
https://wiki.zimbra.com/wiki/Enabling_Z ... ng_servers


Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
tom11011
Posts: 15
Joined: Sat Sep 13, 2014 2:52 am

How to upgrade from 8.6.0

Postby tom11011 » Fri May 05, 2017 4:00 pm

Hello, running 8.6.0_GA_1191.NETWORK

This was installed without the proxy. I believe it was optional with this release.

How do I go about getting upgraded to the latest version? Is there a howto somewhere that addresses this? I tried to do it but it flagged not having the proxy installed. Not sure of the best way to proceed. This is a single server.

Any help appreciated, thanks.
User avatar
Raun
Zimbra Employee
Zimbra Employee
Posts: 75
Joined: Thu Mar 24, 2016 1:22 pm

Re: How to upgrade from 8.6.0

Postby Raun » Sun May 07, 2017 4:21 am

You need to first get proxy and memcached installed and working on 8.6 before upgrading to 87. Follow this to get it working. Once it is done then upgrade to 8.7

https://wiki.zimbra.com/wiki/Enabling_Z ... _memcached
gtinetworks
Posts: 5
Joined: Mon May 09, 2016 3:16 pm

Re: How to upgrade from 8.6.0

Postby gtinetworks » Wed Jun 07, 2017 8:54 pm

Please ignore the following. I just figured it out. I would delete my post if I knew how. Thanks, Kevin


Hi,

I am also having problems with this process. I am trying to follow the steps listed on https://wiki.zimbra.com/wiki/Zimbra_Pro ... mbra_Proxy, specifically

/opt/zimbra/libexec/zmproxyconfig -e -w -o -a 8080:80:8443:443 -x <both> -H `zmhostname`

and I get the following message: -bash: zmhostname: command not found

It appears I cannot run any command with 'zmhostname' in it.

./zmprov gs `zmhostname` | grep -i imap gives me the same error: -bash: zmhostname: command not found

I found a post that said to try su zimbra first. I did that and now I get: bash: both: Permission denied

Any help or suggestions would be greatly appreciated.

Thank you,
Kevin
budy
Posts: 26
Joined: Sat Sep 13, 2014 2:07 am

Re: How to upgrade from 8.6.0

Postby budy » Thu Jun 08, 2017 5:48 pm

Just replace 'zmhostname' with the actual hostname of your Zimbra host.

Cheers,
budy

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 7 guests