Page 2 of 2

Re: ZCS 8.8 upgrade failed with IPv6 enabled

Posted: Thu Sep 07, 2017 2:04 pm
by maxxer
phoenix wrote:Edit the following file and remove the first stanza i.e. just the code in the box below:


I came up with a different patch on the bug: according to docs it's possible to have two stanzas like that, but just one must have the ipv6only=no option (not very familiar with german but found it here).

Theoretically the first stanza catches unknown requests, while the seconds the one for Zimbra's hostname

Re: ZCS 8.8 upgrade failed with IPv6 enabled

Posted: Thu Sep 07, 2017 2:05 pm
by phoenix
Yes, the mail delivery seems to be working fine but I'm seeing a lot of 'timed out' messages for my IPv6 address:

Sep 7 16:18:31 mail01 postfix/lmtp[97421]: connect to mail01.mydomain.com[2a01:e0a:6e:c119:224:83ef:fe86:5606]:7025: Connection timed out

Re: ZCS 8.8 upgrade failed with IPv6 enabled

Posted: Thu Sep 07, 2017 2:15 pm
by phoenix
maxxer wrote:
phoenix wrote:Yes, the mail delivery seems to be working fine but I'm seeing a lot of 'timed out' messages for my IPv6 address:

Sep 7 16:18:31 mail01 postfix/lmtp[97421]: connect to mail01.mydomain.com[2a01:e0a:6e:c119:224:83ef:fe86:5606]:7025: Connection timed out

7025 is not a proxy managed port. I have java listening there (8.7.11)
Strange, this is the 8.8.3 after an upgrade earlier today - I'll check those ports.

Re: ZCS 8.8 upgrade failed with IPv6 enabled

Posted: Thu Sep 07, 2017 2:17 pm
by maxxer
phoenix wrote:That's a more elegant solution than mine, I tend to go for the sledgehammer approach as I'm a novice. :) I'll try your patch shortly and post back here.

I'd not define you a novice :D :D :D

Great if you can test! If you can also report back on the bug as well.. Thanks!

Re: ZCS 8.8 upgrade failed with IPv6 enabled

Posted: Thu Sep 07, 2017 2:26 pm
by maxxer
phoenix wrote:Yes, the mail delivery seems to be working fine but I'm seeing a lot of 'timed out' messages for my IPv6 address:

Sep 7 16:18:31 mail01 postfix/lmtp[97421]: connect to mail01.mydomain.com[2a01:e0a:6e:c119:224:83ef:fe86:5606]:7025: Connection timed out

7025 is not a proxy managed port. I have java listening there (8.7.11)

Re: ZCS 8.8 upgrade failed with IPv6 enabled

Posted: Thu Sep 07, 2017 2:35 pm
by maxxer

Re: ZCS 8.8 upgrade failed with IPv6 enabled

Posted: Thu Sep 07, 2017 2:36 pm
by phoenix
maxxer wrote:Port 7025 is mailboxd

https://wiki.zimbra.com/wiki/Ports
Those 'timed out' messages seem to be coming only from a local delivery email when I restart ZCS other inbound mail seems to be working OK. I don't, as yet, have any inbound mail on IPv6.

I also seem to getting the following from dkimmilter (are they likely to be significant?):

Code: Select all

Sep  7 16:49:21 mail01 postfix/dkimmilter/smtpd[119985]: disconnect from localhost.localdomain[::1] ehlo=1 mail=1 rcpt=1 data=1 commands=4
Sep  7 16:49:22 mail01 postfix/dkimmilter/smtpd[119964]: timeout after END-OF-MESSAGE from localhost.localdomain[::1]

Re: ZCS 8.8 upgrade failed with IPv6 enabled

Posted: Thu Sep 07, 2017 3:09 pm
by phoenix
maxxer wrote:
phoenix wrote:I also seem to getting the following from dkimmilter (are they likely to be significant?):

Code: Select all

Sep  7 16:49:21 mail01 postfix/dkimmilter/smtpd[119985]: disconnect from localhost.localdomain[::1] ehlo=1 mail=1 rcpt=1 data=1 commands=4
Sep  7 16:49:22 mail01 postfix/dkimmilter/smtpd[119964]: timeout after END-OF-MESSAGE from localhost.localdomain[::1]


I do have them on 8.7.11, harmless
Yes, I've just checked back through my splunk logs and there are those messages that predate the upgrade to IPv6 and the 8.8.3 install earlier today. Panic over. :)

Re: ZCS 8.8 upgrade failed with IPv6 enabled

Posted: Thu Sep 07, 2017 3:21 pm
by maxxer
phoenix wrote:I also seem to getting the following from dkimmilter (are they likely to be significant?):

Code: Select all

Sep  7 16:49:21 mail01 postfix/dkimmilter/smtpd[119985]: disconnect from localhost.localdomain[::1] ehlo=1 mail=1 rcpt=1 data=1 commands=4
Sep  7 16:49:22 mail01 postfix/dkimmilter/smtpd[119964]: timeout after END-OF-MESSAGE from localhost.localdomain[::1]


I do have them on 8.7.11, harmless

Re: ZCS 8.8 upgrade failed with IPv6 enabled

Posted: Thu Sep 07, 2017 9:02 pm
by ppearl
This issue appears to be more fallout from the fix for https://bugzilla.zimbra.com/show_bug.cgi?id=107963.
Also, as mentioned earlier using ipv6only=off more than once seems wrong (per the docs,
and noted server behavior. ref: http://nginx.org/en/docs/http/ngx_http_core_module.html#listen).

Digging deeper, (and corresponding with Rick for testing) it appears that 'both' mode may have been not listening on ipv4 as it was supposed to anyway. So, the proposed "fixes" so far will get nginx up, but perhaps not in the desired mode. Details will probably follow in Bug 108293.