Page 1 of 1

zmtlsctl fails to set the Web Server Mode

Posted: Wed Sep 20, 2017 2:13 pm
by mrgreiner
Hi,

I've just upgraded my Zimbra from 8.0.7 to 8.7, and installed a commercial SSL certificate. Both HTTP and HTTPS are working fine, but I would like to push all users to use HTTPS. To that, I saw that I should use zmtlsctl . The problem is that the command is failing with the following output:

[zimbra@webmail2 ~]$ zmtlsctl redirect
Attempting to query proxy (zimbra.<my domain>) settings for zimbraReverseProxyMailMode and zimbraReverseProxySSLToUpstreamEnabled.
Error: Unable to determine the proxy's value of zimbraReverseProxyMailMode

With other parameter values (like 'http', 'https', 'both',...) the error is the same.

Could somebody give me a help?

Tks.

Roberto

PS: Running ZCS 8.7, on a Centos 6.9 VM, with 600GB for /opt partition, 4GB RAM, 4CPUs.

Re: zmtlsctl fails to set the Web Server Mode

Posted: Thu Sep 20, 2018 2:58 pm
by nolly
Hi mrgreiner

I also have this issue, did you find how to fix this ?

Thanks

Re: zmtlsctl fails to set the Web Server Mode

Posted: Thu Nov 08, 2018 5:11 pm
by Simich
Hello!
Same problem here

Attempting to query proxy (mailserver.region.if.ua) settings for zimbraReverseProxyMailMode and zimbraReverseProxySSLToUpstreamEnabled.
Error: Unable to determine the proxy's value of zimbraReverseProxyMailMode

Any solution found yet?

Re: zmtlsctl fails to set the Web Server Mode

Posted: Thu Nov 08, 2018 5:51 pm
by phoenix
Simich wrote:Any solution found yet?
Why don't you just check it's current status then set it manually?

https://wiki.zimbra.com/wiki/SecureConfiguration
https://wiki.zimbra.com/wiki/Zimbra_Proxy_Manual:Installing_,_Configuring,_Disabling_the_Zimbra_Proxy