[SOLVED] Webmail problem after upgrade to 8.8.5 open source

Ask questions about your setup or get help installing ZCS server (ZD section below).
henk@boschker.net
Posts: 8
Joined: Fri Dec 22, 2017 9:47 am

[SOLVED] Webmail problem after upgrade to 8.8.5 open source

Postby henk@boschker.net » Fri Dec 22, 2017 10:11 am

Release 8.8.5.GA.1894.UBUNTU16.64 UBUNTU16_64 FOSS edition.

After upgrade from 8.7.11 to 8.8.5 webmail disconnected connection after receiving cert, which is own certified.
My mailserver is behind a firewall and all local webclients work ok..
the firewall is redirecting port 443 to 443 from the zimbra server.
so https://mailserver.domain.xxx is not working and https://mailserver.domain.local works fine.

Thank you for your answer.
Henk


axslingr
Advanced member
Advanced member
Posts: 91
Joined: Sat Sep 13, 2014 2:20 am
ZCS/ZD Version: Release 8.8.9.GA.3019.UBUNTU14.64

Re: Webmail problem after upgrade to 8.8.5 open source

Postby axslingr » Sat Dec 23, 2017 5:26 am

Try editing the domain in the admin console and add a virtual host for the one that isn't working.

Lance
henk@boschker.net
Posts: 8
Joined: Fri Dec 22, 2017 9:47 am

Re: Webmail problem after upgrade to 8.8.5 open source

Postby henk@boschker.net » Sat Dec 23, 2017 3:55 pm

Thanks for the answer Lance.

I have tried all configuratio options fotr https for the public domain without any result.
I also tried your suggestion for adding virtual host to the domain in the admin console. That is more on user side.

To be more specific to the problem, on the public domain i do not get an login screen. in the left hand bottom of firefox it says executing TLS handschaking on the domain and then it stops with a connection failure.

Maybe this is helpfull for a next suggestion.
axslingr
Advanced member
Advanced member
Posts: 91
Joined: Sat Sep 13, 2014 2:20 am
ZCS/ZD Version: Release 8.8.9.GA.3019.UBUNTU14.64

Re: Webmail problem after upgrade to 8.8.5 open source

Postby axslingr » Sun Dec 24, 2017 1:39 pm

henk@boschker.net wrote:To be more specific to the problem, on the public domain i do not get an login screen. in the left hand bottom of firefox it says executing TLS handschaking on the domain and then it stops with a connection failure.
.


So you added a virtual host of mailserver.domain.xxx to the domain mailserver.domain.local?

Lance
henk@boschker.net
Posts: 8
Joined: Fri Dec 22, 2017 9:47 am

Re: Webmail problem after upgrade to 8.8.5 open source

Postby henk@boschker.net » Sun Dec 24, 2017 4:51 pm

Not at first but just now I did, with same result. No improvement.

I wish you a merry Christmas.
henk@boschker.net
Posts: 8
Joined: Fri Dec 22, 2017 9:47 am

Re: Webmail problem after upgrade to 8.8.5 open source

Postby henk@boschker.net » Sun Dec 24, 2017 5:03 pm

Just discovered another thing.
https://mailserver.domain.local gives login screen, but
https://10.0.1.52 does not do that.

On the live server I get a login screen in both situations; https:://livemail.thuis.local and https://10.0.1.61.
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

Re: Webmail problem after upgrade to 8.8.5 open source

Postby jorgedlcruz » Mon Dec 25, 2017 3:55 am

Hello,
The using only the IP issue is a known issue, we mentioned it on this forums in multiple threads, which will be handled better in ZCS 8.8.6, if you need to still accessing using the IP use the port 8443, which connects to the jetty server instead if nginx.

Best regards
Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
henk@boschker.net
Posts: 8
Joined: Fri Dec 22, 2017 9:47 am

Re: Webmail problem after upgrade to 8.8.5 open source

Postby henk@boschker.net » Wed Dec 27, 2017 6:08 pm

Hello,

The use of only an IP number is not crucia l for me.

Getting a loginscreen on a webbrowser, when behind a firewall is crucial.
So I am back on 8.7.11 which works fine.

Regards, Henk.
User avatar
jorgedlcruz
Zimbra Alumni
Zimbra Alumni
Posts: 2769
Joined: Thu May 22, 2014 4:47 pm

Re: Webmail problem after upgrade to 8.8.5 open source

Postby jorgedlcruz » Wed Dec 27, 2017 7:47 pm

Hello,
Glad to hear. Still the problem could be with something at virtualhostname configuration.

Best regards
Jorge de la Cruz https://jorgedelacruz.es
Technical Marketing Manager at Zimbra/Synacor https://www.zimbra.com/
henk@boschker.net
Posts: 8
Joined: Fri Dec 22, 2017 9:47 am

Re: [SOLVED] Webmail problem after upgrade to 8.8.5 open source

Postby henk@boschker.net » Fri Dec 29, 2017 2:16 pm

Hello,

The problem on 8.8.5 is that I had to configure a virtual host, but not as mentioned earlier.
Quote: So you added a virtual host of mailserver.domain.xxx to the domain mailserver.domain.local?

I configured the local mailserver.domain.local, which is the real zimbra server, as a virtual host for the domain.net.

That did the trick.
Thank all of you for your help.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 9 guests