Issue upgrading from 8.6.0 Community

Ask questions about your setup or get help installing ZCS server (ZD section below).
kazabe
Posts: 22
Joined: Fri Sep 12, 2014 11:42 pm

Issue upgrading from 8.6.0 Community

Postby kazabe » Sat Jan 13, 2018 1:08 pm

Hi.

Im trying to upgrade a zimbra zcs-8.6.0_GA_1153.UBUNTU12_64. to lastest version.

First upgrade the ubuntu to 14.04 and upgrade zimbra for that version. zcs-8.6.0_GA_1153.UBUNTU14.

All work fine. But when try to upgrade to 8.7.11 or 8.8.5, the process stop with this message:

Use Zimbra's package repository [Y]

Configuring package repository
ERROR: Unable to install packages via apt-get
Please fix system to allow normal package installation before proceeding

I install a virtual machine to try to replicate the error and all process was successfull passing from ubuntu 12.04 to 16.04 with zimbra 8.8.5.

    1. upgrade ubuntu 12.04 to 14.04
    2. upgrade zimbra 8.6.0 to ubuntu 14.04 version
    3. upgrade zimbra to 8.8.5 for ubuntu 14.04
    4. upgrade ubuntu 14.04 to 16.04 [check keep enabled the third repos for zimbra]
    5. upgrade zimbra 8.8.5 to ubuntu 16.04 version
    6. (Optional) and they lived happily ever after ;)


in the test server all the process work fluid without any issue, but in the production server, the process die at the step 3.

I try to fix it running

Code: Select all

apt-get install -f


but receive this (my apologies for the language in this log)

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
zimbra-libevent-lib zimbra-memcached-base
Use 'apt-get autoremove' to remove them.
Se instalarán los siguientes paquetes extras:
zimbra-osl zimbra-perl-mail-spamassassin zimbra-spamassassin-rules
Se instalarán los siguientes paquetes NUEVOS:
zimbra-osl zimbra-perl-mail-spamassassin zimbra-spamassassin-rules
0 actualizados, 3 se instalarán, 0 para eliminar y 8 no actualizados.
6 no instalados del todo o eliminados.
Se necesita descargar 0 B/994 kB de archivos.
Se utilizarán 6.090 kB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n]
(Leyendo la base de datos ... 153538 ficheros o directorios instalados actualmente.)
Preparing to unpack .../zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb ...
Unpacking zimbra-osl (1.0.9-1zimbra8.7b1.14.04) ...
dpkg: error processing archive /var/cache/apt/archives/zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb (--unpack):
intentando sobreescribir `/opt/zimbra/docs/open_source_licenses.txt', que está también en el paquete zimbra-core 8.6.0.GA.1153.UBUNTU14.64
dpkg-deb: error: el subproceso copiado fue terminado por la señal (Broken pipe)
Preparing to unpack .../zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b2.14.04_all.deb ...
Unpacking zimbra-perl-mail-spamassassin (3.4.1-1zimbra8.7b2.14.04) ...
dpkg: error processing archive /var/cache/apt/archives/zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b2.14.04_all.deb (--unpack):
intentando sobreescribir `/opt/zimbra/data/spamassassin/localrules/v340.pre', que está también en el paquete zimbra-mta 8.6.0.GA.1153.UBUNTU14.64
dpkg-deb: error: el subproceso copiado fue terminado por la señal (Broken pipe)
Preparing to unpack .../zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb ...
Unpacking zimbra-spamassassin-rules (1.0.0-1zimbra8.7b1.14.04) ...
dpkg: error processing archive /var/cache/apt/archives/zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb (--unpack):
intentando sobreescribir `/opt/zimbra/data/spamassassin/rules/72_active.cf', que está también en el paquete zimbra-mta 8.6.0.GA.1153.UBUNTU14.64
dpkg-deb: error: el subproceso copiado fue terminado por la señal (Broken pipe)
Se encontraron errores al procesar:
/var/cache/apt/archives/zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b2.14.04_all.deb
/var/cache/apt/archives/zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Any ideas to solve it?

Thanks and regards.


phoenix
Ambassador
Ambassador
Posts: 25468
Joined: Fri Sep 12, 2014 9:56 pm

Re: Issue upgrading from 8.6.0 Community

Postby phoenix » Sat Jan 13, 2018 1:19 pm

The one reason I suse CentOS instead of any distro that has apt as a package manager is because of problems like this. :( You might have broken packages in there, take a look at the answer in this thread and see if it helps: https://askubuntu.com/questions/118749/ ... -to-fix-it

BTW, the easiest method of upgrading, especially if you're using a VM, is the move to a new server and the best tool for that is ZeXtras Migration Tool.

BTW, I removed your other post as your current thread is in the correct forum. ;)
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 13 guests