unary operator expected

Ask questions about your setup or get help installing ZCS server (ZD section below).
fbzimblet
Advanced member
Advanced member
Posts: 116
Joined: Sun Apr 17, 2016 4:15 pm

unary operator expected

Postby fbzimblet » Wed Jan 17, 2018 4:45 pm

ZCS 8.7.11 CentOS 6.6

When I re-run ./install
Below error appears.



Code: Select all

./util/utilfunc.sh: line 790: [: -lt: unary operator expected
./util/utilfunc.sh: line 790: [: too many arguments
Validating ldap configuration
Value "--vminor" invalid for option vmajor (number expected)
Value "--umajor" invalid for option vmicro (number expected)
Error: Unable to create a successful TLS connection to the ldap masters.
       Fix cert configuration prior to upgrading.


All services are stopped and bringing up would result in -bash: zmcontrol: command not found

How would I be able to reinstall/upgrade?


tpop
Posts: 1
Joined: Sun Mar 04, 2018 9:01 am

Re: unary operator expected

Postby tpop » Sun Mar 04, 2018 9:07 am

Bump up on this one.

I'm trying to get away from ZCS 8.7.1 on Ubuntu 12.0.4.

Going to 14.0.4, I've purged and reinstalled Perl and various perl lib and packages.

When I try to run ZCS 8.7.1 install.sh, I get the same error.
fbzimblet
Advanced member
Advanced member
Posts: 116
Joined: Sun Apr 17, 2016 4:15 pm

Re: unary operator expected

Postby fbzimblet » Tue Mar 06, 2018 12:41 am

you might have not just purged perl, but something more. Check your installed zimbra packages.

backup current zimbra folder and attempt DR recovery from wiki

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 3 guests