Page 1 of 2

Upgrade 8.7->8.8 - Admin Console port changed in Webmail UI?

Posted: Mon Feb 19, 2018 12:11 pm
by liverpoolfcfan
Hi

I am testing the upgrade process from 8.7 to 8.8 and for some reason in the upgrade process the port number in the Webmail client for the Admin Console link gets switched from the normal :7071 to :9071 - and as a result it fails to connect. If I manually change the port number in the new Admin Console Browser instance to :7071 then it connects as normal.

Is there a particular reason for this happening?

Where should it be changed so as to show the correct link?

Are there any other port numbers that get changed/broken under-the-covers?

Thanks

Re: Upgrade 8.7->8.8 - Admin Console port changed in Webmail UI?

Posted: Mon Feb 19, 2018 2:03 pm
by DualBoot
Hello,

9071 is for zimbraAdminProxyPort for the Nginx configuration.

Regards,

Re: Upgrade 8.7->8.8 - Admin Console port changed in Webmail UI?

Posted: Mon Feb 19, 2018 2:21 pm
by liverpoolfcfan
Right... but, I had never selected the check box for "proxy enabled" for the admin console, and in the old version the link in the webmail client was therefore set to 7071, whereas in the upraded version the checkbox is still not selected but the link in the webmail is set to 9071

Re: Upgrade 8.7->8.8 - Admin Console port changed in Webmail UI?

Posted: Mon Feb 19, 2018 4:45 pm
by DualBoot
I think it is because Nginx is now mandatory.

Re: Upgrade 8.7->8.8 - Admin Console port changed in Webmail UI?

Posted: Tue Feb 20, 2018 4:19 pm
by liverpoolfcfan
Nginx is mandatory for the admin console now?

Re: Upgrade 8.7->8.8 - Admin Console port changed in Webmail UI?

Posted: Tue Feb 20, 2018 6:32 pm
by DualBoot
Nope for the admin console, but for the installation.
Connecting directly to your store on port 7071 should work. But do not use the zimbraVirtualHostname to connect to, maybe the problem is here.

Re: Upgrade 8.7->8.8 - Admin Console port changed in Webmail UI?

Posted: Fri Jun 08, 2018 5:28 pm
by hisfran
Has anyone found a solution?
I have a similar problem on a Zimbra server version 8.7.7.GA.1787.NETWORK

In Webmail for delegated Admins, the Admin Console button launches https://zimbraserver:9071/zimbraAdmin/
and times out.
Until recently that Admin Console button was lauching https://zimbraserver:7071/zimbraAdmin/ which still works.

I checked and the server config does not enable proxy:
zimbraAdminProxyPort: 9071
zimbraReverseProxyAdminEnabled: FALSE

What else should I look for?


/Fran

Re: Upgrade 8.7->8.8 - Admin Console port changed in Webmail UI?

Posted: Mon Oct 08, 2018 6:53 pm
by eribertos
Hi

Did anyone know a solution?

the proxy option is enabled but gives the "connection refused" error on port 9071, I have identified that nginx is not listening on that port.

Hand does not go out

Re: Upgrade 8.7->8.8 - Admin Console port changed in Webmail UI?

Posted: Tue Oct 09, 2018 12:08 pm
by gabrieles
DualBoot wrote:I think it is because Nginx is now mandatory.

Proxy is mandatory since 8.7, and he's upgrading from 8.7... should have it

Re: Upgrade 8.7->8.8 - Admin Console port changed in Webmail UI?

Posted: Tue Nov 06, 2018 2:59 pm
by mla23
hisfran wrote:In Webmail for delegated Admins, the Admin Console button launches https://zimbraserver:9071/zimbraAdmin/
and times out.
Until recently that Admin Console button was lauching https://zimbraserver:7071/zimbraAdmin/ which still works.

I checked and the server config does not enable proxy:
zimbraAdminProxyPort: 9071
zimbraReverseProxyAdminEnabled: FALSE

What else should I look for?


/Fran


Hi Fran,

just ran into the same issue after upgrading to 8.8.10 from 8.6.
Got it fixed by setting the Parameter "zimbraWebClientAdminReference", to theAdmin-UI URL, which not set:

Code: Select all

zmprov mcf zimbraWebClientAdminReference "https://zimbraserver:7071/zimbraAdmin"


After reloading the webclient, it should be working again.

/Matthias