Zimbra 8.8.8 Has Been Released

Ask questions about your setup or get help installing ZCS server (ZD section below).
User avatar
L. Mark Stone
Elite member
Elite member
Posts: 2170
Joined: Wed Oct 09, 2013 11:35 am
Location: Portland, Maine, US
ZCS/ZD Version: 8.8.15 Network Edition
Contact:

Re: Zimbra 8.8.8 Has Been Released

Postby L. Mark Stone » Tue Apr 03, 2018 12:41 pm

Raun wrote:
L. Mark Stone wrote:
Raun wrote:Ztalk needs a separate/different license . Maybe that is the issue there with Ztalk not working properly. If you guys can DM me your case numbers open with Z support , I can look into them directly.


I opened Case 00710401 last week on this. FWIW, this case is no longer in my list of open nor closed cases, so I opened another case to ask the status.

Thanks for helping!

All the best,
Mark


Workaround:
Can you install zimbra-talk and check. zimbra-talk removes zimbra-chat package, undeploys chat zimlets, installs zimbra-talk package and deploys talk zimlets. We have observed that once zimbra-talk is installed and mailbox restarted, the port conflict issue gets resolved.

To install Zimbra-Talk:
Ubuntu:
As root, apt-get install zimbra-talk
su - zimbra
zmmailboxdctl restart

RHEL:
As root, yum install zimbra-talk
su - zimbra
zmmailboxdctl restart

If Talk license is not available, Talk zimlet would behave like Chat and Talk features are not made available to end user.
This has been identified as a bug and fix should be available in the upcoming release.

Here is the bug https://bugzilla.zimbra.com/show_bug.cgi?id=108906


Thanks for this; the workaround does not however work for me. I added comments in the bug.

All the best,
Mark


___________________________________
L. Mark Stone
Mission Critical Email - Zimbra VAR/BSP/Training Partner https://www.missioncriticalemail.com/
Zeta Alliance http://www.zetalliance.org/
User avatar
L. Mark Stone
Elite member
Elite member
Posts: 2170
Joined: Wed Oct 09, 2013 11:35 am
Location: Portland, Maine, US
ZCS/ZD Version: 8.8.15 Network Edition
Contact:

Re: Zimbra 8.8.8 Has Been Released

Postby L. Mark Stone » Tue Apr 03, 2018 6:30 pm

Hey Raun,

Thanks to John Hurley and David Bingham, we got the workaround to work on today's Zeta Alliance call. I've updated the Bugzilla accordingly.

Here for reference:

Workaround:

The administrator can install zimbra-talk. Zimbra-talk removes the zimbra-chat package, undeploys chat zimlets, installs the zimbra-talk package and deploys talk zimlets. We have observed that once zimbra-talk is installed and mailbox restarted, the port conflict issue gets resolved.

To install Zimbra-Talk (Ubuntu):
As root, apt-get install zimbra-talk
su - zimbra
zmmailboxdctl restart

RHEL:
As root, yum install zimbra-talk
su - zimbra
zmmailboxdctl restart

If Talk license is not available, the Talk zimlet will behave like Chat, and Talk features are not visible to end user.

After installing the Zimbra Talk zimlet (which removes the traditional Zimbra Chat zimlet) after upgrading to 8.8.8, the Talk zimlet (com_zextras_talk) must be:

-- Enabled in the Admin Console at the Home > Configure > Zimlet level
-- Enabled in every CoS in the Admin Console at the Home > Configure > Class of Service > (each specific CoS) > Zimlets level
-- Enabled for every user account which existed before the upgrade to 8.8.8 in the Admin Console at the Manage Accounts > (each specific account) > Zimlets level

Once all of the above was done, the Chat (Talk) window then presented OK, with the same functionality as the traditional Chat window (looks almost identical) -- even without a Talk license installed.

I'm guessing that once a Talk v2 license is installed, the end users will then be presented with the Talk tab in the web UI.

Hope that helps others,
Mark
___________________________________
L. Mark Stone
Mission Critical Email - Zimbra VAR/BSP/Training Partner https://www.missioncriticalemail.com/
Zeta Alliance http://www.zetalliance.org/
User avatar
Raun
Zimbra Employee
Zimbra Employee
Posts: 75
Joined: Thu Mar 24, 2016 1:22 pm

Re: Zimbra 8.8.8 Has Been Released

Postby Raun » Wed Apr 04, 2018 6:45 am

L. Mark Stone wrote:Hey Raun,

Thanks to John Hurley and David Bingham, we got the workaround to work on today's Zeta Alliance call. I've updated the Bugzilla accordingly.

Here for reference:

Workaround:

The administrator can install zimbra-talk. Zimbra-talk removes the zimbra-chat package, undeploys chat zimlets, installs the zimbra-talk package and deploys talk zimlets. We have observed that once zimbra-talk is installed and mailbox restarted, the port conflict issue gets resolved.

To install Zimbra-Talk (Ubuntu):
As root, apt-get install zimbra-talk
su - zimbra
zmmailboxdctl restart

RHEL:
As root, yum install zimbra-talk
su - zimbra
zmmailboxdctl restart

If Talk license is not available, the Talk zimlet will behave like Chat, and Talk features are not visible to end user.

After installing the Zimbra Talk zimlet (which removes the traditional Zimbra Chat zimlet) after upgrading to 8.8.8, the Talk zimlet (com_zextras_talk) must be:

-- Enabled in the Admin Console at the Home > Configure > Zimlet level
-- Enabled in every CoS in the Admin Console at the Home > Configure > Class of Service > (each specific CoS) > Zimlets level
-- Enabled for every user account which existed before the upgrade to 8.8.8 in the Admin Console at the Manage Accounts > (each specific account) > Zimlets level

Once all of the above was done, the Chat (Talk) window then presented OK, with the same functionality as the traditional Chat window (looks almost identical) -- even without a Talk license installed.

I'm guessing that once a Talk v2 license is installed, the end users will then be presented with the Talk tab in the web UI.

Hope that helps others,
Mark


Thanks for the update Mark. Have a great day ahead.
jtflottorp
Posts: 6
Joined: Mon Apr 14, 2014 2:17 am

Re: Zimbra 8.8.8 Has Been Released

Postby jtflottorp » Wed Apr 04, 2018 8:35 am

So we need a Talk V2 license to get the full Talk V2 experience?
User avatar
L. Mark Stone
Elite member
Elite member
Posts: 2170
Joined: Wed Oct 09, 2013 11:35 am
Location: Portland, Maine, US
ZCS/ZD Version: 8.8.15 Network Edition
Contact:

Re: Zimbra 8.8.8 Has Been Released

Postby L. Mark Stone » Wed Apr 04, 2018 1:36 pm

jtflottorp wrote:So we need a Talk V2 license to get the full Talk V2 experience?


Yes.
___________________________________
L. Mark Stone
Mission Critical Email - Zimbra VAR/BSP/Training Partner https://www.missioncriticalemail.com/
Zeta Alliance http://www.zetalliance.org/
hmmblah
Advanced member
Advanced member
Posts: 53
Joined: Fri Sep 12, 2014 11:44 pm
ZCS/ZD Version: Zimbra 8.8.10_GA_3041

Re: Zimbra 8.8.8 Has Been Released

Postby hmmblah » Sun Apr 08, 2018 3:45 am

Raun wrote:
L. Mark Stone wrote:
Raun wrote:Ztalk needs a separate/different license . Maybe that is the issue there with Ztalk not working properly. If you guys can DM me your case numbers open with Z support , I can look into them directly.


I opened Case 00710401 last week on this. FWIW, this case is no longer in my list of open nor closed cases, so I opened another case to ask the status.

Thanks for helping!

All the best,
Mark


Workaround:
Can you install zimbra-talk and check. zimbra-talk removes zimbra-chat package, undeploys chat zimlets, installs zimbra-talk package and deploys talk zimlets. We have observed that once zimbra-talk is installed and mailbox restarted, the port conflict issue gets resolved.

To install Zimbra-Talk:
Ubuntu:
As root, apt-get install zimbra-talk
su - zimbra
zmmailboxdctl restart

RHEL:
As root, yum install zimbra-talk
su - zimbra
zmmailboxdctl restart

If Talk license is not available, Talk zimlet would behave like Chat and Talk features are not made available to end user.
This has been identified as a bug and fix should be available in the upcoming release.

Here is the bug https://bugzilla.zimbra.com/show_bug.cgi?id=108906


Had the same issue on a migration to 8.8.8 today. This did the trick, thanks!
saschadd
Posts: 29
Joined: Tue Nov 01, 2016 7:50 pm
ZCS/ZD Version: 8.8.11_GA_3737.RHEL7

Re: Zimbra 8.8.8 Has Been Released

Postby saschadd » Sun Apr 08, 2018 8:21 pm

antigerme wrote:After I upgraded to v8.8.8 the Zimbra repo (yum repo) got broken

Code: Select all

# yum upgrade
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.ufscar.br
 * extras: mirror.ufscar.br
 * updates: mirror.ufscar.br
Resolving Dependencies
--> Running transaction check
---> Package zimbra-chat.x86_64 0:1.0.13.1521626727-2.r7 will be obsoleted
---> Package zimbra-talk.x86_64 0:1.0.2.1521642559-1.r7 will be obsoleting
--> Processing Dependency: zimbra-network-modules-ng >= 1.0.13 for package: zimbra-talk-1.0.2.1521642559-1.r7.x86_64
--> Finished Dependency Resolution
Error: Package: zimbra-talk-1.0.2.1521642559-1.r7.x86_64 (zimbra-888-patch)
           Requires: zimbra-network-modules-ng >= 1.0.13
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


I get the same error after upgrading 8.8.7 to 8.8.8 open source.
zimbra-network-modules-ng seems to be only part of network edition which i found out here viewtopic.php?t=63954&p=282899
So is the new zimbra talk not part of open source version or is it wrong that zimbra talk depens on zimbra-network-modules-ng which is not part of open source edition :?

EDIT: Another issue: Admin console start page shows queue length of 51 while sudo ~/libexec/zmqstat and the detail page in admin console shows 0.
copowpow
Posts: 19
Joined: Mon Mar 26, 2018 3:34 pm

Re: Zimbra 8.8.8 Has Been Released

Postby copowpow » Sun Apr 08, 2018 8:53 pm

antigerme wrote:After I upgraded to v8.8.8 the Zimbra repo (yum repo) got broken

Code: Select all

# yum upgrade
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.ufscar.br
 * extras: mirror.ufscar.br
 * updates: mirror.ufscar.br
Resolving Dependencies
--> Running transaction check
---> Package zimbra-chat.x86_64 0:1.0.13.1521626727-2.r7 will be obsoleted
---> Package zimbra-talk.x86_64 0:1.0.2.1521642559-1.r7 will be obsoleting
--> Processing Dependency: zimbra-network-modules-ng >= 1.0.13 for package: zimbra-talk-1.0.2.1521642559-1.r7.x86_64
--> Finished Dependency Resolution
Error: Package: zimbra-talk-1.0.2.1521642559-1.r7.x86_64 (zimbra-888-patch)
           Requires: zimbra-network-modules-ng >= 1.0.13
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest



same thing happened to me but ubuntu 16.04:

Code: Select all

@mail:~$ sudo apt-get install zimbra-talk
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zimbra-talk : Depends: zimbra-network-modules-ng (>= 1.0.13) but it is not installable
E: Unable to correct problems, you have held broken packages.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: Google [Bot] and 2 guests