8.8.8 on RH7 clean install, wont run mailbox [chat prob]

Ask questions about your setup or get help installing ZCS server (ZD section below).
sanddweller
Posts: 3
Joined: Sun Jul 08, 2018 1:09 pm

8.8.8 on RH7 clean install, wont run mailbox [chat prob]

Postby sanddweller » Sun Jul 08, 2018 1:49 pm

Hi

Any help on this would be appreciated.
I've been struggling with installing ZCS 8.8.8 on a RH7 server (64bit AMI, on AWS EC2).
Clean RH7 image.
Installed dnsmasq and configured.
Zimbra dnscache deselected to void port 53 conflict.

All goes cleanly with the install, but when server starts the mailbox service fails.
It looks like the chat service is not running, due to database tables not built during install.
There's no option during install to elect to NOT install chat.
zmprov gets connection errors, if I attempt to disable (presumably bc server not running)

Unless something has changed recently in install scripts, I cant imagine this has not encountered by others.

Have I stupidly overlooked something? I dont think so.

I'd LIKE to install chat to see what its like - my main mailserver is running 8.6(and prior) happily for a few years.

thanks!
regards,
--geoff


From install log:

Code: Select all

Sun Jul  8 12:55:12 2018    com_zextras_chat_open...
Sun Jul  8 12:55:12 2018 *** Running as zimbra user: /opt/zimbra/bin/zmzimletctl -l deploy zimlets/com_zextras_chat_open.zip
[] INFO: Deploying Zimlet com_zextras_chat_open in LDAP.
[] INFO: Installing Zimlet com_zextras_chat_open on this host.
[] INFO: Upgrading Zimlet com_zextras_chat_open to 11
[] INFO: Adding Zimlet com_zextras_chat_open to COS default
[] INFO: Enabling Zimlet com_zextras_chat_open
Sun Jul  8 12:55:16 2018 done.



After install:

Code: Select all

 zmcontrol status
Host mail.xxxxxxxx.com
        amavis                  Running
        antispam                Running
        antivirus               Stopped
                zmclamdctl is not running
        ldap                    Running
        logger                  Running
        mailbox                 Stopped
                zmmailboxdctl is not running.
        memcached               Running
        mta                     Running
        opendkim                Running
        proxy                   Running
        service webapp          Stopped
                zmmailboxdctl is not running.
        snmp                    Running
        spell                   Running
        stats                   Running
        zimbra webapp           Stopped
                zmmailboxdctl is not running.
        zimbraAdmin webapp      Stopped
                zmmailboxdctl is not running.
        zimlet webapp           Stopped
                zmmailboxdctl is not running.
        zmconfigd               Running


From mailbox.log:

Code: Select all

..
2018-07-08 12:51:05,018 INFO  [main] [] mailbox - Starting ZAL version 2.3.0 commit d96c2a7c927535618735047867c2ea1105711670
2018-07-08 12:51:05,071 INFO  [main] [] mailbox - File /opt/zimbra/lib/ext/openchat/extension-path not present, using standard boot
2018-07-08 12:51:05,073 INFO  [main] [] extensions - Searching ZAL extension in directory /opt/zimbra/lib/ext/openchat
2018-07-08 12:51:05,150 INFO  [main] [] extensions - Initialized extension Zimbra Abstraction Layer for: openchat: org.openzal.zal.extension.ZalEntrypointImpl@com.zimbra.cs.extension.ZimbraExtensionClassLoader@75b3673
...
2018-07-08 12:51:07,951 INFO  [main] [] pop - Starting Pop3Server on /0.0.0.0:7110
2018-07-08 12:51:07,981 INFO  [main] [] pop - Starting Pop3SSLServer on /0.0.0.0:7995
2018-07-08 12:51:08,021 INFO  [main] [] imap - Starting ImapServer on /0.0.0.0:7143
2018-07-08 12:51:08,040 INFO  [main] [] imap - Starting ImapSSLServer on /0.0.0.0:7993
2018-07-08 12:51:08,086 INFO  [main] [] scheduler - Loaded 0 scheduled data source tasks
2018-07-08 12:51:08,089 INFO  [main] [] misc - Starting zimbraMailPurgeSleepInterval thread with 1m interval
2018-07-08 12:51:08,115 WARN  [main] [] contactbackup - zimbraFeatureContactBackupFrequency is set to 0
2018-07-08 12:51:08,128 INFO  [MailboxPurge] [] purge - Purge thread sleeping for 1800000ms before doing work.
2018-07-08 12:51:08,283 INFO  [main] [] extensions - Post-Initializing extensions
2018-07-08 12:51:08,285 INFO  [main] [] mailbox - OpenChat starting ...
2018-07-08 12:51:10,089 ERROR [main] [] extensions - ################## OpenChat cannot start:com.zextras.lib.switches.Service$ServiceStartException: Unable to preload relationships
        at com.zextras.modules.chat.services.DbPreloader.start (DbPreloader.java:52)
..
Caused by: com.zextras.modules.chat.server.exceptions.ChatSqlException: Unable to execute the SQL statement: SELECT * FROM chat.RELATIONSHIP
        at com.zextras.modules.chat.services.DbPreloader$RelationshipsPreloadSqlClosure.execute (DbPreloader.java:110)
..
Caused by: java.sql.SQLSyntaxErrorException: Table 'chat.RELATIONSHIP' doesn't exist
Query is:
sql : 'SELECT * FROM chat.RELATIONSHIP'
        at org.mariadb.jdbc.internal.SQLExceptionMapper.get (SQLExceptionMapper.java:138)
..
2018-07-08 12:51:10,090 ERROR [main] [] extensions - Startup error in extension com.zextras.modules.chat.ChatExtension
java.lang.RuntimeException: com.zextras.lib.switches.Service$ServiceStartException: Unable to preload relationships
    at com.zextras.modules.chat.ChatExtension.startup(ChatExtension.java:239)
..
       


Found a script at /opt/zimbra/libexec/scripts/migrate20180301-ZimbraChat.pl
This appears to build the database tables for chat, however, running it, returns a scheme version mismatch.

Code: Select all

./migrate20180301-ZimbraChat.pl
Sun Jul  8 13:40:28 2018: Schema version mismatch.  Expected version 108.  Version in the database is 109.


phoenix
Ambassador
Ambassador
Posts: 25587
Joined: Fri Sep 12, 2014 9:56 pm

Re: 8.8.8 on RH7 clean install, wont run mailbox [chat prob]

Postby phoenix » Sun Jul 08, 2018 4:31 pm

This would appear to be either a) a ZeXtras package install or b) an install of the Zimbra ZeXtras modules. If that's the case you should open a support case with Zimbra for their version or with ZeXtras for their version of the software.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
sanddweller
Posts: 3
Joined: Sun Jul 08, 2018 1:09 pm

Re: 8.8.8 on RH7 clean install, wont run mailbox [chat prob]

Postby sanddweller » Sun Jul 08, 2018 5:44 pm

Thanks Bill.7It is however, the plain vanilla download from the Zimbra site for ZCS 8.8.8
File downloaded from the Zimbra websire was zcs-8.8.8_GA_2009.RHEL7_64.20180322150747.tgz

Now, since my first post Ive had a further play, and for the hell of it, did a yum update to find some updates:
    zimbra-common-core-jar x86_64 1.0.0.1527759637-1.r7 zimbra-888-patch 13 M
    zimbra-mbox-conf x86_64 1.0.0.1525182510-1.r7 zimbra-888-patch 35 k
    zimbra-mbox-service x86_64 1.0.0.1525182510-1.r7 zimbra-888-patch 3.7 k
    zimbra-mbox-war x86_64 1.0.0.1525182510-1.r7 zimbra-888-patch 21 M
    zimbra-mbox-webclient-war x86_64 1.0.0.1527079283-1.r7 zimbra-888-patch 24 M

Code: Select all

yum update
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Could not contact CDS load balancer rhui2-cds01.eu-west-3.aws.ce.redhat.com, trying others.
Resolving Dependencies
--> Running transaction check
---> Package zimbra-common-core-jar.x86_64 0:1.0.0.1521707697-1.r7 will be updated
---> Package zimbra-common-core-jar.x86_64 0:1.0.0.1527759637-1.r7 will be an update
---> Package zimbra-mbox-conf.x86_64 0:1.0.0.1521707697-1.r7 will be updated
---> Package zimbra-mbox-conf.x86_64 0:1.0.0.1525182510-1.r7 will be an update
---> Package zimbra-mbox-service.x86_64 0:1.0.0.1521707697-1.r7 will be updated
---> Package zimbra-mbox-service.x86_64 0:1.0.0.1525182510-1.r7 will be an update
---> Package zimbra-mbox-war.x86_64 0:1.0.0.1521707697-1.r7 will be updated
---> Package zimbra-mbox-war.x86_64 0:1.0.0.1525182510-1.r7 will be an update
---> Package zimbra-mbox-webclient-war.x86_64 0:1.0.0.1521723166-1.r7 will be updated
---> Package zimbra-mbox-webclient-war.x86_64 0:1.0.0.1527079283-1.r7 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================
 Package                            Arch            Version                        Repository                 Size
===================================================================================================================
Updating:
 zimbra-common-core-jar             x86_64          1.0.0.1527759637-1.r7          zimbra-888-patch           13 M
 zimbra-mbox-conf                   x86_64          1.0.0.1525182510-1.r7          zimbra-888-patch           35 k
 zimbra-mbox-service                x86_64          1.0.0.1525182510-1.r7          zimbra-888-patch          3.7 k
 zimbra-mbox-war                    x86_64          1.0.0.1525182510-1.r7          zimbra-888-patch           21 M
 zimbra-mbox-webclient-war          x86_64          1.0.0.1527079283-1.r7          zimbra-888-patch           24 M

Transaction Summary
===================================================================================================================
Upgrade  5 Packages


I shutdown zimbra, applied those updates then ran the zimbra install again.. as an update from 8.8.8.8 to 8.8.8.8.
Again it completed without error, but this time cleanly, and Zimbra is now up and running.

cheers
phoenix
Ambassador
Ambassador
Posts: 25587
Joined: Fri Sep 12, 2014 9:56 pm

Re: 8.8.8 on RH7 clean install, wont run mailbox [chat prob]

Postby phoenix » Sun Jul 08, 2018 7:01 pm

Ah OK! I didn't realise that the chat module from ZeXtras was used in the OSS version, I just happen to use the ZeXtras products on my server but not the chat module so I haven't taken much notice of it. Anyway thanks for the update and I'm glad you've fixed it.

I would suggest you do a "yum clean all" the the suggested "rm" command before install any ZCS product, I have noticed similar problems occasionally on my install/updates and the clean & rm seems to fix it.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
sanddweller
Posts: 3
Joined: Sun Jul 08, 2018 1:09 pm

Re: 8.8.8 on RH7 clean install, wont run mailbox [chat prob]

Postby sanddweller » Sun Jul 08, 2018 7:24 pm

Yes.. I cant really explain what the problem may have been.

This was a new RedHat install, and after install had been updated 'yum update', so was 100% upto date for all RH stuff.

I presume the Zimbra instal adds a sw repository, and loads packages from that.
Why it didnt load the latest packages, I do not know. Possibly its hardcoded to load specific versions?
Yet, the versions installed seemed to be broken (why havent others encountered this?)
Fortunately I tried another 'yum update' and found these updated packages, which seemed to fix the issue, by essentially rerunning the install as an update so as to not scrap the already downloaded packages and start from scratch.
cheers,
--geoff

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 10 guests