zimbra stop working after do-release-upgrade

Ask questions about your setup or get help installing ZCS server (ZD section below).
linustorl
Posts: 10
Joined: Mon May 07, 2018 4:08 am

zimbra stop working after do-release-upgrade

Postby linustorl » Sat Feb 16, 2019 10:52 pm

Hi Guys,

Need your guys help very badly right now.

Recently i am doing do-release-upgrade for my zimbra server from 16.04 to 18.04, once upgrading done, found out that zimbra is not working anymore where is the command
zmcontrol
is not found.

is this a bug or anything? and how to workaround this issue and preserve all users' email?

I am not sure which version of zimbra was installed but i think it is ZCS 8.8.7 OR ZCS 8.8.8.

Please do help me how to solve this issue guys.


lytledd
Outstanding Member
Outstanding Member
Posts: 507
Joined: Sat Sep 13, 2014 12:54 am
ZCS/ZD Version: Ubuntu Release 8.8.15.GA.P10 FOSS

Re: zimbra stop working after do-release-upgrade

Postby lytledd » Sat Feb 16, 2019 11:06 pm

Recently i am doing do-release-upgrade for my zimbra server from 16.04 to 18.04, once upgrading done, found out that zimbra is not working anymore where is the command zmcontrol is not found.


Zimbra is currently not supported under Ubuntu 18.04. You'll need to revert to your backup.

Doug
linustorl
Posts: 10
Joined: Mon May 07, 2018 4:08 am

Re: zimbra stop working after do-release-upgrade

Postby linustorl » Sat Feb 16, 2019 11:15 pm

Oh My Gosh,

I don't have any backup, how do i get the emails back? probably from /opt/zimbra directory?
lytledd
Outstanding Member
Outstanding Member
Posts: 507
Joined: Sat Sep 13, 2014 12:54 am
ZCS/ZD Version: Ubuntu Release 8.8.15.GA.P10 FOSS

Re: zimbra stop working after do-release-upgrade

Postby lytledd » Sun Feb 17, 2019 11:27 am

linustorl wrote:Oh My Gosh,

I don't have any backup, how do i get the emails back? probably from /opt/zimbra directory?


First and foremost, you should always preform a backup before doing such upgrades. If it's virtualized, it's as simple as taking a snapshot.

https://wiki.zimbra.com/wiki/Backup_and_Restore_Articles

My suggestion would be to build a 16.04 system and then move your data to it

https://wiki.zimbra.com/wiki/How_to_move_ZCS_to_another_server

Doug
linustorl
Posts: 10
Joined: Mon May 07, 2018 4:08 am

Re: zimbra stop working after do-release-upgrade

Postby linustorl » Mon Feb 18, 2019 4:14 am

Why there is no

Code: Select all

bin
folder in my original zimbra folder /opt/zimbra?
lytledd
Outstanding Member
Outstanding Member
Posts: 507
Joined: Sat Sep 13, 2014 12:54 am
ZCS/ZD Version: Ubuntu Release 8.8.15.GA.P10 FOSS

Re: zimbra stop working after do-release-upgrade

Postby lytledd » Mon Feb 18, 2019 4:38 pm

linustorl wrote:Why there is no

Code: Select all

bin
folder in my original zimbra folder /opt/zimbra?


Because Zimbra uses the package manager now and there are no Ubuntu 18.04 packages, so that application was removed, along with the bin folder contents,

Doug
linustorl
Posts: 10
Joined: Mon May 07, 2018 4:08 am

Re: zimbra stop working after do-release-upgrade

Postby linustorl » Tue Feb 19, 2019 1:38 am

lytledd wrote:
linustorl wrote:Why there is no

Code: Select all

bin
folder in my original zimbra folder /opt/zimbra?


Because Zimbra uses the package manager now and there are no Ubuntu 18.04 packages, so that application was removed, along with the bin folder contents,

Doug


So it is possible for me to follow this guide https://wiki.zimbra.com/wiki/How_to_move_ZCS_to_another_server.

This is what i have done so far by following the wiki.

1. Installed a fresh ubuntu 16.04
2. Install the same Zimbra to the new installed Ubuntu with the flag -s (./install.sh -s)
3. Rename new installed zimbra folder and rename backup folder to zimbra.
3. Copy few folders including `bin`, `contrib`, `extension_extra`, `libexec`, `sbin`, and `share` <== not exists in backup folder.
4. Fix zimbra permission.
5. Run ./install.sh again but it gave an error in file zmValidate.pl in Line 159 saying that file not found, when i opened the file and go to line 159, found out it is related to LDAP and i am very sure that i have choose 'Y' for zimbra-ldap during installation.

Is there something that i am missing? or perhaps you can help me to do this? i am willing to pay for your service. (i am so desperate at this moment)
lytledd
Outstanding Member
Outstanding Member
Posts: 507
Joined: Sat Sep 13, 2014 12:54 am
ZCS/ZD Version: Ubuntu Release 8.8.15.GA.P10 FOSS

Re: zimbra stop working after do-release-upgrade

Postby lytledd » Tue Feb 19, 2019 8:57 pm

it gave an error in file zmValidate.pl in Line 159 saying that file not found, when i opened the file and go to line 159, found out it is related to LDAP and i am very sure that i have choose 'Y' for zimbra-ldap during installation.


I had the same issue and ended having the follow the below instructions to re-install the Zimbra Perl modules, which fixed it for me

https://forums.zimbra.org/viewtopic.php?t=62657

or perhaps you can help me to do this? i am willing to pay for your service. (i am so desperate at this moment)


Sorry, but that goes beyond what I would be willing to do,

Doug
linustorl
Posts: 10
Joined: Mon May 07, 2018 4:08 am

Re: zimbra stop working after do-release-upgrade

Postby linustorl » Wed Feb 20, 2019 2:47 am

After following the Perl workaround, no error from zmvalidate.pl anymore but now it gave an error about the LDAP things.

Code: Select all

Checking for existing installation...
    zimbra-chat...FOUND zimbra-chat-1.0.20.1532350417-2.u16
    zimbra-drive...FOUND zimbra-drive-1.0.11.1518786326-1.u16
    zimbra-imapd...NOT FOUND
    zimbra-license-tools...NOT FOUND
    zimbra-license-extension...NOT FOUND
    zimbra-network-store...NOT FOUND
    zimbra-network-modules-ng...NOT FOUND
    zimbra-ldap...FOUND zimbra-ldap-8.8.8.GA.2009.UBUNTU16.64
    zimbra-logger...FOUND zimbra-logger-8.8.8.GA.2009.UBUNTU16.64
    zimbra-mta...FOUND zimbra-mta-8.8.8.GA.2009.UBUNTU16.64
    zimbra-dnscache...FOUND zimbra-dnscache-8.8.8.GA.2009.UBUNTU16.64
    zimbra-snmp...FOUND zimbra-snmp-8.8.8.GA.2009.UBUNTU16.64
    zimbra-store...FOUND zimbra-store-8.8.8.GA.2009.UBUNTU16.64
    zimbra-apache...FOUND zimbra-apache-8.8.8.GA.2009.UBUNTU16.64
    zimbra-spell...FOUND zimbra-spell-8.8.8.GA.2009.UBUNTU16.64
    zimbra-convertd...NOT FOUND
    zimbra-memcached...FOUND zimbra-memcached-1:1.4.37-2.u16
    zimbra-proxy...FOUND zimbra-proxy-8.8.8.GA.2009.UBUNTU16.64
    zimbra-archiving...NOT FOUND
    zimbra-core...FOUND zimbra-core-8.8.8.GA.2009.UBUNTU16.64
ZCS upgrade from 8.8.8 to 8.8.8 will be performed.
Validating ldap configuration
Error: Unable to bind to the LDAP server as the root LDAP user.
       This is required to upgrade.


And this is something from the LDAP command :

Code: Select all

calendar_resource_ldap_search_maxsize = 1000
ldap_accesslog_envflags = writemap nometasync
ldap_accesslog_maxsize = 85899345920
ldap_amavis_password = *
ldap_bes_searcher_password = *
ldap_bind_url =
ldap_cache_account_maxage = 15
ldap_cache_account_maxsize = 20000
ldap_cache_alwaysoncluster_maxage = 15
ldap_cache_alwaysoncluster_maxsize = 100
ldap_cache_cos_maxage = 15
ldap_cache_cos_maxsize = 100
ldap_cache_custom_dynamic_group_membership_maxage_ms = 600000
ldap_cache_domain_maxage = 15
ldap_cache_domain_maxsize = 500
ldap_cache_external_domain_maxage = 15
ldap_cache_external_domain_maxsize = 10000
ldap_cache_group_maxage = 15
ldap_cache_group_maxsize = 2000
ldap_cache_mime_maxage = 15
ldap_cache_reverseproxylookup_domain_maxage = 15
ldap_cache_reverseproxylookup_domain_maxsize = 100
ldap_cache_reverseproxylookup_server_maxage = 15
ldap_cache_reverseproxylookup_server_maxsize = 100
ldap_cache_right_maxage = 15
ldap_cache_right_maxsize = 100
ldap_cache_server_maxage = 15
ldap_cache_server_maxsize = 100
ldap_cache_share_locator_maxage = 15
ldap_cache_share_locator_maxsize = 5000
ldap_cache_timezone_maxsize = 100
ldap_cache_ucservice_maxage = 15
ldap_cache_ucservice_maxsize = 100
ldap_cache_xmppcomponent_maxage = 15
ldap_cache_xmppcomponent_maxsize = 100
ldap_cache_zimlet_maxage = 15
ldap_cache_zimlet_maxsize = 100
ldap_common_loglevel = 49152
ldap_common_require_tls = 0
ldap_common_threads = 8
ldap_common_tlsciphersuite = MEDIUM:HIGH
ldap_common_tlsprotocolmin = 3.1
ldap_common_toolthreads = 2
ldap_common_writetimeout = 360
ldap_connect_pool_debug = false
ldap_connect_pool_health_check_background_interval_millis = 30000
ldap_connect_pool_health_check_max_response_time_millis = 30000
ldap_connect_pool_health_check_on_checkout_enabled = false
ldap_connect_pool_initsize = 1
ldap_connect_pool_master = false
ldap_connect_pool_maxsize = 50
ldap_connect_pool_prefsize = 0
ldap_connect_pool_timeout = 120000
ldap_connect_timeout = 30000
ldap_db_envflags = writemap nometasync
ldap_db_maxsize = 85899345920
ldap_db_rtxnsize = 0
ldap_deref_aliases = always
ldap_dit_base_dn_admin =
ldap_dit_base_dn_alwaysoncluster =
ldap_dit_base_dn_appadmin =
ldap_dit_base_dn_config =
ldap_dit_base_dn_cos =
ldap_dit_base_dn_domain =
ldap_dit_base_dn_global_dynamicgroup =
ldap_dit_base_dn_mail =
ldap_dit_base_dn_mime =
ldap_dit_base_dn_server =
ldap_dit_base_dn_share_locator =
ldap_dit_base_dn_ucservice =
ldap_dit_base_dn_xmppcomponent =
ldap_dit_base_dn_zimlet =
ldap_dit_naming_rdn_attr_cos =
ldap_dit_naming_rdn_attr_dynamicgroup =
ldap_dit_naming_rdn_attr_globalconfig =
ldap_dit_naming_rdn_attr_globalgrant =
ldap_dit_naming_rdn_attr_mime =
ldap_dit_naming_rdn_attr_server =
ldap_dit_naming_rdn_attr_share_locator =
ldap_dit_naming_rdn_attr_ucservice =
ldap_dit_naming_rdn_attr_user =
ldap_dit_naming_rdn_attr_xmppcomponent =
ldap_dit_naming_rdn_attr_zimlet =
ldap_host = mail.domain.com
ldap_is_master = true
ldap_ldapi_socket_file = ${zimbra_home}/data/ldap/state/run/ldapi
ldap_master_url = ldap://mail.domain.com:389
ldap_monitor_alert_only = true
ldap_monitor_critical = 90
ldap_monitor_growth = 25
ldap_monitor_mdb = true
ldap_monitor_warning = 80
ldap_nginx_password = *
ldap_overlay_accesslog_logpurge = 01+00:00  00+04:00
ldap_overlay_syncprov_checkpoint = 20 10
ldap_overlay_syncprov_sessionlog = 10000000
ldap_port = 389
ldap_postfix_password = *
ldap_read_timeout = 300000
ldap_replication_password = *
ldap_root_password = *
ldap_starttls_required = false
ldap_starttls_supported = 0
ldap_url = ldap://mail.domain.com:389
zimbra_class_ldap_client = com.zimbra.cs.ldap.unboundid.UBIDLdapClient
zimbra_class_provisioning = com.zimbra.cs.account.ldap.LdapProvisioning
zimbra_ldap_password = *
zimbra_ldap_user = zimbra
zimbra_ldap_userdn = uid=zimbra,cn=admins,cn=zimbra
zimbra_zmprov_default_to_ldap = false

is it something related to LDAP again?
lytledd
Outstanding Member
Outstanding Member
Posts: 507
Joined: Sat Sep 13, 2014 12:54 am
ZCS/ZD Version: Ubuntu Release 8.8.15.GA.P10 FOSS

Re: zimbra stop working after do-release-upgrade

Postby lytledd » Wed Feb 20, 2019 11:30 pm

Error: Unable to bind to the LDAP server as the root LDAP user.
This is required to upgrade.


Googling the above error indicates that the LDAP password is incorrect:

https://wiki.zimbra.com/wiki/Upgrade_Script_Check_-_Validating_LDAP_configuration

Is that the proper fix for your situation? I have no clue, I've never had to deal with database issues before.

Good luck,

Doug

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 7 guests