Upgrade from 8.7.11 to 8.8.11 - total (unforgettable) failure

Ask questions about your setup or get help installing ZCS server (ZD section below).
Posts: 12
Joined: Tue Dec 12, 2017 8:14 pm

Upgrade from 8.7.11 to 8.8.11 - total (unforgettable) failure

Postby shanmarsh28 » Mon Mar 11, 2019 12:12 am

Hi Guys,

I just want to let you know that I have now attempted twice an upgrade from Zimbra 8.7.11 to 8.8.11 (Community) and each time it resulted in what I can only describe as a catastrophic loss of the server.

Before I explain, I have worked with servers for many years and I have never seen anything quite like this.

The upgrade wizard itself seems to run smoothly and completes quickly. I used this as a guide: https://www.howtoforge.com/tutorial/upg ... on-ubuntu/

After the upgrade however, the server Zimbra does appear to come back online but starts consuming disk space at a rate I've never seen before. The log files simply explode at about 5GB a minute and become so large that I can't see whats contained within them. On the second attempt I had the foresight to ban the server from sending service notification emails because it was sending those out at an simply alarming rate (6000 emails a minute) so when I had a second go at it, I set within /opt/zimbra/conf/localconfig.xml "smtp_notify" to no. I learned my lesson because on the first go, our SMTP relay providor suspended our account. I should mention that the logfiles are not the only place where Zimbra seems to be consuming disk space. Once I turned the notifications off, the free space continued to drop and I am positive there is a another process responsible but the server could not be kept online long enough for me to diagnose it.

In both attempts the entire HDD was consumed in total (which only took a matter of minutes) and I was forced to shut the server down and revert to a backup.

I have to say I have absolutely no idea how to fix this or where to even begin. I regard this upgrade as dangerous.

Shane. :(
Last edited by shanmarsh28 on Mon Mar 11, 2019 7:53 pm, edited 3 times in total.

Posts: 26418
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: Upgrade from 8.7.11 to 8.8.11 - total (unforgettable) failure

Postby phoenix » Mon Mar 11, 2019 6:32 am

That 'how to' contains instructions on doing an update to the operating system, that's never a good idea. You've also not mentioned if you've done that and nor have you mentioned which versions of Ubuntu were involved in the upgrade - I believe that Zimbra has always discouraged an in-place operating system upgrade of the ZCS server. An in-place distribution upgrade is always done at your own risk despite the fact that it's worked for some people. How about using the ZeXtras Migration Tool to move your ZCS install to a new server?


Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
Posts: 12
Joined: Tue Dec 12, 2017 8:14 pm

Re: Upgrade from 8.7.11 to 8.8.11 - total (unforgettable) failure

Postby shanmarsh28 » Mon Mar 11, 2019 9:51 am

Thanks for your reply. Happily I didn't run the disto upgrade - I ignored that part of their instructions as I believed that would cause more issues. I have found these help pages: https://zimbra.github.io/installguides/ ... grade.html. The steps are very similar except for several commands that fix the default globalconfig values. Those I did not run.

I think a migration to a newly built server using ZeXtras Migration Tool or similar is our only option at present.

Ubuntu: 16.04.5 LTS
Zimbra: 8.7.11_GA_2038.NETWORK (network label is a bug after installing Patch 9: https://wiki.zimbra.com/wiki/Zimbra_Releases)
Upgrade package: https://files.zimbra.com/downloads/8.8. ... 111719.tgz

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 6 guests