Page 2 of 2

Re: Upgrade to 8.8.12 - Mailbox webapps fails to start

Posted: Thu Apr 11, 2019 4:05 pm
by pup_seba
So Peq, have you been able to fix it then? If so, I'm really happy about it.

Regarding those error messages, about the "Unrecognized VM option 'PrintGCDateStamps'", is weird because I have 8.8.12 running and not only I don't see those messages, but the process is up with those options configured. As postmortem or maybe as a hint, I guess disabling these options maybe could allow to start up the jvm?

For example, you could just "copy/edit/paste" the line of the zmlocalconfig (not you Peq...if your is already working, don't touch it! :D)

[zimbra@zimbrastore01 ~]$ zmlocalconfig mailboxd_java_options
mailboxd_java_options = -server -Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2 -Djdk.tls.client.protocols=TLSv1,TLSv1.1,TLSv1.2 -Djava.awt.headless=true -Dsun.net.inetaddr.ttl=${networkaddress_cache_ttl} -Dorg.apache.jasper.compiler.disablejsr199=true -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=1 -XX:-OmitStackTraceInFastThrow -verbose:gc -XX:+PrintGCDetails -XX:+PrintGCDateStamps -XX:+PrintGCApplicationStoppedTime -Xloggc:/opt/zimbra/log/gc.log -XX:+UseGCLogFileRotation -XX:NumberOfGCLogFiles=20 -XX:GCLogFileSize=10M -Djava.net.preferIPv4Stack=true

[zimbra@zimbrastore01 ~]$ zmlocalconfig -e mailboxd_java_options="mailboxd_java_options = -server -Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2 -Djdk.tls.client.protocols=TLSv1,TLSv1.1,TLSv1.2 -Djava.awt.headless=true -Dsun.net.inetaddr.ttl=${networkaddress_cache_ttl} -Dorg.apache.jasper.compiler.disablejsr199=true -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=1 -XX:-OmitStackTraceInFastThrow -verbose:gc -XX:+PrintGCDetails -XX:+PrintGCApplicationStoppedTime -Xloggc:/opt/zimbra/log/gc.log -XX:+UseGCLogFileRotation -XX:NumberOfGCLogFiles=20 -XX:GCLogFileSize=10M -Djava.net.preferIPv4Stack=true"

Just as a workaround for those of you still facing this problem. I think the real problem is with the java being used by zimbra, it would be nice to see what's the output of your (not working) "ps -ef | grep -i java". This lines work just fine...

Re: Upgrade to 8.8.12 - Mailbox webapps fails to start

Posted: Thu Apr 11, 2019 5:10 pm
by rosole
Thank you for replay.

I've tried to disabled/removed PrintGCDetails and PrintGCApplicationStoppedTime but got error:

OpenJDK 64-Bit Server VM warning: .hotspot_compiler file is present but has been ignored. Run with -XX:CompileCommandFile=.hotspot_compiler to load the file.
Error: Could not find or load main class mailboxd_java_options
Caused by: java.lang.ClassNotFoundException: mailboxd_java_options

It looks like it's mandatory to run java machine.

I have no idea how to fix it.

How to debug it?

Re: Upgrade to 8.8.12 - Mailbox webapps fails to start

Posted: Thu Apr 11, 2019 7:17 pm
by pup_seba
Hi Rosol,

In your env as zimbra user, there are somethings that are wrong. I wouldn't dare to say that they are the reason for the failure, but they are defenetly wrong nontheless.

It is requirement for instance, that the locale for zimbra user is "C", yours seems to be other. Are you switching to zimbra user with "su - zimbra"? (note the dash) or are you using some other form like "su zimbra"? (no dash means no proper env loading).

Take a look at my "env" as zimbra user, don't overlook things like the "LC_ALL=C" (mandatory to be exactly like that) or the "LANG=C" nor the "MAIL=var/spool/mail/zimbra".

Re: Upgrade to 8.8.12 - Mailbox webapps fails to start

Posted: Thu Apr 11, 2019 7:39 pm
by rosole
Hello pup_seba

I'm using su - zimbra and as you can see below, locale is C

zimbra@zimbra:~$ env
MANPATH=/opt/zimbra/common/share/man:
SHELL=/bin/bash
TERM=xterm-256color
PERL5LIB=/opt/zimbra/common/lib/perl5/x86_64-linux-gnu-thread-multi:/opt/zimbra/common/lib/perl5
LC_ALL=C
USER=zimbra
SNMPCONFPATH=/opt/zimbra/conf
USERNAME=zimbra
JYTHONPATH=/opt/zimbra/common/lib/jylibs
MAIL=/var/mail/zimbra
PATH=/opt/zimbra/bin:/opt/zimbra/common/lib/jvm/java/bin:/opt/zimbra/common/bin:/opt/zimbra/common/sbin:/usr/sbin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/snap/bin
PWD=/opt/zimbra
JAVA_HOME=/opt/zimbra/common/lib/jvm/java
LANG=C
PERLLIB=/opt/zimbra/common/lib/perl5/x86_64-linux-gnu-thread-multi:/opt/zimbra/common/lib/perl5
SHLVL=1
HOME=/opt/zimbra
LOGNAME=zimbra
XDG_DATA_DIRS=/usr/local/share:/usr/share:/var/lib/snapd/desktop
HISTTIMEFORMAT=%y%m%d %T
_=/usr/bin/env


zimbra@zimbra:~$ cat .bash_profile
# .bash_profile
umask 0027

# Get the aliases and functions
if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

# User specific environment and startup programs

# this breaks unicode_start on vt consoles
#BASH_ENV=$HOME/.bashrc
#export BASH_ENV

USERNAME="zimbra"
export USERNAME

export LANG=C
export LC_ALL=C
unset CLASSPATH
unset DYLD_LIBRARY_PATH

Re: Upgrade to 8.8.12 - Mailbox webapps fails to start

Posted: Thu Apr 11, 2019 8:58 pm
by rosole
Hello again.

I've changed zmlocalconfig as below and Zimbra now is working:

zmlocalconfig -e mailboxd_java_options="-server -Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2 -Djdk.tls.client.protocols=TLSv1,TLSv1.1,TLSv1.2 -Djava.awt.headless=true -Dsun.net.inetaddr.ttl=${networkaddress_cache_ttl} -Dorg.apache.jasper.compiler.disablejsr199=true -XX:SoftRefLRUPolicyMSPerMB=1 -XX:-OmitStackTraceInFastThrow -verbose:gc -Xlog:gc:/opt/zimbra/log/gc.log -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/opt/zimbra/log -XX:ErrorFile=/opt/zimbra/log/hs_err_pid%p.log"

Regarding this article:
https://wiki.zimbra.com/wiki/Performance_Tuning_Guidelines_for_Large_Deployments

-verbose:gc -XX:+PrintGCDetails -XX:+PrintGCDateStamps -XX:+PrintGCApplicationStoppedTime: Turn on logging about garbage collection. On a busy system this generates about 1MB-2MB of log data per day (to zmmailboxd.out). The log file is rotated / deleted automatically and it is worth having these on by default for diagnosis of server performance.

Thank you for help and idea, how to resolve issue !!!

Re: Upgrade to 8.8.12 - Mailbox webapps fails to start

Posted: Thu May 30, 2019 3:22 am
by christian7mx
The solution of rosole works perfectly, thanks