Zimbra 8.8.12_GA_3794 on Ubuntu 18.04.2 LTS failing with missing "zimbra" database in mysql

Ask questions about your setup or get help installing ZCS server (ZD section below).
OliverR
Posts: 2
Joined: Wed May 29, 2019 8:54 pm

Zimbra 8.8.12_GA_3794 on Ubuntu 18.04.2 LTS failing with missing "zimbra" database in mysql

Postby OliverR » Wed May 29, 2019 9:11 pm

Dear all,

I failed. I accidentially upgraded my server from Ubuntu 14 to 16, then 18 without accordingly updating the Zimbra server installation beforehand. Luckily, I do have a zextras Backup at hand such that external restore should not be an issue.

Nonetheless, I now ran into several issues when performing a complete uninstall of the zimbra server and a subsequent clean and fresh install of the latest (beta) release version which is zcs-8.8.12_GA_3794.UBUNTU18_64.20190329045002 in my case.

After fixing most of the issues in the past 2 days, I now ended up with a Zimbra installation that is capable of starting all installed processes with the zmcontrol start command. Yet, after a couple of minutes certain processes stop working due to an issue with the mysql database. When checking the logs, I understand that the database zimbra and its tables have never ever been injected during the installation process.

What would you suggest to fix these issues?

Some details:

Code: Select all

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.2 LTS
Release:        18.04
Codename:       bionic


Code: Select all

zimbra@(...):~$ zmcontrol start
Host (...)
        Starting ldap...Done.
        Starting zmconfigd...Done.
        Starting logger...Done.
        Starting mailbox...Done.
        Starting memcached...Done.
        Starting proxy...Done.
        Starting amavis...Done.
        Starting antispam...Done.
        Starting antivirus...Done.
        Starting opendkim...Done.
        Starting mta...Done.
        Starting stats...Done.
        Starting service webapp...Done.
        Starting zimbra webapp...Done.
        Starting zimbraAdmin webapp...Done.
        Starting zimlet webapp...Done.


Failure logs in mailbox.log:

Code: Select all

Caused by: org.mariadb.jdbc.internal.common.QueryException: Could not connect: Unknown database 'zimbra'
        at org.mariadb.jdbc.internal.mysql.MySQLProtocol.checkErrorPacket(MySQLProtocol.java:558)
        at org.mariadb.jdbc.internal.mysql.MySQLProtocol.connect(MySQLProtocol.java:500)
        at org.mariadb.jdbc.internal.mysql.MySQLProtocol.connect(MySQLProtocol.java:709)
        at org.mariadb.jdbc.internal.mysql.MySQLProtocol.<init>(MySQLProtocol.java:280)
        at org.mariadb.jdbc.Driver.connect(Driver.java:111)
        ... 64 more
2019-05-29 23:06:05,077 WARN  [main] [] misc - Could not establish a connection to the database.  Retrying in 5 seconds.
com.zimbra.common.service.ServiceException: system failure: getting database connection
ExceptionId:main:1559163965077:3f8450095686e741
Code:service.FAILURE
        at com.zimbra.common.service.ServiceException.FAILURE(ServiceException.java:288)
        at com.zimbra.cs.db.DbPool.getConnection(DbPool.java:360)
        at com.zimbra.cs.db.DbPool.getConnection(DbPool.java:322)
        at com.zimbra.cs.db.DbPool.waitForDatabase(DbPool.java:243)
        at com.zimbra.cs.db.DbPool.startup(DbPool.java:234)
        at com.zimbra.cs.util.Zimbra.startup(Zimbra.java:218)
        at com.zimbra.cs.util.Zimbra.startup(Zimbra.java:177)
        at com.zimbra.soap.SoapServlet.init(SoapServlet.java:129)
        at javax.servlet.GenericServlet.init(GenericServlet.java:244)
        at org.eclipse.jetty.servlet.ServletHolder.initServlet(ServletHolder.java:626)
        at org.eclipse.jetty.servlet.ServletHolder.initialize(ServletHolder.java:405)
        at org.eclipse.jetty.servlet.ServletHandler.initialize(ServletHandler.java:875)
        at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:346)



Code: Select all

zimbra@(...):~$ mysql
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 76
Server version: 10.1.25-MariaDB Zimbra MariaDB binary distribution

Copyright (c) 2000, 2017, Oracle, MariaDB Corporation Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]> show databases;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| mysql              |
| performance_schema |
| test               |
+--------------------+
4 rows in set (1.75 sec)



Any help is much appreciated!

Cheers!


Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 11 guests