We setup our Zimbra email server host name correctly, but recipient ‘s email server always get a different IP, causing

Ask questions about your setup or get help installing ZCS server (ZD section below).
chenqiang@gmail.com
Posts: 1
Joined: Thu May 30, 2019 10:22 am

We setup our Zimbra email server host name correctly, but recipient ‘s email server always get a different IP, causing

Postby chenqiang@gmail.com » Thu May 30, 2019 10:42 am

1. Current status: We have a new Zimbra email server up and running, it can send and receive emails normally.
2. Issue facing:
a. Sometimes we got bounce back message from recipient ‘s email server says:
“Client host rejected: cannot find your reverse hostname. [111.223.108.252]”
b. And we saw the below message in the message header that we sent out:
“Received: from mail.emarineonline.com (Unknown_Domain [111.223.108.252])”

3. Background:
a. We have A record and MX record created on mail.emarineonline.com and point to 111.223.108.251
b. we have reverse DNS record on IP 111.223.108.251 pointed mail.emarineonline.com
c. NSLookup and ping result on mail.emarineonline.com are all point to 111.223.108.251.
d. hostnamectl status on email server shows “hostname: mail.emarineonline.com”
4. Question:
a. We could not understand why the recipient ‘s email server get a wrong sender email server IP 111.223.108.252 which is not our email server host IP 111.223.108.251.
b. We do have the reverse DNS record on IP 111.223.108.251 which is our email host, why the recipient ‘s email server can not detect it , but instead detect on a different IP 111.223.108.252.
c. can help to point out if there is any parameter that we config wrongly on Zimbra server causing that?
BTW, the IP 111.223.108.252 is one of our office public IP.


phoenix
Ambassador
Ambassador
Posts: 26244
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: We setup our Zimbra email server host name correctly, but recipient ‘s email server always get a different IP, caus

Postby phoenix » Fri May 31, 2019 7:05 am

As all your DNS records are correct (I checked them :)) and you have valid A, MX and a reverse dns and your reverse DNS is correct I'd hazard a guess that it's an intermittent problem with their network or DNS server at the recipient server.or their infrastructure. My only suggestion is that you contact their admin and point out the problem and that everything is correct.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 12 guests