Page 1 of 1

We setup our Zimbra email server host name correctly, but recipient ‘s email server always get a different IP, causing

Posted: Thu May 30, 2019 10:42 am
by chenqiang@gmail.com
1. Current status: We have a new Zimbra email server up and running, it can send and receive emails normally.
2. Issue facing:
a. Sometimes we got bounce back message from recipient ‘s email server says:
“Client host rejected: cannot find your reverse hostname. [111.223.108.252]”
b. And we saw the below message in the message header that we sent out:
“Received: from mail.emarineonline.com (Unknown_Domain [111.223.108.252])”

3. Background:
a. We have A record and MX record created on mail.emarineonline.com and point to 111.223.108.251
b. we have reverse DNS record on IP 111.223.108.251 pointed mail.emarineonline.com
c. NSLookup and ping result on mail.emarineonline.com are all point to 111.223.108.251.
d. hostnamectl status on email server shows “hostname: mail.emarineonline.com”
4. Question:
a. We could not understand why the recipient ‘s email server get a wrong sender email server IP 111.223.108.252 which is not our email server host IP 111.223.108.251.
b. We do have the reverse DNS record on IP 111.223.108.251 which is our email host, why the recipient ‘s email server can not detect it , but instead detect on a different IP 111.223.108.252.
c. can help to point out if there is any parameter that we config wrongly on Zimbra server causing that?
BTW, the IP 111.223.108.252 is one of our office public IP.

Re: We setup our Zimbra email server host name correctly, but recipient ‘s email server always get a different IP, caus

Posted: Fri May 31, 2019 7:05 am
by phoenix
As all your DNS records are correct (I checked them :)) and you have valid A, MX and a reverse dns and your reverse DNS is correct I'd hazard a guess that it's an intermittent problem with their network or DNS server at the recipient server.or their infrastructure. My only suggestion is that you contact their admin and point out the problem and that everything is correct.