Problem upgrading zcs 8.6 to 8.7

Ask questions about your setup or get help installing ZCS server (ZD section below).
User avatar
vojtechmyslivec
Posts: 3
Joined: Sun Jun 02, 2019 8:44 pm

Problem upgrading zcs 8.6 to 8.7

Postby vojtechmyslivec » Sun Jun 02, 2019 10:15 pm

Hi,

I want to upgrade my Zimbra collaboration suite version 8.6 on Ubuntu 14.04 server to 8.7. I follow wiki upgrade manual, however I have encountered some issues with the upgrade process.

I have downloaded 8.7.11 GA installation archive from zimbra.org, extract the archive and run the install.sh script. It detects installed Zimbra 8.6 correctly and started the upgrade process.

The script failed with following error (full output can be found in install-zcs-8.7.11.txt):

Code: Select all

Installing local packages (10):
   zimbra-core
   zimbra-ldap
   zimbra-logger
   zimbra-mta
   zimbra-dnscache
   zimbra-snmp
   zimbra-store
   zimbra-apache
   zimbra-spell
   zimbra-proxy
      ...
ERROR: Unable to install required packages
WARNING: REMOTE PACKAGE INSTALLATION FAILED.


And in the installation log in /tmp directory is following (and similar) messages (full installation log can be found in install-zcs-8.7.11.log):

Code: Select all

dpkg: dependency problems prevent configuration of zimbra-core:
 zimbra-core depends on zimbra-core-components; however:
  Package zimbra-core-components is not installed.

dpkg: error processing package zimbra-core (--install):
 dependency problems - leaving unconfigured
...
 dpkg: dependency problems prevent configuration of zimbra-proxy:
 zimbra-proxy depends on zimbra-core; however:
  Package zimbra-core is not configured yet.
 zimbra-proxy depends on zimbra-proxy-components; however:
  Package zimbra-proxy-components is not installed.

dpkg: error processing package zimbra-proxy (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 zimbra-core
 zimbra-ldap
 zimbra-logger
 zimbra-mta
 zimbra-dnscache
 zimbra-snmp
 zimbra-store
 zimbra-apache
 zimbra-spell
 zimbra-proxy


I figured out the *-components packages are missing during installation process and so it fails.

I have tried to fix package dependencies with apt-get install -f, which finished successfully. However, when I run the install.sh again, it ends up with the same error.

I have also tried to run install.sh with bash -x and it seems the installation script configure zimbra deb repository and then download and install packages manually by running dpkg --install package-name1.deb package-name2.deb ... without installing *-components "variants" of these packages. The script uses low-level dpkg utility which does not neither solve nor download nor install dependent packages.

Does anyone understand this problem and is possible to help me with the upgrade process? I think the upgrade process should use apt or apt-get (which install package successfully when run manually) instead of dpkg.


User avatar
vojtechmyslivec
Posts: 3
Joined: Sun Jun 02, 2019 8:44 pm

Re: Problem upgrading zcs 8.6 to 8.7

Postby vojtechmyslivec » Thu Jun 06, 2019 9:59 pm

Does anyone have an advice how to upgrade from 8.6 to some more recent version? I plan to migrate this zcs to a new server with Ubuntu 16.04 and Zimbra 8.8 but I need to upgrade the actual instance first.

I have cloned the original VPS and also have snapshots of the filesystem so I can test the upgrade repeatedly. I have tried it several times already and every time it ends up the same I have reported.
phoenix
Ambassador
Ambassador
Posts: 26243
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: Problem upgrading zcs 8.6 to 8.7

Postby phoenix » Fri Jun 07, 2019 5:46 am

vojtechmyslivec wrote:Does anyone have an advice how to upgrade from 8.6 to some more recent version? I plan to migrate this zcs to a new server with Ubuntu 16.04 and Zimbra 8.8 but I need to upgrade the actual instance first.
As you're moving ZCS to a new server then just use the ZeXtras Migration Tool, it free, quick and easy to use and no need to update your current ZCS installation.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
User avatar
vojtechmyslivec
Posts: 3
Joined: Sun Jun 02, 2019 8:44 pm

Re: Problem upgrading zcs 8.6 to 8.7

Postby vojtechmyslivec » Fri Jun 07, 2019 10:26 pm

phoenix wrote:just use the ZeXtras Migration Tool


Ok, thanks for the tip, I will try this tool.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 8 guests