Zimbra installation Ldap failure

Ask questions about your setup or get help installing ZCS server (ZD section below).
Blisk
Posts: 33
Joined: Tue May 21, 2019 7:47 am

Zimbra installation Ldap failure

Postby Blisk » Sun Jun 23, 2019 3:34 pm

Today I have installed Zimbra on centos 7.6 Server.
All goes well until I get error MX record can't be found.
I have setup dnsmasq and after that now I get error A record and AAA record can not be found.

Is here anyone which have Zimbra on censtos 7.6 server which is behind ruter and use dnsmasq or bind??
I hope I can see config files for dnsmasq or bind.
thank you


phoenix
Ambassador
Ambassador
Posts: 26244
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: Zimbra installation Ldap failure

Postby phoenix » Sun Jun 23, 2019 4:54 pm

Did you follow the wiki article, or the many forum threads, on the subject of Split DNS?
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
Blisk
Posts: 33
Joined: Tue May 21, 2019 7:47 am

Re: Zimbra installation Ldap failure

Postby Blisk » Sun Jun 23, 2019 5:34 pm

phoenix wrote:Did you follow the wiki article, or the many forum threads, on the subject of Split DNS?


yes I tried all. I bang may head for this for 6 hours and doesn't work.
that's why I am here
phoenix
Ambassador
Ambassador
Posts: 26244
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: Zimbra installation Ldap failure

Postby phoenix » Sun Jun 23, 2019 5:46 pm

Blisk wrote:
phoenix wrote:Did you follow the wiki article, or the many forum threads, on the subject of Split DNS?


yes I tried all. I bang may head for this for 6 hours and doesn't work.
that's why I am here
Merely saying 'it doesn't work' isn't really much information with which anyone can help you so why aren't you providing the information that's mentioned in the Split DNS article?
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
Blisk
Posts: 33
Joined: Tue May 21, 2019 7:47 am

Re: Zimbra installation Ldap failure

Postby Blisk » Mon Jun 24, 2019 6:48 am

I use this to install bind
https://johannfenech.com/?p=31

after that I run and get the same error

/opt/zimbra/libexec/zmsetup.pl
Operations logged to /tmp/zmsetup.20190624-084554.log
Installing LDAP configuration database...done.
Setting defaults...No results returned for A lookup of max99
Checked nameservers:
192.168.10.20
217.72.64.222
No results returned for AAAA lookup of max99
Checked nameservers:
192.168.10.20
217.72.64.222


DNS ERROR resolving max99
It is suggested that the hostname be resolvable via DNS
Change hostname [Yes]


I also tried dnsmasq and result is the same, before I get
No results returned for MX lookup of max99
until I tried this below
http://shorewall.org/SplitDNS.html


/opt/zimbra/libexec/zmsetup.pl
Operations logged to /tmp/zmsetup.20190624-084554.log
Installing LDAP configuration database...done.
Setting defaults...No results returned for A lookup of max99
Checked nameservers:
192.168.10.20
217.72.64.222
No results returned for AAAA lookup of max99
Checked nameservers:
192.168.10.20
217.72.64.222


DNS ERROR resolving max99
It is suggested that the hostname be resolvable via DNS
Change hostname [Yes]
phoenix
Ambassador
Ambassador
Posts: 26244
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: Zimbra installation Ldap failure

Postby phoenix » Mon Jun 24, 2019 8:07 am

You still haven't posted all the required information which leads me to the conclusion that a) you haven't correctly verified the configuration and b) you haven't made the corect changes to the hosts and resolv files. You need to post all the required information mentioned in that article.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
Blisk
Posts: 33
Joined: Tue May 21, 2019 7:47 am

Re: Zimbra installation Ldap failure

Postby Blisk » Mon Jun 24, 2019 8:38 am

I found out why I get error for A adn AAA record, because I miss domain it was only max99 instead of max99.com
Now I have MX error again

hosts
192.168.100.200 max99.com mail.max99.com
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6


this is resolv.conf

nameserver 192.168.100.200
nameserver 217.72.64.222


this is ERROR
IP 123.123.123.123 is my public IP

MX: mail.sztj88.si (123.123.123.123)

Interface: 127.0.0.1
Interface: ::1
Interface: 192.168.0.7
Interface: 192.168.100.201
123.123.123.123
123.123.123.123
123.123.123.123
123.123.123.123


DNS ERROR - none of the MX records for max99.com
resolve to this host


dig -t A max99.com

; <<>> DiG 9.9.4-RedHat-9.9.4-74.el7_6.1 <<>> -t A max99.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 54790
;; flags: qr rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;max99.com. IN A

;; ANSWER SECTION:
max99.com. 4898 IN A 123.123.123.123

;; Query time: 7 msec
;; SERVER: 217.72.64.222#53(217.72.64.222)
;; WHEN: Mon Jun 24 10:41:06 CEST 2019
;; MSG SIZE rcvd: 43


dig -t MX max99.com

; <<>> DiG 9.9.4-RedHat-9.9.4-74.el7_6.1 <<>> -t MX max99.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13819
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

;; QUESTION SECTION:
;max99.com. IN MX

;; ANSWER SECTION:
max99.com. 8408 IN MX 10 mail.max99.com.

;; AUTHORITY SECTION:
max99.com. 1207 IN NS dns1.domene.si.
max99.com. 1207 IN NS dns2.domene.si.

;; ADDITIONAL SECTION:
dns2.domene.si. 9658 IN A 142.4.10.178

;; Query time: 7 msec
;; SERVER: 217.72.64.222#53(217.72.64.222)
;; WHEN: Mon Jun 24 10:42:37 CEST 2019
;; MSG SIZE rcvd: 109
phoenix
Ambassador
Ambassador
Posts: 26244
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: Zimbra installation Ldap failure

Postby phoenix » Mon Jun 24, 2019 8:57 am

The format of the hosts filee is clearly described in the wiki article and your first line is incorrect, it should be like this:

Code: Select all

192.168.100.200 mail.max99.com mail


You should also have in your resolv file just the LAN DNS servers.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
Blisk
Posts: 33
Joined: Tue May 21, 2019 7:47 am

Re: Zimbra installation Ldap failure

Postby Blisk » Mon Jun 24, 2019 9:01 am

phoenix wrote:The format of the hosts filee is clearly described in the wiki article and your first line is incorrect, it should be like this:

Code: Select all

192.168.100.200 mail.max99.com mail


You should also have in your resolv file just the LAN DNS servers.



this is my hosts file

hosts
192.168.100.200 max99.com mail.max99.com
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
phoenix
Ambassador
Ambassador
Posts: 26244
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: Zimbra installation Ldap failure

Postby phoenix » Mon Jun 24, 2019 9:10 am

I've already pointed out the correct format for the hosts file.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 14 guests