Trying to roll out new mail server before Monday

Ask questions about your setup or get help installing ZCS server (ZD section below).
User avatar
tgx
Outstanding Member
Outstanding Member
Posts: 285
Joined: Fri Sep 12, 2014 10:06 pm
Location: USA
ZCS/ZD Version: 8.8.12 CentOS 7.6.180

Trying to roll out new mail server before Monday

Postby tgx » Sun Jun 30, 2019 3:52 pm

I am 16 hours into this and have imported my old domains using zextras.
Things are mostly working EXCEPT, I cannot send or receive emails which is kinda key.
Inbound email I see passes through my firewall and hits the server but never appears in
the inboxes.

I have added the trusted networks but I am still getting:
Docs I have found for this issue are dated version 4-5, not 8+

Outbound normally will give me the message from the web client that says:

<code>
Message not sent; one or more addresses were not accepted.
Rejected addresses: somerecipient <somerecipient@yahoo.com>
method: [unknown]
msg: Invalid address: somerecipient <somerecipient@yahoo.com>. com.zimbra.cs.mailbox.MailSender$SafeSendFailedException: MESSAGE_NOT_DELIVERED; chained exception is: com.zimbra.cs.mailclient.smtp.InvalidRecipientException: RCPT failed: Invalid recipient someuser@yahoo.com: 554 5.7.1 <someuser@yahoo.com>: Relay access denied
code: mail.SEND_ABORTED_ADDRESS_FAILURE
detail: soap:Sender
trace: qtp391914049-170:1561937903906:3f4a35948ff341ea
request:

Body: {
SendMsgRequest: {
_jsns: "urn:zimbraMail",
m: {
e: [
// [0]:
{
a: "somerecipient@yahoo.com",
p: "Some recipient",
t: "t"
},
// [1]:
{
a: "user@somewhere.com",
p: "Some User",
t: "f"
}
],
idnt: "eb0b5582-e736-4012-93da-ea3889dfc6bf",
mp: [
// [0]:
{
ct: "multipart/alternative",
mp: [
// [0]:
{
content: {
_content: "test
"
},
ct: "text/plain"
},
// [1]:
{
content: {
_content: "&lt;html&gt;&lt;body&gt;&lt;div style=&quot;font-family: Times New Roman; font-size: 12pt; color: #000000&quot;&gt;&lt;div&gt;test&lt;br data-mce-bogus=&quot;1&quot;&gt;&lt;/div&gt;&lt;/div&gt;&lt;/body&gt;&lt;/html&gt;"
},
ct: "text/html"
}
]
}
],
su: {
_content: "test"
}
},
suid: 1561909557283
}
},
Header: {
context: {
_jsns: "urn:zimbra",
account: {
_content: "user@somewhere.com",
by: "name"
},
authToken: "(removed)",
csrfToken: "0_c17fb915871d0bb3ba5f1c26ef51b4085c8f134a",
notify: {
seq: 6
},
session: {
_content: 12,
id: 12
},
userAgent: {
name: "ZimbraWebClient - FF60 (Linux)",
version: "8.8.12_GA_3809"
</code>


User avatar
tgx
Outstanding Member
Outstanding Member
Posts: 285
Joined: Fri Sep 12, 2014 10:06 pm
Location: USA
ZCS/ZD Version: 8.8.12 CentOS 7.6.180

Re: Trying to roll out new mail server before Monday

Postby tgx » Sun Jun 30, 2019 4:14 pm

Okay, outbound issues are solved (dns resolver).
Any ideas on inbound?
User avatar
tgx
Outstanding Member
Outstanding Member
Posts: 285
Joined: Fri Sep 12, 2014 10:06 pm
Location: USA
ZCS/ZD Version: 8.8.12 CentOS 7.6.180

Re: Trying to roll out new mail server before Monday

Postby tgx » Sun Jun 30, 2019 5:32 pm

Okay, so I have inbound and outbound working. I had to do a server rename
and set it to the name of the old server. Now everything is working EXCEPT,
in the zimbra Administation console there is a notification that some services are not running.
If I look at the services, I see a complete set of services listed for the server as running AND
a complete listing of services under the heading of the old server name as Not Running.
Looks like I need to fix something, just not sure what.

Any help appreciated, I know it's a Sunday afternoon in US, EST.
phoenix
Ambassador
Ambassador
Posts: 26244
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: Trying to roll out new mail server before Monday

Postby phoenix » Sun Jun 30, 2019 5:37 pm

Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
User avatar
tgx
Outstanding Member
Outstanding Member
Posts: 285
Joined: Fri Sep 12, 2014 10:06 pm
Location: USA
ZCS/ZD Version: 8.8.12 CentOS 7.6.180

Re: Trying to roll out new mail server before Monday

Postby tgx » Sun Jun 30, 2019 6:13 pm

More information if I run zmloggerhostmap all I see are the old hostname entries.

The instructions from here:

https://wiki.zimbra.com/wiki/ZmSetServerName

using

zmloggerhostmap -d zimbra-sn-u14-01.example.com zimbra-sn-u14-01.example.com
zmloggerhostmap -d zimbra-sn-u14-01 zimbra-sn-u14-02.example.com

are ineffectual. They do not delete the old hostname. It acts like it does but then restarting the server
they come back.

Interestingly at the moment I only show the correct server name now but only 1 service zmconfigd shows as
running. The rest show not running, even though they are.
User avatar
tgx
Outstanding Member
Outstanding Member
Posts: 285
Joined: Fri Sep 12, 2014 10:06 pm
Location: USA
ZCS/ZD Version: 8.8.12 CentOS 7.6.180

Re: Trying to roll out new mail server before Monday

Postby tgx » Sun Jun 30, 2019 6:16 pm

Well it seems after some time all of the services are now showing as running.
I still have the old servernames in zmloggerhostmap but everything seems to be working
at the moment.
User avatar
tgx
Outstanding Member
Outstanding Member
Posts: 285
Joined: Fri Sep 12, 2014 10:06 pm
Location: USA
ZCS/ZD Version: 8.8.12 CentOS 7.6.180

Re: Trying to roll out new mail server before Monday

Postby tgx » Sun Jun 30, 2019 6:26 pm

Last bits checked:

[zimbra@server ~]$ zmprov gacf | grep server2.com

zimbraReverseProxyAvailableLookupTargets: server2.com
zimbraReverseProxyUpstreamLoginServers: server2.com
zimbraVersionCheckNotificationEmail: admin@server2.com
zimbraVersionCheckNotificationEmailFrom: admin@server2.com

These are places that still reference the old server. What is the best way to change these?
User avatar
tgx
Outstanding Member
Outstanding Member
Posts: 285
Joined: Fri Sep 12, 2014 10:06 pm
Location: USA
ZCS/ZD Version: 8.8.12 CentOS 7.6.180

Re: Trying to roll out new mail server before Monday

Postby tgx » Mon Jul 01, 2019 4:22 pm

I was able to correct these two:
zimbraVersionCheckNotificationEmail: admin@server2.com
zimbraVersionCheckNotificationEmailFrom: admin@server2.com

So I am left with:
zimbraReverseProxyAvailableLookupTargets: server2.com
zimbraReverseProxyUpstreamLoginServers: server2.com

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 4 guests