Installation of 8.8.12 CA failed.

Ask questions about your setup or get help installing ZCS server (ZD section below).
Marcosebas
Advanced member
Advanced member
Posts: 79
Joined: Tue Sep 13, 2016 11:25 pm

Installation of 8.8.12 CA failed.

Postby Marcosebas » Wed Jul 10, 2019 4:52 pm

Dear All,

I am getting the following error during the installation of ZCS 8.8.12.

Main menu

1) Common Configuration:
2) zimbra-ldap: Enabled
3) zimbra-logger: Enabled
4) zimbra-mta: Enabled
5) zimbra-dnscache: Disabled
6) zimbra-snmp: Enabled
7) zimbra-store: Enabled
8) zimbra-spell: Enabled
9) zimbra-proxy: Enabled
10) Default Class of Service Configuration:
s) Save config to file
x) Expand menu
q) Quit

*** CONFIGURATION COMPLETE - press 'a' to apply
Select from menu, or press 'a' to apply config (? - help) a
Save configuration data to a file? [Yes] yes
Save config in file: [/opt/zimbra/config.29319]
Saving config in /opt/zimbra/config.29319...done.
The system will be modified - continue? [No] yes
Operations logged to /tmp/zmsetup.20190710-114328.log
Setting local config values...done.
Initializing core config...Setting up CA...failed.


What can be the cause of it and how to solve it? I already uninstalled all packages and remove everything that could be from Zimbra in the server. I restart the installation and I get the same error again.


In the /tmp/zmsetup.20190710-122844.log I found the following error

Wed Jul 10 12:36:53 2019 Initializing core config...
Wed Jul 10 12:36:53 2019 Setting up CA...
Wed Jul 10 12:36:53 2019 *** Running as zimbra user: /opt/zimbra/bin/zmcertmgr createca -new
/opt/zimbra/bin/zmlocalconfig: line 83: exec: java: not found
new: error: no data returned from local config at /opt/zimbra/bin/zmcertmgr line 2635
LocalConfig::new('LocalConfig') called at /opt/zimbra/bin/zmcertmgr line 506
eval {...} called at /opt/zimbra/bin/zmcertmgr line 506
CertMgr::new('CertMgr', 'new', 1, 'command', 'createca') called at /opt/zimbra/bin/zmcertmgr line 408
Wed Jul 10 12:36:53 2019 failed.


User avatar
tgx
Outstanding Member
Outstanding Member
Posts: 287
Joined: Fri Sep 12, 2014 10:06 pm
Location: USA
ZCS/ZD Version: 8.8.12 CentOS 7.6.180

Re: Installation of 8.8.12 CA failed.

Postby tgx » Wed Jul 10, 2019 7:17 pm

What operating system?
Marcosebas
Advanced member
Advanced member
Posts: 79
Joined: Tue Sep 13, 2016 11:25 pm

Re: Installation of 8.8.12 CA failed.

Postby Marcosebas » Wed Jul 10, 2019 8:29 pm

I solved the issue. When you unnistall Zimbra 8.8.x with ./install -u not all packages are deletes. zimbra-openjdk is still in the server so you need to unninstall the RPM rpm -e zimbra-openjdk. After it I did the installation again and it works.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 3 guests