8.8.15 Patch 10 and 9.0.0 Patch 3 Released

Ask questions about your setup or get help installing ZCS server (ZD section below).
Andy
Posts: 13
Joined: Mon Jun 08, 2020 2:09 pm

Re: 8.8.15 Patch 10 and 9.0.0 Patch 3 Released

Postby Andy » Tue Jun 09, 2020 3:33 pm

gabrieles wrote:
Andy wrote:permissions of /var/spool/cron/zimbra file it should be owned by zimbra or root?

The group is different based on your distribution, but user's crontab are always owned by the user.

L. Mark Stone wrote:I have no such file

That's because you're on ubuntu:


[root@centos77 ~]# ll /var/spool/cron/zimbra
-rw------- 1 zimbra zimbra 2350 Nov 19 2019 /var/spool/cron/zimbra

root@ubuntu16:~# ll /var/spool/cron/crontabs/zimbra
-rw------- 1 zimbra crontab 3569 Apr 16 17:30 /var/spool/cron/crontabs/zimbra


Unfortunately, this is not a problem of permissions because on CentOS 6 with P9 I have the same file permissions and everything works fine. Something has changed in the console status service. Mates need help with this crap.

Andy


Andy
Posts: 13
Joined: Mon Jun 08, 2020 2:09 pm

Re: 8.8.15 Patch 10 and 9.0.0 Patch 3 Released

Postby Andy » Tue Jun 09, 2020 8:08 pm

ok I solved. The problem is with the P10 version of zmstatuslog - it doesn't work properly with crond. The version with P9 works perfectly - now the service status in the console is green.

Andy
User avatar
L. Mark Stone
Elite member
Elite member
Posts: 2197
Joined: Wed Oct 09, 2013 11:35 am
Location: Portland, Maine, US
ZCS/ZD Version: 8.8.15 Network Edition
Contact:

Re: 8.8.15 Patch 10 and 9.0.0 Patch 3 Released

Postby L. Mark Stone » Tue Jun 09, 2020 8:28 pm

Andy wrote:ok I solved. The problem is with the P10 version of zmstatuslog - it doesn't work properly with crond. The version with P9 works perfectly - now the service status in the console is green.

Andy


Glad you got it sorted; curious what errors crond is throwing?

All the best,
Mark
___________________________________
L. Mark Stone
Mission Critical Email - Zimbra VAR/BSP/Training Partner https://www.missioncriticalemail.com/
Zeta Alliance http://www.zetalliance.org/
Andy
Posts: 13
Joined: Mon Jun 08, 2020 2:09 pm

Re: 8.8.15 Patch 10 and 9.0.0 Patch 3 Released

Postby Andy » Tue Jun 09, 2020 8:55 pm

L. Mark Stone wrote:
Andy wrote:ok I solved. The problem is with the P10 version of zmstatuslog - it doesn't work properly with crond. The version with P9 works perfectly - now the service status in the console is green.

Andy


Glad you got it sorted; curious what errors crond is throwing?

All the best,
Mark


The P10 version did not populate entries in /var/log/zimbra-stats.log, the P9 version does it. Interestingly, the P10 version launched from the finger populated entries but already run by crond not. P9 run from the finger and from crond populated entries.
I didn't have entries like this but now I have it and everything is green

Code: Select all

Jun  9 22:46:08 host zimbramon[23662]: 23662:info: 2020-06-09 22:46:01, STATUS: a.b.c: amavis: Running
....
...
User avatar
L. Mark Stone
Elite member
Elite member
Posts: 2197
Joined: Wed Oct 09, 2013 11:35 am
Location: Portland, Maine, US
ZCS/ZD Version: 8.8.15 Network Edition
Contact:

Re: 8.8.15 Patch 10 and 9.0.0 Patch 3 Released

Postby L. Mark Stone » Tue Jun 09, 2020 11:52 pm

Thanks for posting the details Andy. Patch 10, CentOS6, crontab doesn't execute "*/2 * * * * /opt/zimbra/libexec/zmstatuslog > /dev/null 2>&1" so red X's in the Admin Console > Monitoring page because no status entries in /var/log/zimbra-stats.log.

I've asked Zimbra to take a look to see if they can reproduce.

All the best,
Mark
___________________________________
L. Mark Stone
Mission Critical Email - Zimbra VAR/BSP/Training Partner https://www.missioncriticalemail.com/
Zeta Alliance http://www.zetalliance.org/
Andy
Posts: 13
Joined: Mon Jun 08, 2020 2:09 pm

Re: 8.8.15 Patch 10 and 9.0.0 Patch 3 Released

Postby Andy » Wed Jun 10, 2020 5:58 am

L. Mark Stone wrote:Thanks for posting the details Andy. Patch 10, CentOS6, crontab doesn't execute "*/2 * * * * /opt/zimbra/libexec/zmstatuslog > /dev/null 2>&1" so red X's in the Admin Console > Monitoring page because no status entries in /var/log/zimbra-stats.log.

I've asked Zimbra to take a look to see if they can reproduce.

All the best,
Mark


Hi

zmstatuslog is the only file that has been changed in the /opt/zimbra/libexec directory after installing P10. Files with P9 and P10 are different in content. Restoration from version P9 solved the problem. My current version of Zimbra is:
Release 8.8.15_GA_3829.RHEL6_64_20190718141144 RHEL6_64 FOSS edition, Patch 8.8.15_P10. zmstatuslog from version Release 8.8.15_GA_3829.RHEL6_64_20190718141144 RHEL6_64 FOSS edition, Patch 8.8.15_P9. Maybe someone will need this solution.
Have a nice day everyone.

Andy
User avatar
jeastman
Zimbra Employee
Zimbra Employee
Posts: 33
Joined: Tue Mar 29, 2016 1:36 pm

Re: 8.8.15 Patch 10 and 9.0.0 Patch 3 Released

Postby jeastman » Wed Jun 10, 2020 1:36 pm

Thank you Andy (and Mark) for bringing this issue to our attention. The team has confirmed the issue specific to RedHat 6 (RedHat 7 appears to be fine, as well as Ubuntu). A bug has been filed (ZCS-9372 for those who wish to know) and has been added to the engineering backlog. Our Product team is still working on a means of providing some insight on issues/fixes/roadmap/etc. Best I can do at the moment is provide the ticket number which can be used in communication with our support team.
John Eastman
Andy8515
Posts: 3
Joined: Mon Jan 29, 2018 8:24 pm

Re: 8.8.15 Patch 10 and 9.0.0 Patch 3 Released

Postby Andy8515 » Mon Jun 15, 2020 7:18 pm

Hi.
Get same issue on Centos 6. Zimbra Release 8.8.15_GA_3829.RHEL6_64_20190718141144 RHEL6_64 FOSS edition, Patch 8.8.15_P10.
The problem seems to be in missing perl5 module "PP.pm"

/opt/zimbra/libexec/zmstatuslog return this:

Code: Select all

Can't locate JSON/PP.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /opt/zimbra/libexec/zmstatuslog line 20.
BEGIN failed--compilation aborted at /opt/zimbra/libexec/zmstatuslog line 20.

Unlike Centos 7, there is no oficial package named like "perl-JSON-PP" for Centos 6.

So I got "perl-JSON-PP-2.27202-2.el7.noarch.rpm" for Centos 7 from http://mirror.centos.org/centos/7/os/x86_64/Packages/, look inside and find
/usr/share/perl5/vendor_perl/JSON/PP.pm
and
/usr/share/perl5/vendor_perl/JSON/PP/Boolean.pm (used by PP.pm).
It seems just perl scripts.

So I tryed just extract content from /usr/share/perl5/vendor_perl/ from this .rpm to local
/usr/share/perl5/vendor_perl/
and after that everything worked fine.
zmsoap -z GetServiceStatusRequest return all "1", all services in admin console turned to green too.
For test, I stopped snmp, after which only snmp was set to "0" and red, so it seems that zmstatuslog works correctly now.

Mayby it’s not qute right way (or wrong way at all :) ), but it’s worked for me.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 9 guests