imapsync error from zoho mail to my mail server

Looking to migrate to ZCS? Ask here. Got a great tip or script that helped you migrate? Post it here.
wowcybaster
Posts: 1
Joined: Sat Sep 13, 2014 3:35 am

imapsync error from zoho mail to my mail server

Postby wowcybaster » Sun Apr 06, 2014 12:27 pm

i want to migrate the email form zoho mail to my mail server but fail....


-bash-4.1# /usr/bin/imapsync --host1 imap.zoho.com --port1 993 --ssl1 --user1 abc@mydomain.com --password1 password --host2 mail.mydomiain.com --user2 abc@mydomain.com --password2 password

$RCSfile: imapsync,v $ $Revision: 1.476 $ $Date: 2011/12/10 01:33:50 $

Here is a [linux] system (Linux mail.hkonea.com 2.6.32-431.1.2.el6.vs2.3.0.36.29.6.35.x86_64 #1 SMP Sat Dec 14 02:28:25 CET 2013 x86_64)

With perl 5.10.1 Mail::IMAPClient 3.35

Command line used:

/usr/bin/imapsync --host1 imap.zoho.com --port1 993 --ssl1 --user1 abc@mydomain.com --password1 MASKED --host2 mail.mydomiain.com --user2 abc@mydomain.com --password2 MASKED

Temp directory is /tmp

PID file is /tmp/imapsync.pid

Modules version list:

Mail::IMAPClient 3.35

IO::Socket 1.31

IO::Socket::INET 1.31

IO::Socket::SSL 1.31

Digest::MD5 2.39

Digest::HMAC_MD5 1.01

Term::ReadKey 2.31

Authen::NTLM 1.09
Info: turned ON syncinternaldates, will set the internal dates (arrival dates) on host2 same as host1.

Info: will try to use LOGIN authentication on host1

Info: will try to use LOGIN authentication on host2

Host1: imap server [imap.zoho.com] port [993] user [info@hkonea.com]

Host2: imap server [mail.mydomiain.com] port [143] user [info@hkonea.com]

Banner: * OK svwall.zoho.com IMAP4 Server (Zoho Mail IMAP4rev1 Server version 1.0)

Info: host imap.zoho.com says it has NO CAPABILITY for AUTHENTICATE LOGIN

Failure: error login [imap.zoho.com] with user [abc@mydomain.com] auth [LOGIN]: 2 NO [ALERT] Invalid credentials(Failure)

Failure: error login [imap.zoho.com] with user [abc@mydomain.com] auth [LOGIN]: 2 NO [ALERT] Invalid credentials(Failure)
please help me ~~~


john.holder
Posts: 6
Joined: Sat Sep 13, 2014 3:36 am

imapsync error from zoho mail to my mail server

Postby john.holder » Wed Apr 09, 2014 6:22 pm

Looks like you're trying to send a password over a method that isn't supported.
In this case, the info line before the error login tells you that you're trying to use an authentication method which either isn't right, isn't supported, or unknown. Try looking up how to send a PLAIN password auth mech using IMAP sync.
If you don't want to move to plain, then try messing with your --ssl1 parameter.

Guide to imapsync - Zimbra :: Wiki
Any condition at which IMAPSync can't negotiate the protocol returns invalid creds, not because the creds are wrong, but because it can't decipher them to know if they're wrong.

Return to “Migration”

Who is online

Users browsing this forum: No registered users and 2 guests