zmprov with encrypted password

Looking to migrate to ZCS? Ask here. Got a great tip or script that helped you migrate? Post it here.
bonoboslr
Advanced member
Advanced member
Posts: 117
Joined: Fri Sep 12, 2014 11:19 pm

zmprov with encrypted password

Postby bonoboslr » Wed Feb 27, 2008 5:36 am

i am migrating users from another mail platform, but unfortunately I only have the encrypted MD5 passwords in LDAP. How can I provision these accounts with zmprov? I do not want to ldapmodify the zimbra ldap server.
Thanks


ple
Advanced member
Advanced member
Posts: 113
Joined: Sat Sep 13, 2014 12:00 am
Location: United States
Contact:

zmprov with encrypted password

Postby ple » Fri Jan 23, 2009 3:51 pm

I run into the same roadblock as yours. Did you finally migrate all users without using ldapmodify utility?

Thanks.

PL
bonoboslr
Advanced member
Advanced member
Posts: 117
Joined: Fri Sep 12, 2014 11:19 pm

zmprov with encrypted password

Postby bonoboslr » Sun Jan 25, 2009 3:09 am

Yes, you need to give zmprov the encrypted password. As long as the prefix ({MD5}) is present, then it understands to insert the password in the encrypted format.
ple
Advanced member
Advanced member
Posts: 113
Joined: Sat Sep 13, 2014 12:00 am
Location: United States
Contact:

zmprov with encrypted password

Postby ple » Mon Jan 26, 2009 10:38 am

Say if I use zmprov to create an account John Doe using zmprov
"createAccount jdoe@domain.com {SSHA}8G1S3pulE0JnCz7Q0j02hlHxfNxxOHpMShBmdQ== displayName 'John Doe' givenName John sn Doe"

In other words, should I include the {SSHA} part or not? Thanks.

PL
linuradu
Posts: 4
Joined: Mon Apr 24, 2017 6:18 pm

Re: zmprov with encrypted password

Postby linuradu » Mon May 01, 2017 7:25 pm

Does anyone have a solution for this issue?
My existing passwords are MD5; I want to migrate from dovecot to Zimbra.

I've tried with the following options
zmprov sp test@test.org '{SSHA}25d55ad283aa400af464c76d713c07ad'
zmprov sp test@test.org '{MD5}25d55ad283aa400af464c76d713c07ad'
zmprov sp test@test.org '{crypt}25d55ad283aa400af464c76d713c07ad'

AND

zmprov sp test@test.org {SSHA}25d55ad283aa400af464c76d713c07ad
zmprov sp test@test.org {MD5}25d55ad283aa400af464c76d713c07ad
zmprov sp test@test.org {crypt}25d55ad283aa400af464c76d713c07ad

Also with

zmprov ma test@test.org ....

but doesn't work:

The password that should I use to login after editing with that commands is: "{crypt}25d55ad283aa400af464c76d713c07ad" or another one with prefixes.

Does anyone have an answer for this issue?
Was changed Zimbra API and should we use another command to insert encrypted password?

Return to “Migration”

Who is online

Users browsing this forum: No registered users and 4 guests