Page 1 of 1

zmprov with encrypted password

Posted: Wed Feb 27, 2008 5:36 am
by bonoboslr
i am migrating users from another mail platform, but unfortunately I only have the encrypted MD5 passwords in LDAP. How can I provision these accounts with zmprov? I do not want to ldapmodify the zimbra ldap server.
Thanks

zmprov with encrypted password

Posted: Fri Jan 23, 2009 3:51 pm
by ple
I run into the same roadblock as yours. Did you finally migrate all users without using ldapmodify utility?

Thanks.

PL

zmprov with encrypted password

Posted: Sun Jan 25, 2009 3:09 am
by bonoboslr
Yes, you need to give zmprov the encrypted password. As long as the prefix ({MD5}) is present, then it understands to insert the password in the encrypted format.

zmprov with encrypted password

Posted: Mon Jan 26, 2009 10:38 am
by ple
Say if I use zmprov to create an account John Doe using zmprov
"createAccount jdoe@domain.com {SSHA}8G1S3pulE0JnCz7Q0j02hlHxfNxxOHpMShBmdQ== displayName 'John Doe' givenName John sn Doe"

In other words, should I include the {SSHA} part or not? Thanks.

PL

Re: zmprov with encrypted password

Posted: Mon May 01, 2017 7:25 pm
by linuradu
Does anyone have a solution for this issue?
My existing passwords are MD5; I want to migrate from dovecot to Zimbra.

I've tried with the following options
zmprov sp test@test.org '{SSHA}25d55ad283aa400af464c76d713c07ad'
zmprov sp test@test.org '{MD5}25d55ad283aa400af464c76d713c07ad'
zmprov sp test@test.org '{crypt}25d55ad283aa400af464c76d713c07ad'

AND

zmprov sp test@test.org {SSHA}25d55ad283aa400af464c76d713c07ad
zmprov sp test@test.org {MD5}25d55ad283aa400af464c76d713c07ad
zmprov sp test@test.org {crypt}25d55ad283aa400af464c76d713c07ad

Also with

zmprov ma test@test.org ....

but doesn't work:

The password that should I use to login after editing with that commands is: "{crypt}25d55ad283aa400af464c76d713c07ad" or another one with prefixes.

Does anyone have an answer for this issue?
Was changed Zimbra API and should we use another command to insert encrypted password?

Re: zmprov with encrypted password

Posted: Sat Dec 14, 2019 7:38 am
by mqaroush
Hello
are you fix that or not??

Re: zmprov with encrypted password

Posted: Tue Dec 31, 2019 4:18 pm
by DualBoot
you can set the password with zmprov like that :
zmprov -l ma account_name@domain.tld userPassword "{SSHA512}blabalabalebdjehzhezhobalabalabbalab"

Regards,

Re: zmprov with encrypted password

Posted: Thu Apr 30, 2020 5:49 am
by saman_s1
Hi all,
I have almost same issue, and after 6 years it seems that this command not working properly for some reason, I search all forums, google, etc., but nobody knows why it's not working,
but with try and test over and over, I found somehow it works for me BUT just one time, let me explain more,
I user ubuntu 18.04 with zimbra 8.6 and try to migrate my user with their hashed password {SSHA512}
I found if I use this two syntax it will work for users just one time login, it means when I use the commands, my user can login one time and after that they can't login again and have the error that user name or password is wrong (the general error I mean), also at first login if they try to change password, while they input old password they faced that the old password is wrong !!!
When I do the commands again on shell they can login just one more time, and again the same error, it is really weird for me !!
another issue that I face was I can't use the 2nd command repetitively and in that way its not working at all, so I try over and over and found if I use 1st command then use 2nd one it will work just one time and if I use twice the 2nd command it not working at all, each time for changing password to its original (hash password) I have to use both 1st and 2nd command to work only one time login !

here is the command that I use:
1st: zmprov ma user@domain userPassword "xxxxxx" the xxxxxx is clear text password like 123456
2nd: zmprov -l ma user@domain userPassword {SSHA512}xxRthmDaYFzAkP97efJA1QUMtPNQYLwifJF20oJoPNmxeYh5vDJgv3BCQtWFBThOEI1dOh7H+jS2+MovqcrQhkbAlA=

right now I'm going to migrate from iredmail to zimbra and I can't change my users password also I can't use this command, so any help will make me happy, thanks.

Re: zmprov with encrypted password

Posted: Thu Apr 30, 2020 9:05 am
by DualBoot
When you use zmprov -l you directly change the ldap value of your attribute.
Zimbra works a lot of with cache so maybe there is a problem here. Another trail is replication between Zimbra LDAP.

After changing your password, flush all the cache to check this hypothesis.

Re: zmprov with encrypted password

Posted: Sun May 03, 2020 6:32 am
by saman_s1
DualBoot wrote:When you use zmprov -l you directly change the ldap value of your attribute.
Zimbra works a lot of with cache so maybe there is a problem here. Another trail is replication between Zimbra LDAP.

After changing your password, flush all the cache to check this hypothesis.


Thanks, I do FlushCache and also reboot server, but the issue still exist. :/