Page 1 of 1

Hard size limit on imapsync xfer to Zimbra?

Posted: Wed Sep 29, 2010 5:24 pm
by jmadden
I'm trying to migrate from a Scalix server to Zimbra NE 6.0.8 and I seem to have a hit a hard size limit.

This mailbox (a test mailbox) has 7 messages in it, varying from 10MB to 120MB. I'm using the latest

version of imapsync to try this.
I can transfer the other 6 messages with no problem, the largest being about 90MB in size.

The particular message I'm stuck on is about 120MB. It's a simple 1 line text with a large attachment.
In desperation, and after 2 weeks of searching, I've set the following parameters,

and completely rebooted the server. It seems to make no difference (am I reading that correctly that

I'm setting these to 300MB?)
zmprov mcf zimbraFileUploadMaxSize 300000000

zmprov mcf zimbraMtaMaxMessageSize 300000000

zmprov mcf zimbraMailContentMaxSize 300000000

zmprov mcf zimbraImapMaxRequestSize 300000000
I get this error every time. (the other 6 messages are already synced, so they don't xfer again) Any thoughts, or have I missed something obvious? :confused:


- msg INBOX/21 couldn't append (Subject:[EXE attached]) to folder INBOX: 17 NO maximum message size exceeded

[Sent] -> [Sent]

[Sent Items] -> [Sent Items]

++++ End looping on each folder

++++ Statistics

Transfer time : 26 sec

Messages transferred : 0

Messages skipped : 6

Messages found duplicate on host1 : 0

Messages found duplicate on host2 : 0

Messages void (noheader) on host1 : 0

Messages void (noheader) on host2 : 0

Messages deleted on host1 : 0

Messages deleted on host2 : 0

Total bytes transferred : 0

Total bytes duplicate host1 : 0

Total bytes duplicate host2 : 0

Total bytes skipped : 255577355

Total bytes error : 124839910

Message rate : 0.0 messages/s

Average bandwidth rate : 0.0 KiB/s

Reconnections to host1 : 0

Reconnections to host2 : 0

Detected 1 errors

Hard size limit on imapsync xfer to Zimbra?

Posted: Thu Sep 30, 2010 2:03 am
by 13445raj
you have all the right prams..even upto version 6.0.x
Try setting all to 500MB (500000000) or more..

some time BINARY to ASCII conversion of attahments can really bloat the blob size.
it should work

Hard size limit on imapsync xfer to Zimbra?

Posted: Thu Sep 30, 2010 9:08 am
by jmadden
Thanks for the reply, raj. I was pretty sure I had all the params after researching for 2 weeks. However, increasing the size has made no difference. I've increased each parameter to 2GB (2000000000) and rebooted with the same end result.(increasing above that starts to give error messages (zimbraMtaMaxMessageSize must be a valid integer: 2200000000) Surely that should be enough for a little 120MB attachment. :p I've got several users that have large (250MB) attachments, that I need to migrate, so it's necessary that I figure this out if I'm to continue on the path to Zimbra. If there's something maybe corrupt about the installation, I'm not above reinstalling Zimbra. It's the only thing running on this machine that I'm using strictly for evaluation (CentOS 5.5, 3GB RAM, 110GB disk with 81GB available). Our production server would be much beefier. Is there any more information I can provide that will be helpful?


Hard size limit on imapsync xfer to Zimbra?

Posted: Mon Oct 04, 2010 10:12 am
by Matuscak
When we migrated with Imapsync, we ran into some cases where a small number of specific source messages just didn't work. Other larger files would be fine, and those files looked OK on the source system, but they just wouldn't work. We never figured out why those were broke.
You might want to try some other users just to see if there is something weird with that particular message.

Hard size limit on imapsync xfer to Zimbra?

Posted: Mon Oct 04, 2010 12:26 pm
by jmadden
Thanks for that suggestion. I did try another file of similar size, and had the same result. I've even tried using Thunderbird with both accounts set up as a transfer method by copying from one mailbox to the other. Each time I get "The mail server for account ZTest responded: maximum message size exceeded."
Have I missed an obvious (or not so obvious) setting somewhere? (wouldn't be the first time today!) :rolleyes:

Hard size limit on imapsync xfer to Zimbra?

Posted: Wed Oct 13, 2010 12:04 pm
by jmadden
Oh wow, is there really no fix for this? This will have to be a dealbreaker for us if we can find a reliable way to migrate our emails from Scalix to Zimbra. :( I see lots of posts about people migrating many thousands of accounts with no problems, but nothing really about a few accounts (about 100) with some very large attachments. I've spent weeks pouring through the forums and the wiki, but have not had any success. It seems to fail whenever the attachment size approaches 100MB or larger. Is there a better way than imapsync to try and migrate? (with the deafening silence from Xandros/Scalix the last 9 months, I expect a lot of people to start looking at Zimbra - perhaps Zimbra could create a migration utility the way they've done for other email systems? ;) )

Hard size limit on imapsync xfer to Zimbra?

Posted: Wed Oct 13, 2010 12:31 pm
by phoenix
Have you also tried setting the zimbraImapMaxRequestSize to your required value? See this thread: If that doesn't fix it you should post details of what parameters you're using for IMAPSYNC (and which version) and the exact errors you see in the log files[/URL].