Imapsync auth [PLAIN]: 3 NO AUTHENTICATE failed

Looking to migrate to ZCS? Ask here. Got a great tip or script that helped you migrate? Post it here.
jazzyzha
Posts: 1
Joined: Tue Aug 23, 2016 2:52 am

Imapsync auth [PLAIN]: 3 NO AUTHENTICATE failed

Postby jazzyzha » Mon Apr 17, 2017 4:19 am

Dear All,

I'm trying to migrate mailbox with imapsync. Before running the script I'm using zmprov -l gaa > /srv/sync-mail/acc.txt to generate list of email accounts, then using this script with admin authuser to migrate:

Code: Select all

#!/bin/sh
clear

LOCATION=`pwd`
USER_LIST="acc.txt"
USERS=`cat $LOCATION/$USER_LIST`

echo "Looping for all users"
for ACCOUNT in $USERS; do
        ACC1=`echo $ACCOUNT | awk -F@ '{print $1}'`;
        ACC2=`echo $ACCOUNT | cut -d '.' -f1`

#Import email
imapsync --nosyncacls --subscribe --syncinternaldates --fast --host1 192.168.1.6 --user1 $ACCOUNT --authuser1 admin --password1 opensesame --tls1 --host2 192.168.1.8 --user2 $ACCOUNT --authuser2 admin --password2 opensesame --tls2

        echo ""
        echo "Import data email account : $ACCOUNT finished, Press ENTER for next account..."
        echo ""
       read presskey
done
echo "Synchronization done"


But I got the following output:

Code: Select all

Host1: will try to use PLAIN authentication on host1
Host2: will try to use PLAIN authentication on host2
Host1: imap connexion timeout is 120 seconds
Host2: imap connexion timeout is 120 seconds
Host1: IMAP server [192.168.1.6] port [143] user [panda@acme.com]
Host2: IMAP server [192.168.1.8] port [143] user [panda@acme.com]
Host1: connecting and login on host1 [192.168.1.6] port [143] with user [panda@acme.com]
Host1 banner: * OK IMAP4 ready
Host1: Socket successfuly converted to SSL
Host1: 192.168.1.6 says it has CAPABILITY for AUTHENTICATE PLAIN
Host1 failure: Error login on [192.168.1.6] with user [panda@acme.com] auth [PLAIN]: 3 NO AUTHENTICATE failed



But if I try to use this command its success:

Code: Select all

imapsync --nosyncacls --subscribe --syncinternaldates --fast --host1 192.168.1.6 --user1 panda --password1 opensesame --tls1 --host2 192.168.1.8 --user2 panda --password2 opensesame --tls2


Please help, did I missed something? any help appreciated :)


Return to “Migration”

Who is online

Users browsing this forum: No registered users and 1 guest