Migration Wizard

Looking to migrate to ZCS? Ask here. Got a great tip or script that helped you migrate? Post it here.
Posts: 12
Joined: Tue Dec 12, 2017 8:14 pm

Migration Wizard

Postby shanmarsh28 » Tue Dec 12, 2017 8:49 pm

Hi Guys, I hope you can help.

I am writing this as a last resort after spending an entire afternoon trying to find a solution - I find nothing!

Basically, I followed these instructions to migrate a domains accounts from a generic IMAP Server to Zimbra: https://wiki.zimbra.com/wiki/Migrate_fr ... 0.x_or_8.x

The first time I tried to import everything looked great! The only issue (not related to Zimbra), I was given three incorrect passwords so out of the six mailboxes three succeeded and three failed. Fair enough I thought!

I found the three accounts that had failed, I repeated the process with the three accounts but Zimbra would not let me run the import again. The error I got was:

Code: Select all

at com.zimbra.bp.BulkProvisionException.EMPTY_IMPORT_QUEUE(BulkProvisionException.java:94)

So naturally I tried to delete the completed job. I was then presented with this error:

Code: Select all

2017-12-12 14:08:42,584 WARN  [qtp1068934215-35877:https:https://mydomain.net:7071/service/admin/soap/PurgeBulkIMAPImportTa$
com.zimbra.common.service.ServiceException: system failure: unable to delete data source: 48cd26fc-e869-49c1-8ccd-57487eb12102
        at com.zimbra.common.service.ServiceException.FAILURE(ServiceException.java:286)

I then attempted the XML import again and was presented with:

Code: Select all

at com.zimbra.bp.BulkProvisionException.EMPTY_IMPORT_QUEUE(BulkProvisionException.java:94)

AND so on!!!

The only way I could break out of this loop was to DELETE the three affected mailboxes and re-create them. THEN I was able to import successfully HOWEVER I got some strange thing happen ..

The Import wizard ran but instead of saying a total of 6 imports, it now had a total of 9!!

9 total
3 succeeded
0 failed.

Then it just hung (stayed on processing) until several hours later I when I eventually deleted the task and received the service exception error mentioned above.

Soo my question is this ...

What the hell is going on? Do I have to get everything absolutely spot on first time when importing accounts? It seems you get one shot deal then your dead!

Is there a way to purge the system after a failed import so that it can be re-run?

Your help is greatly appreciated as I could find nothing to help me with this anywhere!


Version: 8.7.11_GA_1854_FOSS OSE
Ubuntu 16.4 LTS

Posts: 12
Joined: Tue Dec 12, 2017 8:14 pm

Re: Migration Wizard

Postby shanmarsh28 » Wed Dec 13, 2017 11:21 pm

Anyone? Surely someone knows whats going on?

Return to “Migration”

Who is online

Users browsing this forum: No registered users and 6 guests