Mail server host name in greeting

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
phoenix
Ambassador
Ambassador
Posts: 26617
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Mail server host name in greeting

Postby phoenix » Tue Apr 03, 2007 2:23 pm

[quote user="nfear24"]my server Hello line is this 220 mail.tickus.com ESMTP Postfix I want it to be tickus.com[/QUOTE]No, you don't want it to be that - that's wrong. It has to be a fully qualified domain name - again, that's made up from your server name 'mail' and your domain name 'tickus.com' = mail.tickus.com.
The name mail.tickus.com DOES exist at your IP address it's the FULLY QUALIFIED DOMAIN NAME of your Zimbra server. How many times can I say the same thing, if you don't believe me then please search the forums for 'DNS in a Nutshell' or any of the dozens of posts that cover DNS problems and their resolution.


Regards

Bill

Rspamd: A high performance spamassassin replacement

Per ardua ad astra
dijichi2
Elite member
Elite member
Posts: 1133
Joined: Fri Sep 12, 2014 10:00 pm

Mail server host name in greeting

Postby dijichi2 » Tue Apr 03, 2007 7:13 pm

actually, tickus.com is an FQDN. in this particular situation i'm not sure that using it will work however, as zimbra usually expects an fqdn and a shortname in /etc/hosts that matches the server hostname, and there's no way of specifying the short host of an @ record. it may be possible to change the servername in the install wizard, but i dont see the point of this.
also, your mail.tickus.com is a CNAME to tickus.com. generally CNAMEs are a bad idea unless there's a particular reason to use one, multiple A records pointing to the same IP are more reliable. this is particularly true with MX records, you must not use a CNAME with MX records. in this case your DNS is correct, because the MX points to the A, not CNAME record. your DNS is correct. i'm just not sure zimbra will cope with the /etc/hosts format in this case.
change your mail.tickus.com to an A record, repoint your MX to mail.tickus.com (that's not 100% necessary but you might as well, will make your setup less ambiguous). live with mail.tickus.com in your smtp banner, i really don't get why that's a problem. it's normal, it's how 99% of everyone else does it.
nfear24
Advanced member
Advanced member
Posts: 121
Joined: Fri Sep 12, 2014 10:23 pm

Mail server host name in greeting

Postby nfear24 » Tue Apr 03, 2007 10:13 pm

[quote user="dijichi2"]actually, tickus.com is an FQDN. in this particular situation i'm not sure that using it will work however, as zimbra usually expects an fqdn and a shortname in /etc/hosts that matches the server hostname, and there's no way of specifying the short host of an @ record. it may be possible to change the servername in the install wizard, but i dont see the point of this.
also, your mail.tickus.com is a CNAME to tickus.com. generally CNAMEs are a bad idea unless there's a particular reason to use one, multiple A records pointing to the same IP are more reliable. this is particularly true with MX records, you must not use a CNAME with MX records. in this case your DNS is correct, because the MX points to the A, not CNAME record. your DNS is correct. i'm just not sure zimbra will cope with the /etc/hosts format in this case.
change your mail.tickus.com to an A record, repoint your MX to mail.tickus.com (that's not 100% necessary but you might as well, will make your setup less ambiguous). live with mail.tickus.com in your smtp banner, i really don't get why that's a problem. it's normal, it's how 99% of everyone else does it.[/QUOTE]
Ok, what should I setup then as you explain. here is what I have.

locally on the zimbra server I have these settings setup with the split dns:
[QUOTE]root@mail:~# host `hostname`

mail.tickus.com has address 192.168.0.104

mail.tickus.com mail is handled by 10 mail.tickus.com.[/QUOTE]
zone file for split dns has these settings:
[QUOTE] ; Define the nameservers and the mail servers

IN NS 192.168.0.104 ; local ip

IN A 192.168.0.104 ; local ip

IN MX 10 mail.tickus.com. ;MXrecord[/QUOTE]
/etc/hosts file

[QUOTE]127.0.0.1 localhost.localdomain localhost

192.168.1.103 FQDN mail.tickus.com mail

192.168.1.103 tickus.com mail

[/QUOTE]
My domain is through godaddy.com and I have these settings there:
[QUOTE]

(A)Host - Points to

@ - 12.236.45.155

mail.tickus.com - 12.236.45.155
(MX)

priority Host Goes to

10 @ tickus.com

20 mail.tickus.com tickus.com[/QUOTE]
dijichi2
Elite member
Elite member
Posts: 1133
Joined: Fri Sep 12, 2014 10:00 pm

Mail server host name in greeting

Postby dijichi2 » Wed Apr 04, 2007 2:45 am

[QUOTE]zone file for split dns has these settings:
Quote:

; Define the nameservers and the mail servers

IN NS 192.168.0.104 ; local ip

IN A 192.168.0.104 ; local ip

IN MX 10 mail.tickus.com. ;MXrecord[/QUOTE]
NS points to A record not IP. Change A record to mail.tickus.com, not the origin. MX is fine.



IN NS mail.tickus.com.

mail IN A 192.186.0.104

IN MX 10 mail.tickus.com.

[QUOTE]/etc/hosts file

127.0.0.1 localhost.localdomain localhost

192.168.1.103 FQDN mail.tickus.com mail

192.168.1.103 tickus.com mail[/QUOTE]
Remove FQDN! You do realise you're pointing to different IP from the DNS, right? Get rid of your tickus.com entry. You can't have two entries for same IP, second will overwrite the first.

127.0.0.1 localhost.localdomain localhost

192.168.1.104 mail.tickus.com mail

[QUOTE](A)Host - Points to

@ - 12.236.45.155

mail.tickus.com - 12.236.45.155
(MX)

priority Host Goes to

10 @ tickus.com

20 mail.tickus.com tickus.com[/QUOTE]
OK. Remove @ record. Remove first MX.

[QUOTE](A)Host - Points to

mail.tickus.com - 12.236.45.155
(MX)

priority Host Goes to

10 mail.tickus.com tickus.com

[/QUOTE]
nfear24
Advanced member
Advanced member
Posts: 121
Joined: Fri Sep 12, 2014 10:23 pm

Mail server host name in greeting

Postby nfear24 » Thu Apr 05, 2007 9:49 am

locally everything checks out ok, but the external DNS never seems to work no matter what I try. The only way it will ever read the mx record is if its tickus.com I have tried many settings and it just continues to only work and read this mx record:
Your 1 MX record is:

30 tickus.com
see attached file.

external_dns.jpg

tbullock
Outstanding Member
Outstanding Member
Posts: 231
Joined: Fri Sep 12, 2014 9:57 pm

Mail server host name in greeting

Postby tbullock » Thu Apr 05, 2007 3:12 pm

Not sure if this will help or not, but I had to change my helo greeting as well.
I edited my main.cf file and added:
smtp_helo_name = webmail.avmax.ca
I did this because my actual host name on this machine is not a public domain but rather an internal one here:
myhostname = webmail.avmax-internal.net
nfear24
Advanced member
Advanced member
Posts: 121
Joined: Fri Sep 12, 2014 10:23 pm

Mail server host name in greeting

Postby nfear24 » Thu Apr 05, 2007 4:07 pm

[quote user="tbullock"]Not sure if this will help or not, but I had to change my helo greeting as well.
I edited my main.cf file and added:
smtp_helo_name = webmail.avmax.ca
I did this because my actual host name on this machine is not a public domain but rather an internal one here:
myhostname = webmail.avmax-internal.net[/QUOTE]
when I add that line and change it to
smtp_helo_name = tickus.com
still doesnt use that.
Nicrad
Posts: 24
Joined: Fri Sep 12, 2014 10:30 pm

Mail server host name in greeting

Postby Nicrad » Tue Apr 10, 2007 6:35 pm

[quote user="tbullock"]Not sure if this will help or not, but I had to change my helo greeting as well.
I edited my main.cf file and added:
smtp_helo_name = webmail.avmax.ca
I did this because my actual host name on this machine is not a public domain but rather an internal one here:
myhostname = webmail.avmax-internal.net[/QUOTE]
That is what I've been looking / asking for since I started my install of Zimbra, I'll test it out now.
Thanks
Nicrad
Posts: 24
Joined: Fri Sep 12, 2014 10:30 pm

Mail server host name in greeting

Postby Nicrad » Tue Apr 10, 2007 6:40 pm

[quote user="nfear24"]when I add that line and change it to
smtp_helo_name = tickus.com
still doesnt use that.[/QUOTE]
I got mine to work, I placed mine directly after the line in the main.cf file that reads smtpd_helo_required = yes then just stop and start Zimbra and send yourself a test message to confirm it.
nfear24
Advanced member
Advanced member
Posts: 121
Joined: Fri Sep 12, 2014 10:23 pm

Mail server host name in greeting

Postby nfear24 » Tue Apr 10, 2007 7:09 pm

Problem has been fixed but I still am being blocked by a friends email service and also hotmail. everywhere else is fine.

Return to “Administrators”

Who is online

Users browsing this forum: No registered users and 16 guests