Page 3 of 5

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Tue Jul 31, 2007 4:30 am
by Vipergts
I also had the same problem, but I could solve this rather easily.
I moved main.cvd to main.cvd and for daily.cvd I did the same. Then I downloaded the files myself from the server.

Changed the owner and group to zimbra, restarted zimbra and all problems were solved.

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Wed Aug 01, 2007 12:17 am
by ipguru99
I think I have the same thing.. but I tried what algogr did, and it never copies over the pid file. I double checked, created the empty file as zimbra user, backed up the zmanti script (good suggestion), then tried to restart clamd.. nothing. I just keeps dying. I also lost power about 14 days ago, but there are only 2 users in the house running zimbra, so it wasn't as noticeable.
Using Ubuntu 6.06, Ubuntu 4.5.5 Zimbra. I have stopped the antivirus in the web admin console, and restarted Zimbra.. now everything works fine. Deferred messages were re-queued and went through just fine.
Anybody else help/solved this?
thanks!

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Wed Aug 01, 2007 12:22 am
by jholder
Just an FYI-

we're currently investigating a bug where in certain instances, the CLAMAV db can corrupt, causing delivery issues.
See Bug 18312 - clamd corrupt db

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Wed Aug 01, 2007 1:08 pm
by greywolf
I am also unable to get clamd started. It was working earlier today and after a restart of the zimbra processes, it is now unable to bind to the port and does not create a pid. I have tried everything previously posted in the thread to no avail. Currently running without anti virus.
Version 4.5.6 on Ubuntu 6.10

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Wed Aug 01, 2007 1:14 pm
by greywolf
Also I should state that I had no crash of my server or Zimbra.

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Wed Aug 01, 2007 1:55 pm
by greywolf
OK found the answer to my issue here:

Basically">http://www.zimbra.com/forums/installation/9268-clamav-problem-whats-happening.html
Basically
it takes 3 minutes for clamd to read in the db file. Once it does it will bind to the port and start normally. I changed the interval in this file:
/opt/zimbra/libexec/zmmtaconfig
from 120 to 180. Now it starts just fine.

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Wed Aug 01, 2007 5:12 pm
by ipguru99
Just going into the web console and starting antivirus fired off everything and it still seemed to fail. Stopping zimbra and starting it worked, though.
thanks! This did it! Just in case anyone else had an 'almost' underpowered machine... this install is on a pIII 800 with 512mb of memory. I am wondering if anyone else that was having this problem was on a slower machine?.. like maybe that was why it was taking SO long to start?
Thanks!

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Wed Aug 01, 2007 7:44 pm
by neilmc
[quote user="greywolf"]..... snip... I changed the interval in this file:
/opt/zimbra/libexec/zmmtaconfig
from 120 to 180. Now it starts just fine.[/QUOTE]
That worked on ours too. AV service wouldn't start without changing the interval setting.
We're using 5 beta 2 where the default seems to be 60 seconds. It's at 180 now, but I might try dropping back to 120 later today.
We've got an old P4 2.4ghz Dell desktop machine with 768mb ram & about 30 mailboxes on ours. (about 8-10 get regular daily use).

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Sat Aug 04, 2007 2:02 pm
by stormchas3r
Well. I am having the same problem as all of you, but mine is not working. I rm -R /db and reinstalled with update. Changed the interval to 180 and clam is still failing.
Anymore thoughts?

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Sat Aug 04, 2007 3:12 pm
by stormchas3r
Ok, now I am really sweating. i disabled clamav, but now the mail that I am sending is getting deferred. When I look at the deferred mail, it says that my connection to smtp is timing out.
I am not really sure why this is happening. Is it possible that my ISP is blocking port 25?
Please let me know when this bug is fixed.