Page 4 of 5

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Fri Aug 10, 2007 8:52 am
by SpEnTBoY
Ok here's all I did ... exactly what jholder suggested:
1. removed the db directory and all its' content (rm -rf)

2. grabbed the latest 4.5.6 for RHEL5 (I wanted to upgrade anyway)

3. let everything restart

4. All was/is happy
Just flushed the deferred stuff and boom it's all back. Hopefully everyone else is getting their stuff back as easy.
--

Lonny

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Fri Aug 10, 2007 9:27 am
by SpEnTBoY
After the upgrade (I'm sure this is covered somewhere) I had to redeploy my zimlets ;)

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Sun Aug 12, 2007 4:17 am
by scott.likens
Personally, I found upgrading to the latest clamav 0.91.1 to solve my issue.
I had tried deleting the db, upgrading to 4.5.6, no change.
Once I upgraded to the latest clamav, it was stable, it stayed up... so I re-enabled AS/AV, turned on amavis, turned on clamav, verified it was running and listening on 3310.
Then, postfix stop postfix start (as it runs libexec/zmmtaconfig rewrite)
then it was running with ClamAV and amavis-new...
I wonder if I upgrade amavis if it'll help even further with my woes lately...

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Thu Aug 16, 2007 11:39 pm
by iceruam
I have upgraded my zimbra 8 aug, it worked until 16 aug.

Now all my mail goes to deferred, can't connnect to 127.0.0.1:3310 connection refused.

I deleted the clamav-0.90.2, reninstalled 4.5.6, it at least sent the mail out after installation was complete but 20 minutes later anitvirus stopped.

now the mail is going back to deferred.

The only thing I did today was

added this

------------------------------------------------------

zmprov mcf zimbraMtaRestriction reject_invalid_hostname zimbraMtaRestriction reject_non-fqdn_hostname zimbraMtaRestriction reject_non_fqdn_sender zimbraMtaRestriction "reject_rbl_client dnsbl.njabl.org" zimbraMtaRestriction "reject_rbl_client cbl.abuseat.org" zimbraMtaRestriction "reject_rbl_client bl.spamcop.net" zimbraMtaRestriction "reject_rbl_client dnsbl.sorbs.net" zimbraMtaRestriction "reject_rbl_client sbl.spamhaus.org" zimbraMtaRestriction "reject_rbl_client relays.mail-abuse.org"
____________________________________________________________

restarted the server and to my discovery it had failed.

I do not know what to do next.

Help please
Ice

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Thu Oct 04, 2007 2:09 pm
by Russianspi
I too, had this problem, and after reading this thread, I thought that I might have to wait for the 5.0 RC1 to come out (I am currently running Beta 3) to solve my problem. I did a hard power-down of my Zimbra VM out of impatience (I know, bad plan...hindsight's 20/20). After sifting through what data I could find on this issue, I think that I found an easy solution. I found the bug that was referenced earlier on this post (see ClamAV: clamd corrupt db. In the bug was a bit of command line code that was offered as a suggestion, and deemed not to work, but after taking another look at it, it (tentatively) seems to have solved my problem without me having to upgrade Zimbra or ClamAV. This is what I did:
I disabled Antivirus in both places on the admin control panel first.
(I don't know if this was important, but I did it...)

(As root)
rm -R /tmp/clam*


su zimbra

mkdir /tmp/clamdb

mv /opt/zimbra/clamav/db/* /tmp/clamdb

zmprov ms mail.mydomainname.com +zimbraServiceEnabled antivirus

/opt/zimbra/clamav/bin/freshclam --config-file=/opt/zimbra/conf/freshclam.conf
(Got an error here...Ignored it)

zmamavisdctl stop

zmamavisdctl start

zmantivirusctl stop

zmantivirusctl start

Hope this helps...everything tests fine, at least for now...

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Fri Oct 05, 2007 8:54 am
by hurstel
I'm running Beta3 and lost power to the server and now have this very fun problem. I tried doing what Russianspi did but now I just have another failed instance of antivirus in the status. I would appreciate any help.

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Fri Oct 05, 2007 10:58 am
by Russianspi
I edited my last post to include this line now: [QUOTE]I disabled Antivirus in both places on the admin control panel first.[/QUOTE]

That may or may not make a difference. Either way, now you have another option: RC1 has been released, so an upgrade is now a potential solution for early adopters like you and myself. Hope this helps.

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Fri Oct 05, 2007 11:09 am
by hurstel
I found something else about editing the zmmtaconfig file and changing "interval => 60," to "interval => 180," I did that and everything started working. I don't have the actual post handy.

[quote user="Russianspi"]I edited my last post to include this line now:

That may or may not make a difference. Either way, now you have another option: RC1 has been released, so an upgrade is now a potential solution for early adopters like you and myself. Hope this helps.[/QUOTE]

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Mon Oct 08, 2007 10:07 pm
by ipguru99
I will try the Russianspi solution next time. I say the next time because this has happened twice now. By the second time, I did what hurstel did from memory.. which was:
Shut down the antivirus from the admin web.

Modify the /opt/zimbra/libexec/zmmtaconfig file to read (on line 55)

 interval    => 180,
instead of 60.

restart Zimbra, enable antivirus from the admin web.
I say two times, because I use the backup script from SourceForge.net: ZCS Tools

and every time I shut down Zimbra, that value gets changed from 180 back to 60.
I am using ZimbraOSS 4.5.5 on Ubuntu 6.06.1

[SOLVED] Antivirus not running, sending all mail to deferred queue

Posted: Mon Oct 08, 2007 10:18 pm
by mmorse
[quote user="ipguru99"]

Shut down the antivirus from the admin web.

Modify the /opt/zimbra/libexec/zmmtaconfig file to read (on line 55)

interval => 180

instead of 60.

restart Zimbra, enable antivirus from the admin web.

I am using ZimbraOSS 4.5.5 on Ubuntu 6.06.1[/quote]
You should upgrade to 4.5.7/8
See some comments here: /forums/installation/11957-clamd-pid-no-such-file.html#post61912