Page 1 of 1

Disappearing emails tied to conversations

Posted: Mon Mar 11, 2013 11:10 am
by bb101
Hello -
We have had our Zimbra 8 server up and running for a few months now and are generally very happy with it. A very odd thing has happened over the past day or so which I am finding hard to explain. Perhaps other people on the forum have experienced it too?
Last night I sent an email to a client (it contained 1 PDF attachment) using Mac OS 10.8's Mail.app, and the email appeared as expected in my Sent folder, and was also there this morning (I checked).
Just after lunch, I received a reply from the client and upon looking through my Sent folder, the original email had disappeared! I don't have conversation view turned on in Mail.app so I did a search - still nothing. Not in Trash, not in Spam, haven't deleted any other emails today. I have since restarted Zimbra and also reindexed my mailbox through the Administration - still no message.
Looking in /opt/zimbra/log/mailbox.log for last night, I can see the message was saved to the Sent folder (with some warnings that seem endemic to the Mail.app client):
2013-03-10 23:20:40,288 INFO  [ImapSSLServer-669] [name=me@company.com;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - copying message data from existing session: Drafts

2013-03-10 23:20:40,288 INFO [ImapSSLServer-669] [name=me@company.com;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - selected folder Drafts

2013-03-10 23:20:41,762 INFO [ImapSSLServer-669] [name=me@company.com;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] HttpMethodDirector - I/O exception (org.apache.commons.httpclient.NoHttpResponseException) caught when processing request: The server mail.company.com failed to respond

2013-03-10 23:20:41,762 INFO [ImapSSLServer-669] [name=me@company.com;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] HttpMethodDirector - Retrying request

2013-03-10 23:20:41,769 WARN [ImapSSLServer-669] [name=me@company.com;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] ParsedMessage - Unable to parse part=2 filename=file.pdf content-type=application/pdf message-id=

2013-03-10 23:20:41,769 INFO [ImapSSLServer-669] [name=me@company.com;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] mailop - Adding Message: id=138305, Message-ID=, parentId=-1, folderId=5, folderName=Sent.

2013-03-10 23:20:42,696 INFO [ImapSSLServer-669] [name=me@company.com;mid=8;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - copying message data from existing session: Drafts

2013-03-10 23:20:42,696 INFO [ImapSSLServer-669] [name=me@company.com;mid=8;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - selected folder Drafts

2013-03-10 23:20:42,729 WARN [ImapSSLServer-669] [name=me@company.com;mid=8;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - possible misconfigured client; requested ignored header in part BODY[HEADER.FIELDS (CONTENT-CLASS)]

2013-03-10 23:20:42,767 WARN [ImapSSLServer-669] [name=me@company.com;mid=8;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - possible misconfigured client; requested ignored header in part BODY[HEADER.FIELDS (CONTENT-CLASS)]

2013-03-10 23:20:42,886 INFO [ImapSSLServer-670] [name=me@company.com;mid=8;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - copying message data from existing session: INBOX

2013-03-10 23:20:42,886 INFO [ImapSSLServer-670] [name=me@company.com;mid=8;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - selected folder INBOX

2013-03-10 23:20:42,926 WARN [ImapSSLServer-670] [name=me@company.com;mid=8;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - possible misconfigured client; requested ignored header in part BODY[HEADER.FIELDS (CONTENT-CLASS)]

2013-03-10 23:20:43,016 INFO [ImapSSLServer-665] [name=me@company.com;mid=8;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - copying message data from existing session: Drafts

2013-03-10 23:20:43,016 INFO [ImapSSLServer-665] [name=me@company.com;mid=8;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - selected folder Drafts

2013-03-10 23:20:43,083 INFO [ImapSSLServer-665] [name=me@company.com;mid=8;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - copying message data from existing session: Sent

2013-03-10 23:20:43,083 INFO [ImapSSLServer-665] [name=me@company.com;mid=8;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - selected folder Sent

2013-03-10 23:20:44,329 INFO [ImapSSLServer-669] [name=me@company.com;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - copying message data from existing session: Sent

2013-03-10 23:20:44,330 INFO [ImapSSLServer-669] [name=me@company.com;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - selected folder Sent

2013-03-10 23:20:44,608 WARN [ImapSSLServer-665] [name=me@company.com;mid=8;ip=8.0.0.0;ua=Mac OS X Mail/6.2 (1499);] imap - possible misconfigured client; requested ignored header in part BODY[HEADER.FIELDS (CONTENT-CLASS)]

This afternoon, when the reply arrived:
2013-03-11 14:12:24,053 INFO  [LmtpServer-33] [ip=5.0.0.0;] lmtp - Delivering message: size=5332 bytes, nrcpts=1, sender=prvs=77649b232=user@client.com, msgid=

2013-03-11 14:12:24,056 INFO [LmtpServer-33] [name=me@company.com;mid=8;ip=5.0.0.0;] mailop - Adding Message: id=138363, Message-ID=, parentId=-1, folderId=2, folderName=Inbox.

2013-03-11 14:12:24,058 INFO [LmtpServer-33] [name=me@company.com;mid=8;ip=5.0.0.0;] mailbox - merging conversation -138305 for references threading

2013-03-11 14:12:24,060 INFO [LmtpServer-33] [name=me@company.com;mid=8;ip=5.0.0.0;] mailop - Deleting Message (id=138305).

2013-03-11 14:12:24,090 INFO [LmtpServer-33] [] lmtp - Handler exiting normally

I'm not sure exactly what Zimbra is doing by merging the conversation and then deleting the original - but it's definitely not something we asked it to do or configured. I'm quite sure that last night's warnings in mailbox.log aren't related as the email and attachment were accessible fine to multiple computers in the Sent folder this morning.
Can anyone else here help shed some light on this odd situation? :confused:
Thanks,
BB

Disappearing emails tied to conversations

Posted: Mon Mar 11, 2013 11:27 pm
by spsohk
I also experience exact the same problem but don't know why, anyone here can help?
I've done the follow but problem not getting fixed:

1. I upgraded server from 8.0.0 to 8.0.2

2. Disable the conversation feature from all classes and users

Disappearing emails tied to conversations

Posted: Wed Mar 13, 2013 4:34 am
by bb101
Glad to hear it isn't just us with the issue then. I had a colleague complain to me a couple of months back about an email that had 'disappeared' and thought he must have just deleted it. Having grepped the previous week's mailbox.logs for "merging conversation", no other instances appear which makes me think it might happen in isolated cases.
Isolated or not, the end result of this bug is that individual emails are purged from mailboxes in a seemingly random fashion without any request from the user - quite a major bug in my book!
BB

Disappearing emails tied to conversations

Posted: Wed Mar 13, 2013 6:05 am
by phoenix
[quote user="bb101"]Isolated or not, the end result of this bug is that individual emails are purged from mailboxes in a seemingly random fashion without any request from the user - quite a major bug in my book![/QUOTE]Then you had better file a report in bugzilla, it's not a 'bug' nor will it get fixed until a report is filed (search first to see if a report is already filed).

Disappearing emails tied to conversations

Posted: Thu Mar 21, 2013 8:05 am
by bb101
Just to update everyone - we raised the issue with VMWare support and their engineers had a look into it. Apparently it was a bug with conversation merging and it has been fixed in 8.0.3.
Further details on the bug can be found at Bug 79571 – Conversation merge deletes messages containing the same ID as a virtual conversation