Page 1 of 1

MoveBlobRequests - Anyone used that?

Posted: Mon Aug 12, 2013 10:46 am
by speno
I'm interested in consolidating some message stores on an old mailbox running 7.2.2. Looks like the SOAP MoveBlobRequests does that, but I'd be interested in hearing if anyone else has used it and what gotchas were encountered. Thanks.

MoveBlobRequests - Anyone used that?

Posted: Wed Aug 14, 2013 4:01 am
by 7531prashant
Not sure what exactly you trying to achieve. Do you want to move some accounts?

MoveBlobRequests - Anyone used that?

Posted: Wed Aug 14, 2013 7:50 am
by speno
[quote user="7531prashant"]Not sure what exactly you trying to achieve. Do you want to move some accounts?[/QUOTE]
I want to consolidate two messages stores into one store thus freeing a storage volume. This particular mailbox has a dozen primary message stores and has had thousands of accounts moved to other mailboxes. So, some of those message stores are a lot less full than they used to be. We can re-use those freed volumes elsewhere once they are emptied of blobs etc.

MoveBlobRequests - Anyone used that?

Posted: Thu Aug 15, 2013 5:08 pm
by speno
It's me again. I tried it today having requested it move blobs from an empty store to a non empty store. I didn't want to actually move anything for this test.
I observed Zimbra iterating over each account on the mailbox to find any blobs on the source store. Given that the store was empty, all I got was a bunch of 'hsm - Found no blobs that need to be moved.' entries in the mailbox.log along with some slow query warnings related to the search for blobs to move.
Next time, I may move blobs for reals. :-)

MoveBlobRequests - Anyone used that?

Posted: Fri Aug 23, 2013 6:32 am
by speno
I moved some blobs for real yesterday. I used this command to move 10GB of blobs at a go. I did this twice. I think it worked fine. I will do it again and again until my store is empty. I may just let it move all the blobs next instead of limiting it to 10GB.
% zmsoap -z MoveBlobsRequest @types=all @sourceVolumeIds=1 @destVolumeId=16 @maxBytes=10737418240


MoveBlobRequests - Anyone used that?

Posted: Mon Aug 26, 2013 2:56 pm
by speno
I did a MoveBlobsRequest with no size limit and it ran fine. However, some blobs did get left behind on the source Volume. I'm working with Zimbra support to determine what's going on there.

MoveBlobRequests - Anyone used that?

Posted: Wed Aug 28, 2013 4:05 pm
by speno
I still haven't been able to move those stuck blobs even when zimbraHsmPolicy was adjusted (cleared actually).
However, migrating an account that has stuck blobs, then purging it from the source mailbox does remove those blobs as expected.

MoveBlobRequests - Anyone used that?

Posted: Thu Aug 29, 2013 9:21 pm
by speno
So, nothing seems to work to move these stuck blobs. We've been advised to move them manually. I'll probably just migrate the accounts to other mailboxes rather than do that.
And maybe we'll have better luck when we try it on another source volume.