Page 1 of 1

sending mail gives me 554 5.7.1 Relay access denied

Posted: Thu Dec 12, 2013 6:42 am
by offerlam22
Hi all,
This is related to this issue:


but">http://www.zimbra.com/forums/administrators/67323-zimbra-wont-recive-mail.html
but
it was resolved and I thought i had everything going well but no.. I am reciving mail again but now i can't send mails. Not to be understood as in they get qued or something but in the sense that when i push send i get an error as described in the title..
I did some digging and it seems to be because im having multiple domains on my server.. I haven't had this problem before so it must be related to the dns and network changes i did somehow..
one article i found suggest me to unclick "enable auth" under MTA for the server in the admins console .. this on the other hand through this alert
Message: Error! Value for MTA Trusted Networks must contain local network interfaces: 172.16.99.248. 

Additional information about MTA Trusted Networks configuration can be found at http://wiki.zimbra.com/index.php?title=ZimbraMtaMyNetworks. Error code: AjxException.INVALID_PARAM Method: ZaServerController.prototype.validateMyNetworks

How should i proceede with this error?
here is the edited version of the original error message:
method:	[unknown]

msg: Invalid address: XX@YYYYYY.dk. com.zimbra.cs.mailbox.MailSender$SafeSendFailedException: MESSAGE_NOT_DELIVERED; chained exception is: com.zimbra.cs.mailclient.smtp.InvalidRecipientException: RCPT failed: Invalid recipient XX@YYYYYY.dk: 554 5.7.1 : Relay access denied

code: mail.SEND_ABORTED_ADDRESS_FAILURE

detail: soap:Sender

trace: qtp759932786-283:https://172.16.99.248:443/service/soap/SendMsgRequest:1386849053704:0569fb4f68072fc4

request:

Body: {

SendMsgRequest: {

_jsns: "urn:zimbraMail",

m: {

e: [

// [0]:

{

a: "XX@YYYYYY.dk",

t: "t"

},

// [1]:

{

a: "my@email.dk",

p: "Casper A.. Jensen",

t: "f"

}

],

idnt: "0e4aa986-9293-41a7-8f82-4b48f8334e1f",

irt: {

_content: "<8B815910-00CC-4E24-BB07-B135357F4E55@medas.dk>"

},

mp: [

// [0]:

{

ct: "multipart/alternative",

mp: [

// [0]:

{

content: {

_content: "bare til information

SÃ¥ virker min mail igen... pyha..


----- Original meddelelse -----
I figured everything from here on is not important

any suggestion would appriciated!!
Thanks
Casper

sending mail gives me 554 5.7.1 Relay access denied

Posted: Thu Dec 12, 2013 6:55 am
by bdial
what does the following command produce


zmprov gs your.server.dk | grep -i zimbraMtaMyNetworks


it should at the bare minimum have 127.0.0.0/8 and the subnet of your zimbra servers ip, in this case probably 172.16.99.0/24

sending mail gives me 554 5.7.1 Relay access denied

Posted: Thu Dec 12, 2013 8:25 am
by offerlam22
Hi Bdial
AH! i see where you are going with this... the old network was 192.168.1.0/24 and the new is 172.16.99.0/24
the new network is not in the output and im guessing thats why its not working?
here is the output:
zimbraMtaMyNetworks: 127.0.0.0/8 192.168.1.0/24 [::1]/128 [fe80::]/64

if im right i don't know how to add 172.16.99.0/24 to the Mta list?
THANKS
Casper

sending mail gives me 554 5.7.1 Relay access denied

Posted: Thu Dec 12, 2013 8:33 am
by bdial
yeah that should do it. if you don't feel like messing with the command line you can do it via the web interface under the MTA section of the server config
may want to give it a couple of minutes sometimes those changes to the mta configuration take a few minutes to get implemented

sending mail gives me 554 5.7.1 Relay access denied

Posted: Thu Dec 12, 2013 8:35 am
by offerlam22
I figured it out.. it was in the same admin webpage as where i wanted to turn off auth...
not the output look likes this:
zimbraMtaMyNetworks: 172.16.99.0/24 127.0.0.0/8 192.168.1.0/24 [::1]/128 [fe80::]/64

an everything seems to be working... :)
thanks for the push in the right direction :)