Page 2 of 3

Error transportfile when install zimbra 8.5beta2

Posted: Mon Jun 23, 2014 10:45 am
by quanah
As I stated previously, the variable has been moved from localconfig to LDAP. That means you need to use zmprov, not zmlocalconfig. You should never modify zmconfigd.cf.
"VAR" means the value is stored in LDAP. "LOCAL" means the value is stored in localconfig.
So what you want to do is:


zmprov mcf zimbraMtaSmtpSaslPasswordMaps lmdb:/opt/zimbra/conf/relay_password


Error transportfile when install zimbra 8.5beta2

Posted: Thu Jul 03, 2014 8:59 am
by 3436baroso
[quote user="quanah"]As I stated previously, the variable has been moved from localconfig to LDAP. That means you need to use zmprov, not zmlocalconfig. You should never modify zmconfigd.cf.
"VAR" means the value is stored in LDAP. "LOCAL" means the value is stored in localconfig.
So what you want to do is:


zmprov mcf zimbraMtaSmtpSaslPasswordMaps lmdb:/opt/zimbra/conf/relay_password

[/QUOTE]


Ok, now I understand that "lmdb:/opt/zimbra/conf/relay_password" is stored as zimbraMtaSmtpSaslPasswordMaps in LDAP.

I (think) got all the configuration right - I checked with "zmprov gacf".
But when I do "postfix reload" - and before even "zmcontrol stop/start" - Zimbra changes the the value of "smtp_sasl_password_maps" back to "hash:/opt/zimbra/conf/relay_password" in "/opt/zimbra/postfix/conf/main.cf".

So, Zimbra mus get the old value from somewhere else than LDAP!?
Just for now to make it work, I manually edited the "/opt/zimbra/postfix/conf/main.cf".
Is this a bug, or am I doing something wrong again?
Thanks for the help!

Error transportfile when install zimbra 8.5beta2

Posted: Thu Jul 03, 2014 12:46 pm
by quanah
I realized since you upgraded an actual node with that value set, it is set at the server level rather than the global level.


zmprov gs `zmhostname` zimbraMtaSmtpSaslPasswordMaps


Should show it set with the hash value. You can update that to the LMDB value with:


zmprov ms `zmhostname` zimbraMtaSmtpSaslPasswordMaps lmdb:/opt/zimbra/conf/relay_password


Error transportfile when install zimbra 8.5beta2

Posted: Thu Jul 03, 2014 3:05 pm
by 3436baroso
[quote user="quanah"]I realized since you upgraded an actual node with that value set, it is set at the server level rather than the global level.


zmprov gs `zmhostname` zimbraMtaSmtpSaslPasswordMaps


Should show it set with the hash value. You can update that to the LMDB value with:


zmprov ms `zmhostname` zimbraMtaSmtpSaslPasswordMaps lmdb:/opt/zimbra/conf/relay_password

[/QUOTE]


You're the man, it works beautifully, even after a reboot!!!
Thanks for your help!!!

Error transportfile when install zimbra 8.5beta2

Posted: Tue Jul 15, 2014 10:30 am
by JiCiT
Is there a similar command for smtp_generic_maps in beta 3? I've tried both ms and mcf commands to zmprov and both return an error "zimbraMtaSmtpGenericMaps: attribute type undefined".

Error transportfile when install zimbra 8.5beta2

Posted: Tue Jul 15, 2014 10:51 am
by quanah
No one has ever requested the ability to customize that field, so there's currently no key for configuring it. Please file a bug in the Zimbra bugzilla, with a specific use case, under the ZCS/ MTA category.
--Quanah

Error transportfile when install zimbra 8.5beta2

Posted: Tue Jul 15, 2014 4:37 pm
by chauvetp
[quote user="quanah"]I would also note that generally all reasons to customize the postfix installation in an unsupported method are no longer necessary with 8.5. I.e., there are supported ways to do most everything in 8.5. If you can better explain what you are trying to accomplish, I can point you at the relevant how to.[/QUOTE]
Actually Quanah, I hope you don't mind if I take you up on that offer. We're not on 8.5 yet, but I'll probably be testing it later this summer. What's the best way in 8.5 to do mail routing for domains to bypass MX records? For example, when mail leaves our Zimbra server for certain internal (but non-Zimbra hosted) domains, we don't want it to go to the MX record, which would be a spam filtering gateway.
Currently we use the transport maps as the original sender was posting about:

subdomain.ourdomain.edu smtp:[otherserver.ourdomain.edu]
I know (based on your post) we can change over to the lmdb instead of hash database, but is there a better way for this in 8.5 (that is Zimbra aware so I don't have to watch for changes after updates)?
Thanks in advance!

Error transportfile when install zimbra 8.5beta2

Posted: Tue Jul 15, 2014 4:38 pm
by JiCiT
Thank you. Bug 93579.

Error transportfile when install zimbra 8.5beta2

Posted: Tue Jul 15, 2014 5:09 pm
by JiCiT
Sorry, earlier I'd missed the question about what it is I'm trying to do. I have situation somewhat similar to chauvetp. I'm forwarding mail for specific aliases/users (I'm not sure what the right term is) to a sub-domain like:
alais1@domain.com alias1@sub.domain.com

alais2@domain.com alias2@sub.domain.com

Error transportfile when install zimbra 8.5beta2

Posted: Fri Jul 18, 2014 6:24 pm
by quanah
@chauvetp:
Specifically, what postconf attributes are you editing? ;)