Page 1 of 2


Posted: Thu Feb 18, 2010 12:18 pm
by ericortego
How do you troubleshoot zimlets?
I've had a zimbra support ticket open for two weeks now and all that they do is remove the zimlet and ask me to try again. Over and over without any results.
I don't get any errors in the mailbox.log but the zimlets will just not display.
I have been using these zimlets for a couple years with no problems until version 6.
I cannot find any information on how to troubleshoot a zimlet. Is there a verbose mode I can put it into? Is there some way I can modify it to be more verbose? Is there some magic that can be done to see what the problem is? I am seriously at my wits end. This is a production system and I am seriously worried about the state of the upgrade.
I've read this: ZCS 6.0:Zimlet Developers Guide:Troubleshooting - Zimbra :: Wiki
But that doesn't exactly give me much direction.


Posted: Thu Feb 18, 2010 1:02 pm
by uxbod
Perhaps you could provide some background to which zimlet and the issues you are experiencing ?


Posted: Thu Feb 18, 2010 2:01 pm
by ericortego
I am just interested in breaking down the problem and being capable of troubleshooting it myself now. It should make no difference if it is this particular zimlet I am having trouble with or some other; zimbra_samba & zimbra_posixaccount are the ones I'd like working again.
I am not even confident that those in particular are the cause of the fact that they will not display because they have not been the only ones to go missing. This system has some serious trouble going on since the upgrade and it seems to manifest by refusing to display zimlets even though they install without any errors.
The upgrade also seems to have broken smtp ssl ... dunno yet if they are related.


Posted: Thu Feb 18, 2010 2:32 pm
by y@w
I've been wondering the same thing while trying to fight through issues with Zimlets..

There's a few pages in the wiki and documentation, but nothing comprehensive.
Of course, always check Firebug for any freebies.
Have a look at: Troubleshooting SalesForce Zimlet - Zimbra :: Wiki
It's specific to the SalesForce Zimlet, but may be helpful depending upon what you are running into.
If that gets you no where, you can add an account logger for Zimlets via zmprov. See: Zimbra CLI Commands
It would be very helpful if you could post any details of things you're struggling through as well.


Posted: Thu Feb 18, 2010 2:35 pm
by y@w
Also, a Zimlet problem won't affect SMTP over SSL.
There have been a few people with issues with GoDaddy certificates being lost during upgrades to 6.0, but I'm fairly certain nothing would work if that was the case..


Posted: Thu Feb 18, 2010 3:09 pm
by ericortego
Background info:

I've been running a basic 50 user zimbra install since 4 series.

Sometime in series 5 I extended the ldap schema, access list and indexes in and also installed the samba & posix extensions. Every upgrade since has just worked. That is until I tried 6.0.1.
After the upgrade several components were missing from the admin interface certificates, backup, ACL, samba, posix, etc...
Removing and reinstalling the missing ones didn't seem to help any nor were any errors that I can find being generated in the logs.
But when we removed all zimlets and installed them one at a time several finally began showing up again. Then one was installed which caused the others to go missing. So we uninstalled them all again and installed them each one at a time with the exception of the apparent problem one(com_zimbra_domainadmin). This kept all of the core zimlets in the interface but still the posix & samba ones do not display.
Durring the last undeploy redeploy cycle, deploying com_zimbra_license would cause the entire admin interface to stick at "Loading..." after login.
This seemingly was caused by the samba zimlet being installed before it. Or as best we can tell since all we think we did to finally get it installed and working was remove just those and redeploy com_zimbra_license. Reinstalling the samba one afterwards doesn't hang the login but still doesn't work...all of this with no sign of an error to be found in the logs....sigh.


Posted: Thu Feb 18, 2010 3:25 pm
by sposetti
One thing you can do is set the zimlet logging to "DEBUG". That will give you more messages to mailbox.log.
Edit {zcs-install-dir}/conf/
Add the following line (to the bottom):

Restart your server.


Posted: Thu Feb 18, 2010 4:00 pm
by ericortego
Well that got me all excited but at least for these two zimlets I don't seem to get a shred of extra information. Just the same old:
2010-02-18 15:55:37,585 INFO  [] mailbox - FileUploadServlet received Upload: {}

2010-02-18 15:55:37,599 INFO [] soap - DeployZimletRequest

2010-02-18 15:55:37,694 INFO [Thread-278] [] zimlet - Deploying Zimlet zimbra_samba in LDAP.

2010-02-18 15:55:37,803 INFO [Thread-278] [] zimlet - Installing Zimlet zimbra_samba on this host.

2010-02-18 15:55:37,805 INFO [Thread-278] [] zimlet - Upgrading Zimlet zimbra_samba to 6.0.3

2010-02-18 15:55:37,971 INFO [Thread-278] [] zimlet - Installing Zimlet config for zimbra_samba

2010-02-18 15:55:38,075 INFO [Thread-278] [] zimlet - Enabling Zimlet zimbra_samba


Posted: Fri Feb 19, 2010 9:07 am
by sposetti
Ok. Real quick step back:
1) You have a bunch of zimlets and two of them are not showing in the zimbra web client (zimbra_samba and com_zimbra_license)

2) You use the admin console to deploy and the zimlets appear to deploy (they are listed as deployed in the admin interface)

3) When you use the zimbra web client, they don't show. And no error messages in the logs
Are you using Firefox? Anything error messages (on MacOS, in the "Window > Error Console" and on Windows "Tools > Error Console")?


Posted: Fri Feb 19, 2010 10:44 am
by ericortego
1. Initially there were more than that missing, currently it is only affecting zimbra_samba & zimbra_posixaccount
2. Most zimlets were deployed on the commandline via zmzimletctl but I did try through the admin console a couple of times.
3. Correct though I have now discovered errors that are not being presented in the zimbra logs by using firebug and IE8's profiler.
In firebug I see error:
e is undefined

[Break on this error] r=e[c]
That section is an if statement where the undefined error is the last line r=e[c]


var s=Dwt.getBounds(u);

var r=this._components[c];


var e=this._views[this._currentView];



In Internet Explorer's profiler I see:
Expected identifier, string or number  Zimlets-nodev_all.js.zgz.js?v=100202213223, line 17525 character 211