[SOLVED] Open Relay amavis warnings in zimbra.log

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
Simulcast
Posts: 15
Joined: Sat Sep 13, 2014 2:23 am

[SOLVED] Open Relay amavis warnings in zimbra.log

Postby Simulcast » Wed Dec 28, 2011 9:39 pm

For anyone else looking at this, for the obvious reason, it seems you will continue to see the Amavis "Open relay?" log entries -- even when Global and Server Webmail MTA Hostnames settings are "localhost" or the simply same as instructed above -- when mail is sent by an sasl authenticated sender instead of the Web interface.
Ie: Amavis doesn't seem to know about the permit_sasl_authenticated smtpd_recipient_restrictions.


maschimidt
Advanced member
Advanced member
Posts: 64
Joined: Sat Sep 13, 2014 12:11 am

[SOLVED] Open Relay amavis warnings in zimbra.log

Postby maschimidt » Thu Oct 03, 2013 2:56 pm

Hi Elliot, you solved you problem about log Open relay???

Thanks..
ewilen
Elite member
Elite member
Posts: 1429
Joined: Fri Sep 12, 2014 11:34 pm

[SOLVED] Open Relay amavis warnings in zimbra.log

Postby ewilen » Sat Oct 05, 2013 9:27 pm

Yes, as I described in the opening post. If you're having the problem and you have a single server install, please check the settings described there. If that doesn't help, you should post details.
By the way, you should put your ZCS version in your profile. See my signature.
maschimidt
Advanced member
Advanced member
Posts: 64
Joined: Sat Sep 13, 2014 12:11 am

[SOLVED] Open Relay amavis warnings in zimbra.log

Postby maschimidt » Mon Oct 07, 2013 9:11 am

Hello Elliot

Thanks for the feedback, I have done the update of my version of zimbra

Release 8.0.4_GA_5737.RHEL6_64_20130524120036 RHEL6_64 FOSS edition
So the way you mention I changed the config's Global Settings> MTA I configured as localhost

But I did not succeed
Need more information?
ewilen
Elite member
Elite member
Posts: 1429
Joined: Fri Sep 12, 2014 11:34 pm

[SOLVED] Open Relay amavis warnings in zimbra.log

Postby ewilen » Mon Oct 07, 2013 9:51 am

Please put your Zimbra version in your profile; don't just post it here. It'll save everyone a lot of time. See the instructions linked in my sig. Thanks.
Does [BConfiguration > Servers > servername >MTA > Web Mail MTA Hostnames match the setting under Global Settings > MTA?
maschimidt
Advanced member
Advanced member
Posts: 64
Joined: Sat Sep 13, 2014 12:11 am

[SOLVED] Open Relay amavis warnings in zimbra.log

Postby maschimidt » Mon Oct 07, 2013 11:16 am

[quote user="ewilen"]Please put your Zimbra version in your profile; don't just post it here. It'll save everyone a lot of time. See the instructions linked in my sig. Thanks.
Does [BConfiguration > Servers > servername >MTA > Web Mail MTA Hostnames match the setting under Global Settings > MTA?[/QUOTE]
Hello Elliot

Already made ​​the change to my Profile ..

So I have done to change both to localhost

but had no effect

:/
ewilen
Elite member
Elite member
Posts: 1429
Joined: Fri Sep 12, 2014 11:34 pm

[SOLVED] Open Relay amavis warnings in zimbra.log

Postby ewilen » Mon Oct 07, 2013 12:58 pm

Sorry about that--after the forum change, things look different.
I'm also sorry that making the change didn't help. At this point, I'd try restarting Zimbra and making sure that the change is still there after restart. But I don't know if it would help. My original post concerned ZCS 6, and you're on 8. So if that doesn't help, I'm afraid I'm out of ideas.
msragab
Posts: 2
Joined: Sat Sep 13, 2014 3:27 am

[SOLVED] Open Relay amavis warnings in zimbra.log

Postby msragab » Sat Feb 15, 2014 1:39 am

Dears,

This is tested.

For Amavis 2.6.4 and later. to removes log's output: Open relay? Nonlocal recips but not originating

Add the following to your ~zimbra/conf/amavisd.conf.in
@mynetworks = qw( 127.0.0.0/8 yourip/32 ); // or whatever your mynetworks value is

@client_ipaddr_policy = map { $_ => 'MYNETS' } @mynetworks;
Then restart Amavis: zmavavisctl reload
Best Regards,

Return to “Administrators”

Who is online

Users browsing this forum: No registered users and 21 guests