Upgrade ETCH 6.0.2 to Lenny 32bit

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
Centro
Advanced member
Advanced member
Posts: 54
Joined: Sat Sep 13, 2014 12:24 am

Upgrade ETCH 6.0.2 to Lenny 32bit

Postby Centro » Tue Nov 24, 2009 12:52 am

Hi,
where can i find a good doco for upgrading our ETCH Zimbra Server to Lenny? - I tried:
simple upgrade from ETCH to Lenny - Libc6 error

newinstall lenny and install clean install Zimbra 6 -> Restore /opt/zimbra - Error
nothing helpfull.
I would to be pleased for a good solution
Greetz Centro


Centro
Advanced member
Advanced member
Posts: 54
Joined: Sat Sep 13, 2014 12:24 am

Upgrade ETCH 6.0.2 to Lenny 32bit

Postby Centro » Tue Nov 24, 2009 2:04 am

I will try this LINK
Centro
Advanced member
Advanced member
Posts: 54
Joined: Sat Sep 13, 2014 12:24 am

Upgrade ETCH 6.0.2 to Lenny 32bit

Postby Centro » Tue Nov 24, 2009 4:23 am

Ok, with this problem it would not work! :(
Is here nobody at the forum who upgradet to lenny? i cant believe!
Greetz Centro
dspillett
Advanced member
Advanced member
Posts: 84
Joined: Fri Sep 12, 2014 10:29 pm

Upgrade ETCH 6.0.2 to Lenny 32bit

Postby dspillett » Wed Nov 25, 2009 5:04 am

The "new install and rsync from backup copy" linked above is the technique I would use, though I have not yet done this. Upgrading my Etch installs to Lenny is something I have yet to find time to do, as it isn't urgent until Etch comes close to losing its "old stable" status and therefore not getting timely security updates. In fact I might move to an Ubuntu LTS release rather than Lenny for my Zimbra installs, but that is getting off-topic...
As for your error when trying this method, you need to give much more detail than "newinstall lenny and install clean install Zimbra 6 -> Restore /opt/zimbra - Error" if you want anyone to be able to give you useful advice. What error(s) did you get and when? Did you check any log files to see if there was more detailed information about your error? The only thing anyone can suggest without more detail about the problem you had is "try again, and make sure that the version you install is exactly the same as the one you are currently running".
Centro
Advanced member
Advanced member
Posts: 54
Joined: Sat Sep 13, 2014 12:24 am

Upgrade ETCH 6.0.2 to Lenny 32bit

Postby Centro » Wed Nov 25, 2009 5:29 am

Nice and long post, but no basic solution! :o
My Problem is the same as it´s posted in many other threads. PERL!

The other problem is dpkg and libc6 but this is not my main problem. I tried it with the lenny and the etch packages, before and after the dist-upgrade and nothing i can do with my libc6 and dpkg!
I got many perl errors, with and without an yes at the question to check the database in the install script.

Sure, i can install perl 5.8.8.8, but this is no real solution, i will use a normal lenny which i can upgrade by aptitude without afraid about upgrading perl to 5.10.
I tried today a change from ETCH 6.0.2 to Centos 5.4 6.0.3 and it looks great for the first look :cool:

I think i will run it under Centos if it will work here.
Yes, Centos is using 5.8.8.8 Perl so all seems ok.
Maybe i will try it one more time on a lenny testsystem, but for the moment i think i change the os to Centos 5.4.
Greetz Centro

Return to “Administrators”

Who is online

Users browsing this forum: No registered users and 11 guests