Adjusting SMTP/milter timeout?

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
millerdc
Posts: 47
Joined: Fri Sep 12, 2014 11:49 pm

Adjusting SMTP/milter timeout?

Postby millerdc » Tue Mar 29, 2011 1:45 pm

Under ZCS 7.0.1 network I'm seeing an issue with 3rd party email clients smtp connections on slower networks and file attachments. There seems to be a timeout set to around two minutes on SMTP connections. I'm seeing the following error in the logs and on email clients when it takes over two minutes to send an email.


Mar 29 10:16:38 email postfix/cleanup[21031]: 6391C3536001: milter-reject: END-OF-MESSAGE from ip72-220-140-199.sd.sd.cox.net[72.220.140.199]: 4.7.1 Service unavailable - try again later; from= to= proto=ESMTP helo=

Mar 29 10:16:38 email postfix/smtpd[18443]: disconnect from ip72-220-140-199.sd.sd.cox.net[72.220.140.199]
Now I have tested this on multiple speed connections and have ruled out that it is the size of attachment and email client. For example at home I get around 250K/sec to my work zimbra server. So I can send about a 15MB attachment with out getting the error. Anything longer goes past the timeout. From a faster net connection that gets about 2MB/sec I can send a 150MB attachment. What do I have to change to increase the timeout on smtp connections? Thanks.


FritzBrause
Advanced member
Advanced member
Posts: 173
Joined: Fri Sep 12, 2014 11:19 pm

Adjusting SMTP/milter timeout?

Postby FritzBrause » Tue Apr 05, 2011 10:21 am

... same issue here with 7.0.1. If I check the possible values with


zmlocalconfig | grep -i milter


I get something like


milter_bind_port = 0

milter_in_process_mode = false

milter_max_idle_seconds = 120

milter_max_scheduled_write_bytes = 1048576

milter_max_sessions = 20000

milter_min_threads = 20

milter_thread_keep_alive_time = 60

milter_write_chunk_size = 1024

milter_write_timeout = 10


which seem to be the default values. I'll test if changing filter_write_timeout to a higher value will give better results. Otherwise I'll file a bug report.
millerdc
Posts: 47
Joined: Fri Sep 12, 2014 11:49 pm

Adjusting SMTP/milter timeout?

Postby millerdc » Tue Apr 05, 2011 12:06 pm

I have an open case with zimbra on this issue too. They say they are going to test this in their lab and get back to me. I have sent them the link to this thread since you are seeing the same thing.
FritzBrause
Advanced member
Advanced member
Posts: 173
Joined: Fri Sep 12, 2014 11:19 pm

Adjusting SMTP/milter timeout?

Postby FritzBrause » Tue Apr 05, 2011 1:31 pm

I dug a little deeper. Please feel free to pass this on to Zimbra:
It seems that this issue occurs with SMTP / STARTTLS and SSL connections only. If I switched the SMTP connection to plain SMTP using no encryption the error didn't occur. I'll verify this by some more testing.
The messages in the log file support this suspicion:


Apr 5 13:11:37 de-dd-srv-1101 postfix/cleanup[9091]: warning: milter inet:127.0.0.1:7026: can't read SMFIC_HEADER reply packet header: Success

Apr 5 13:11:37 de-dd-srv-1101 postfix/cleanup[9091]: 2F266C74E51: milter-reject: END-OF-MESSAGE from de-ch-srv-1102.office.managedhosting.de[213.23.10.202]: 4.7.1 Service unavailable - try again later; from= to= proto=ESMTP helo=

Apr 5 13:11:42 de-dd-srv-1101 postfix/smtpd[9086]: disconnect from de-ch-srv-1102.office.managedhosting.de[213.23.10.202]


If you ask Google about "can't read SMFIC_HEADER reply packet header" there are a lot of answers pointing in our direction.
ppaixao
Posts: 20
Joined: Fri Sep 12, 2014 11:56 pm

Adjusting SMTP/milter timeout?

Postby ppaixao » Tue Apr 12, 2011 10:54 am

Hi all,
I've the same problem. Anyone knows how to solve?
Pedro Paixão
FritzBrause
Advanced member
Advanced member
Posts: 173
Joined: Fri Sep 12, 2014 11:19 pm

Adjusting SMTP/milter timeout?

Postby FritzBrause » Tue Apr 12, 2011 11:07 am

... you may want to try if


zmlocalconfig -e milter_thread_keep_alive_time=120

zmlocalconfig -e milter_write_timeout=30

zmcontrol restart


will ease the pain a bit. Depending on your message size this might help already.
millerdc
Posts: 47
Joined: Fri Sep 12, 2014 11:49 pm

Adjusting SMTP/milter timeout?

Postby millerdc » Tue Apr 12, 2011 11:48 am

Zimbra is still looking into the problem. I have been doing some tests myself. If I turn of the milter server I can send as large of an attachment as I want. We only allow authenticated and SSL encrypted connections to send mail. Turning it off is not an option for us. Well, neither is turning off milter since we use access control to distribution lists and milter server is required for it to work.
rajeshkodali
Advanced member
Advanced member
Posts: 95
Joined: Fri Sep 12, 2014 10:43 pm

Adjusting SMTP/milter timeout?

Postby rajeshkodali » Fri Apr 29, 2011 1:43 pm

Hi,
I am also facing the same problem with milter. Went back to old postfix model of restricting users to mail to DL.
gvillaran
Advanced member
Advanced member
Posts: 94
Joined: Fri Sep 12, 2014 11:21 pm

Adjusting SMTP/milter timeout?

Postby gvillaran » Sat Oct 01, 2011 8:25 am

i have the same problem, and i use the milter for DL aswell, hope this gets fixed soon, my thunderbird and outlook users started to complain about this.
gvillaran
Advanced member
Advanced member
Posts: 94
Joined: Fri Sep 12, 2014 11:21 pm

Adjusting SMTP/milter timeout?

Postby gvillaran » Wed Oct 12, 2011 12:53 pm

millerdc have you filled a bug report?
im trying to find it.

Return to “Administrators”

Who is online

Users browsing this forum: No registered users and 9 guests