Page 1 of 1

[SOLVED] Redirect "view account"

Posted: Mon Jun 27, 2011 7:20 pm
by theboina
Using Zimbra 7.1.1 on Ubuntu 10.04, when I click from the Administrator "View mail" from a certain user account, I redirected to an url: mydomain.com/xxxxx but not mail.mydomain.com/ . Then I go directly to the website.... not the zimbra server (DNS is configured to send you without the www to the corporate website).
What should I change in zimbra to send me mail.mydomain.com/xxx when i click in "view mail" for a certain user account in the administrator view (7071)?
Thx

[SOLVED] Redirect "view account"

Posted: Mon Jun 27, 2011 7:32 pm
by theboina
The Redirect is to:
mydomain.com/service/preauth/xxxx
And I need:
mail.mydomain.com/service/preauth/xxxxx
Thx

[SOLVED] Redirect "view account"

Posted: Tue Jun 28, 2011 5:17 am
by theboina
Any idea??

[SOLVED] Redirect "view account"

Posted: Tue Jun 28, 2011 5:45 am
by fyd
Hi boina, I guess that doesn't need anything more than setting up your zimbra server as mail.mydomain.com. It should be the fqdn of the server, and have proper dns entries.
Clicking view mail redirects you to something that is within your zimbra server, and it should give the zimbra server name that is in your normal login url.
Are you sure your /etc/hosts file is correct, and your zimbra hostname is all right?

[SOLVED] Redirect "view account"

Posted: Tue Jun 28, 2011 7:15 am
by theboina
The hostname is correct. I have a name for the Host fqdn, and five domains in zimbra.
When I click in view mail of account from a domain1 (not hostdomain...) , go to:
domain1.com/service/preauth/xxxx (no mail.domain1.com/service/xxx or
If">http://www.domain1.com/service...
If
view mail of account from domain2... go to:
domain2.com/service/preauth/xxx...
The url must be:http://www.domain2.com/service/xx.. or mail.domain2.com/service/xxx....
The problem is with the others domains in server (not with host domain...)
Any idea?
Thank you in advance

[SOLVED] Redirect "view account"

Posted: Tue Jun 28, 2011 7:41 am
by fyd
Okay. This particular domain must have a proper dns entry and should point 'mail.domain.com' to A record of your mail server. If yes then proceed with setting,
'Public service host name' and 'virtualhost' for this domain on your zimbra server. To do that,
login to zimbraAdmin at 7071, and search for the particular domain under 'domains'. Edit it, and under general information give Public service host name as 'mail.domain.com'. Then under virtual hosts give 'mail.domain.com' as a virtual host.
Now flush cache for this domain on server with ..

# su - zimbra

$ zmprov fc -a domain
I think this should do your thing. Lets hope so :)

[SOLVED] Redirect "view account"

Posted: Tue Jun 28, 2011 5:45 pm
by theboina
Perfect!!!!! It's works fine... The problem is in the Public service host name. There was "mydomain.com" not "mai.mydomain.com"....
Thx... (I love you...)
If you come to Spain and you like beer...call me :-)
Thx....

[SOLVED] Redirect "view account"

Posted: Wed Jun 29, 2011 12:31 am
by fyd
[quote user="theboina"]Perfect!!!!! It's works fine... The problem is in the Public service host name. There was "mydomain.com" not "mai.mydomain.com"....
Thx... (I love you...)
If you come to Spain and you like beer...call me :-)
Thx....[/QUOTE]
haha .. so glad I could make a friend. Thanks to zimbra ;)
And coming to spain, I would really love to do that. Looking forward to it. Good luck boina!